LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-24-2010, 01:26 AM   #1
morebass
LQ Newbie
 
Registered: Jan 2010
Location: Montana
Distribution: OpenBSD > Debian > Xubuntu
Posts: 4

Rep: Reputation: 0
Question Xubuntu 9.10 fresh install usb automount failure FAT: IO charset ISO-8859-1 not found


Hello everyone thanks for dropping by!

EDIT: I thought this info might help
Code:
allen@heavy:/etc$ uname -a  
Linux heavy 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC 2009 i686 GNU/Linux



I just recently installed Xubuntu 9.10 on my old acer Aspire 3000. Previously i was running Debian 5.something it was great and all but I wanted to try out the "New Hotness" that is Xubuntu.

The install went flawless and as far as Linux distro's go this is by far the most impressive. However, I have this problem with my USB storage devices not mounting.

When I plug them in they show up and everything looks like its about to work when I get this:

http://savenet.org/temp/error.png

A quick jaunt over to dmesg:

Code:
#
[ 2950.184072] usb 1-3: new high speed USB device using ehci_hcd and address 6
#
[ 2950.320178] usb 1-3: configuration #1 chosen from 1 choice
#
[ 2950.326192] scsi5 : SCSI emulation for USB Mass Storage devices
#
[ 2950.326513] usb-storage: device found at 6
#
[ 2950.326519] usb-storage: waiting for device to settle before scanning
#
[ 2955.324403] usb-storage: device scan complete
#
[ 2955.332682] scsi 5:0:0:0: Direct-Access     RIM      BlackBerry SD    0002 PQ: 0 ANSI: 0 CCS
#
[ 2955.333691] sd 5:0:0:0: Attached scsi generic sg2 type 0
#
[ 2955.358798] sd 5:0:0:0: [sdb] Attached SCSI removable disk
#
[ 2956.711129] sd 5:0:0:0: [sdb] 3970048 512-byte logical blocks: (2.03 GB/1.89 GiB)
#
[ 2956.711612] sd 5:0:0:0: [sdb] Assuming drive cache: write through
#
[ 2956.713930] sd 5:0:0:0: [sdb] Assuming drive cache: write through
#
[ 2956.713942]  sdb: sdb1
#
[ 2974.853408] FAT: IO charset ISO-8859-1 not found
#
[ 2974.887587] FAT: IO charset ISO-8859-1 not found

I dropped into ubuntu's irc and was suggested to try this:
Code:
#
Generating locales...
#
  en_AG.UTF-8... up-to-date
#
  en_AU.UTF-8... up-to-date
#
  en_BW.UTF-8... up-to-date
#
  en_CA.UTF-8... up-to-date
#
  en_DK.UTF-8... up-to-date
#
  en_GB.UTF-8... up-to-date
#
  en_HK.UTF-8... up-to-date
#
  en_IE.UTF-8... up-to-date
#
  en_IN.UTF-8... up-to-date
#
  en_NG.UTF-8... up-to-date
#
  en_NZ.UTF-8... up-to-date
#
  en_PH.UTF-8... up-to-date
#
  en_SG.UTF-8... up-to-date
#
  en_US.ISO-8859-1... up-to-date
#
  en_US.UTF-8... up-to-date
#
  en_ZA.UTF-8... up-to-date
#
  en_ZW.UTF-8... up-to-date
#
Generation complete.

I've been all over google, in multiple irc rooms asking questions, and I cant seem to get anywhere.

I can mount the devices manually with mount -t auto /dev/sdb1 /mountpoint

but... you know I'm lazy and id rather they mount themselves when I plug them in.



So if anyone can shed some lite on my problem I'd be inclined to fax you over a picture of your favorite beer!


~ allen

Last edited by morebass; 01-24-2010 at 01:33 AM. Reason: update info
 
Old 01-25-2010, 10:22 AM   #2
sumeet inani
Member
 
Registered: Oct 2008
Posts: 895
Blog Entries: 26

Rep: Reputation: 48
(1)If parted comand available by default then
#parted <device>
(parted)check partition

(2)You can check the drive with gparted {"#apt-get install gparted" (without double quotes obviously)will get you the needed software.}
Maybe the partition type is wrongly mentioned in USB.
If USB is empty or contains useless data then create a new disklabel & then partitions.


(3)There are also command you can try such as
vfat.fsck , badblocks

(4)Don't you think
Code:
[ 2956.711129] sd 5:0:0:0: [sdb] 3970048 512-byte logical blocks: (2.03 GB/1.89 GiB)
looks wrong.

Last edited by sumeet inani; 01-25-2010 at 10:30 AM.
 
Old 01-25-2010, 02:50 PM   #3
morebass
LQ Newbie
 
Registered: Jan 2010
Location: Montana
Distribution: OpenBSD > Debian > Xubuntu
Posts: 4

Original Poster
Rep: Reputation: 0
Talking

Quote:
Originally Posted by sumeet inani View Post
(4)Don't you think
Code:
[ 2956.711129] sd 5:0:0:0: [sdb] 3970048 512-byte logical blocks: (2.03 GB/1.89 GiB)
looks wrong.
I don't think there is anything wrong with this device, it works on other windows machines, other linux machines, and even other installs of 9.10 that came from the same cd that this machine is running ...

I believe the problem lies somewhere in the process of automounting devices. I tried to disable Volume Management in Thunar but I still get the popup image stated in the previous post.

Here is the information again from dmesg, when I plug in my blackberry:
Code:
[81509.504042] usb 1-4: new high speed USB device using ehci_hcd and address 6
[81509.637096] usb 1-4: configuration #1 chosen from 1 choice
[81509.646198] scsi3 : SCSI emulation for USB Mass Storage devices
[81509.646418] usb-storage: device found at 6
[81509.646423] usb-storage: waiting for device to settle before scanning
[81514.644340] usb-storage: device scan complete
[81514.646188] scsi 3:0:0:0: Direct-Access     RIM      BlackBerry SD    0002 PQ: 0 ANSI: 0 CCS
[81514.647109] sd 3:0:0:0: Attached scsi generic sg2 type 0
[81514.687382] sd 3:0:0:0: [sdb] Attached SCSI removable disk
[81523.603839] sd 3:0:0:0: [sdb] 3970048 512-byte logical blocks: (2.03 GB/1.89 GiB)
[81523.604468] sd 3:0:0:0: [sdb] Assuming drive cache: write through
[81523.606192] sd 3:0:0:0: [sdb] Assuming drive cache: write through
[81523.606203]  sdb: sdb1
[81525.014500] FAT: IO charset ISO-8859-1 not found
[81525.051810] FAT: IO charset ISO-8859-1 not found

Which results in nothing, so I use this command to mount it manually:

Code:
allen@heavy:~$ sudo mount -t auto /dev/sdb1 /home/allen/Desktop/
[sudo] password for allen: 
allen@heavy:~$
$mount shows

Code:
allen@heavy:~$ mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/sda6 on /home type ext4 (rw)
/dev/sdb1 on /home/allen/Desktop type vfat (rw)

I gave parted a shot and this is what it told me:
Code:
allen@heavy:~$ sudo parted /dev/sdb
GNU Parted 1.8.8.1.159-1e0e
Using /dev/sdb
Welcome to GNU Parted! Type 'help' to view a list of commands.
                                                                  
(parted) print                                                            
Model: RIM BlackBerry SD (scsi)
Disk /dev/sdb: 2033MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      4225kB  2033MB  2028MB  primary  fat16

(parted) check 1                                                          
(parted) q                                                                
allen@heavy:~$

At this point it isn't that big of a deal since I can mount manually, I just wanted this install to be the one that everything just works
 
Old 01-29-2010, 04:45 AM   #4
sumeet inani
Member
 
Registered: Oct 2008
Posts: 895
Blog Entries: 26

Rep: Reputation: 48
evo2 gave suggestion which can help a little
Because you don't have to be root to mount & type less

Add to /etc/fstab
Code:
/dev/sdb1	/pd	 vfat    defaults,user,noauto 0 0
also comment ( i.e. prefix #) any other line starting with /dev/sdb1.
Here mountpoint is folder /pd.You can choose yours & edit line correspondingly.
To mount
$mount /pd
is enough.
A small explanation
zeroes at end means no backup & check of USB.
noauto means system does not attempt to mount.Defaults means root can mount while user means anybody can.

i think
2.03GB = 2.03 x 10^9 bytes
approximately equal to 1.89 GiB = 1.89 x 1024 X 1024 x 1024 bytes) which I had overlooked.So nothing wrong .

You can also post
vfat.fsck , badblocks , dosfsck command outputs
so that someone more knowledgeable can suggest.


This is all I know.
Thank You.

Last edited by sumeet inani; 01-29-2010 at 05:25 AM.
 
Old 03-02-2010, 02:24 PM   #5
morebass
LQ Newbie
 
Registered: Jan 2010
Location: Montana
Distribution: OpenBSD > Debian > Xubuntu
Posts: 4

Original Poster
Rep: Reputation: 0
[SOLVED] usb automount failure FAT: IO charset ISO-8859-1 not foun

Just wanted to update this thread I finally figured out what my problem was.

During the initial installation via expert mode I was setting the locale to just "en_US"...

I tried a clean install not using expert mode and everything worked fine.

SO, I tried another expert mode install again, this time choosing the en_us-UTF-8 option when setting up the locales. Now everything works flawless!

Hope that helps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slack 13, failure to automount usb thumbdrive and cdroms wufo Slackware 3 12-15-2009 09:49 AM
Xubuntu: Grub Error 2 after fresh install netjack Ubuntu 1 01-11-2009 07:09 AM
Info:Switching console charset mapping to ISO-8859 Rixcz Linux - Software 0 10-06-2006 10:14 AM
Suse and ISO-8859-15 charset badbunny Linux - Newbie 2 10-21-2005 04:44 AM
gnome-terminal wrong charset (ANSI_X3.4-1986 not ISO-8859-1). omes Linux - General 1 06-10-2005 10:55 PM


All times are GMT -5. The time now is 06:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration