LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-22-2010, 06:36 PM   #1
wiliamvw
Member
 
Registered: Mar 2008
Location: Pittsburgh
Distribution: openSUSE 11.4 on GoBooks
Posts: 112

Rep: Reputation: 15
Question xterm not recognizing files


openSUSE 10.2 KDE GoBook III zsh (but same with bash)

Well, I'm not really a newbie, but problem seems so impossible that must be something very fundamental that I'm overlooking.

As root and in xterm and in home directory, key-in:
ls Documents [gives: .directory (in black) and LA1b222.odt (in green)]
then: cat LA1b222.odt (gives: "No such file or directory")

Have tried various combinations and also cat on files listed in ~/Desktop and with same results ("No such file or directory")
As the file it says doesn't exist, it had just previously displayed on the very line above, I assume I'm overlooking something very basic, but can't determine what it is.

I am able to pull-up files from the computer's own system (proc, etc, so-forth), but NOTHING from my home directories whether /root or /user.

Some insight appreciated as wish to invoke vim and it (vi filename) won't come up for vi either.
 
Old 03-22-2010, 06:45 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,983
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Ummm ... you don't really want to cat an odt file; but that aside:
it *should* be
cat Documents/LA1b222.odt
if it's not in the current working directory but in Documents (as you
suggested yourself just one line above) ... ;}



Cheers,
Tink
 
Old 03-23-2010, 03:53 PM   #3
wiliamvw
Member
 
Registered: Mar 2008
Location: Pittsburgh
Distribution: openSUSE 11.4 on GoBooks
Posts: 112

Original Poster
Rep: Reputation: 15
Thumbs up tried that as well

Appreciate your taking time to reply Tink, but that was one of the combinations that I had tried -- as well as full path on both the ~/Documents and the ~/Desktop entries when I tried to call-up each of the listed files, and constantly was checking that I was in home directory as my working directory (the use of cat was only a convenience after trying head and less and some others). I suppose it may be an OS problem in tieing in to the xterm, but 10.2 has always been reliable which why I went back to it.
 
Old 03-23-2010, 05:05 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,983
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
The fact that you're talking about "root and user" makes me wonder whether you're
maybe sitting in a users home (e.g., /home/wiliam) as the user root, and issuing
ls ~/Documents or ~/Desktop ... that would certainly explain why you're not seeing
the file if wiliam downloaded or created the file, and root is trying to cat it.

I very much doubt that this problem has to do with xterm or with the version of
SuSE you're using, but rather is a user behaviour thing.


Cheers,
Tink
 
Old 03-27-2010, 01:13 PM   #5
wiliamvw
Member
 
Registered: Mar 2008
Location: Pittsburgh
Distribution: openSUSE 11.4 on GoBooks
Posts: 112

Original Poster
Rep: Reputation: 15
Unhappy tried various statuses

Thanks again Tink for thoughtful input. After installing more file handling programs, including locate, I tried again as simple user (prompt sign indicates am considered to be plain user) and still no access to files in home directories. I had also put a copy of my chief file of interest into /root home, but still no good even when did switch to being root (indeed, there is lock symbol on /root listing on directory options when am operating as simple user).
Am going through the book "Bash to Z Shell" to try to find-out just what I can do to solve this, but so far no real progress (well, I am learning some long delayed instructions).
Any additional thoughts greatly appreciated -- test and eliminate is my most operative strategy at the moment.
 
Old 03-27-2010, 02:30 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,983
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
William, I still don't think that what you're facing is a
problem of bash or the xterm. Next thing I'd think of is
having a filesystem check performed on the partitions/
volumes in question ...
 
Old 03-29-2010, 02:32 PM   #7
wiliamvw
Member
 
Registered: Mar 2008
Location: Pittsburgh
Distribution: openSUSE 11.4 on GoBooks
Posts: 112

Original Poster
Rep: Reputation: 15
Unhappy filesystem check on PARTITIONS?

Am not sure how to check partitions relative to the filesystem except that the default file system is listed in the partition menu as being the one used.
Did fix a setting for home directory that was on "no" put it back to the default/recommended "yes" -- but made no difference.
Checking why "autofs" wasn't enabled (though doubt it would change much if was enabled) got message that it not configured and "files nis" does not provide a mount point. Paging though /etc/init.d/autofs shows nis at only two locations and both read the same:
function getmounts ()
{
for scheme in $(getschemes) ; do
case "$scheme" in
files)
getmounts_files
;;
nis)
getmounts_nis
;;
nisplus)
getmounts_nisplus
;;
/dap)
getmounts_dap
;;
esac
done

I recognize the C++ programing but not familiar with the syntax to be used here to change some line to what required to give "nis" the necessary mount point. This definitely is getting complicated, but will try to work through any suggestions provided.
Am attemting to install odt2txt program from freshmeat which wasn't available on the OS for some reason. Not sure what is meant by run make "in source directory" so trying couple things since won't install directly.

Last edited by wiliamvw; 04-23-2010 at 04:27 PM. Reason: missing program
 
  


Reply

Tags
shell, suse10, xterm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache 2 not recognizing .shtml files lilmike Linux - Newbie 21 11-10-2009 05:02 PM
Mandriva 2009 not recognizing removable media files CD/DVD etc. KFL Linux - Newbie 2 01-08-2009 03:00 AM
Hard drive installation error, not recognizing ISO files PDAOmega Fedora - Installation 2 07-24-2005 11:24 PM
Redhat 9.0 not recognizing executable files BenRichards Linux - Software 2 09-17-2004 03:25 PM
Recognizing windows 2000 hard drive files in linux eelee Linux - Newbie 6 01-02-2002 01:23 AM


All times are GMT -5. The time now is 12:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration