LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-08-2005, 02:24 PM   #1
furcatus
Member
 
Registered: Dec 2005
Location: The Netherlands
Distribution: Ubuntu 6.06 Dapper Drake
Posts: 39

Rep: Reputation: 15
Xserver problems


Hi,
I have a problem with my xserver, When I start my computer it loads KDE but the screen is much bigger than my monitor (doesn't fit).

Here is my XF86config-4 file

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri" # direct rendering
EndSection

Section "DRI"
Mode 0666
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us_intl"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Dell"
ModelName "Dell E172FP"
HorizSync 31.0-80.0
VertRefresh 56.0-76.0

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "Intel Corporation"
BoardName "Intel 865"
Driver "i810"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Virtual 800 600
EndSubsection

Subsection "Display"
Depth 15
Virtual 800 600
EndSubsection

Subsection "Display"
Depth 16
Virtual 800 600
EndSubsection

Subsection "Display"
Depth 24
Virtual 800 600
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

Can anyone tell how I can solve this problem?

tnx
 
Old 12-08-2005, 04:20 PM   #2
Oliv'
Senior Member
 
Registered: Jan 2004
Location: Montpellier (France)
Distribution: Gentoo
Posts: 1,014

Rep: Reputation: 36
Hi,
that's probably a "modeline" problem. I think you'll be able to solve it with xvidtune utility.

Oliv'
 
Old 12-09-2005, 02:46 AM   #3
furcatus
Member
 
Registered: Dec 2005
Location: The Netherlands
Distribution: Ubuntu 6.06 Dapper Drake
Posts: 39

Original Poster
Rep: Reputation: 15
Tnx for the sugestion but I found out that it was a incorect Bios setting.

I'm Using a Dell Dimension and those are known to have problems with this.

tnx anyway
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xserver-xorg config warning: migrating xserver-xfree86 templates doctorwebbox Debian 9 07-27-2005 08:24 PM
XServer problems for ROOT !! theGuru Red Hat 4 09-11-2004 05:26 PM
xserver problems quentusrex Debian 29 08-13-2004 10:19 PM
Problems installing Xserver rech Linux - Software 1 02-21-2004 06:42 PM
problems with xserver CMDR_PAIN Linux - Newbie 4 08-25-2003 08:18 AM


All times are GMT -5. The time now is 09:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration