LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 07-11-2005, 02:59 PM   #1
Biglinuxnewb
Member
 
Registered: Jul 2003
Distribution: Gentoo, FreeBSD, OpenBSD, Debian, Knoppix, Digital Unix
Posts: 33

Rep: Reputation: 15
Xscreensaver


I love it and it's wonderful, but when using a media player such as kaffiene, it only disabled the internal KDE screensaver when viewing a movie, and it will not disable xscreensaver, and thus I'd have to disable xscreensaver everytime. I know there are programs that I can have that when I click a button it automatically kills the daemon, but isn't there a much simpler way using Xine's libraries? Help me out here, guys .
 
Old 07-11-2005, 03:31 PM   #2
nonsense28sal
Member
 
Registered: Mar 2005
Location: USA - Oxford, Mississippi
Distribution: Kubuntu-Gutsy, SuSE, Mandriva, Debian
Posts: 89

Rep: Reputation: 15
Mplayer works well

I don't normally use Kaffine, but in MPlayer you can go into “Preferences” then “Misc” and then click a radio button that disables Xscreensaver during video playback. I use it, and that's worked for me.
 
Old 07-11-2005, 03:43 PM   #3
Biglinuxnewb
Member
 
Registered: Jul 2003
Distribution: Gentoo, FreeBSD, OpenBSD, Debian, Knoppix, Digital Unix
Posts: 33

Original Poster
Rep: Reputation: 15
well I found a "xine engine parameters" menu, and it has a misc tab, but nothing about xscreensaver .
 
Old 07-11-2005, 04:06 PM   #4
Biglinuxnewb
Member
 
Registered: Jul 2003
Distribution: Gentoo, FreeBSD, OpenBSD, Debian, Knoppix, Digital Unix
Posts: 33

Original Poster
Rep: Reputation: 15
maybe I can do this from a text end instead of graphical, can you tell me the parameter in your config file that passes that?
 
Old 07-11-2005, 04:18 PM   #5
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
In my ~/.xine/config file I have this entry related to screensaver:

Code:
# Screensaver wakeup
# numeric, default: 10
#gui.screensaver_timeout:10
My guess is that it fakes a mouse or keyboard event every 10 minutes to fake activity and prevent the screensaver. Don't quote me on that, though

Mplayer takes a different approach to this problem by disabling DPMS when the player starts. Then there's also an option in xscreesaver somewhere that disables the screensaver when DPMS is disabled as well. These two options work together perfectly.

--Shade
 
Old 07-11-2005, 05:59 PM   #6
Biglinuxnewb
Member
 
Registered: Jul 2003
Distribution: Gentoo, FreeBSD, OpenBSD, Debian, Knoppix, Digital Unix
Posts: 33

Original Poster
Rep: Reputation: 15
I added that to my Kaffeine config file and all it did was continue to play the movie while the screensaver went on.

Please explain this DPMS method .
 
Old 07-19-2006, 12:09 PM   #7
RedCharlie
LQ Newbie
 
Registered: Jul 2003
Location: Arkansas
Distribution: Fedora, Ubuntu, CentOS
Posts: 26

Rep: Reputation: 15
Try Settings->Configure Kaffeine Player...->Behavior->Interval to fake keypresses

Set it to one minute less than the screensaver.

I'm using Kaffeine 0.7.1 (Using KDE 3.5.1-0.1.fc4), although I am using Gnome for my desktop environment.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xscreensaver Diminished7th Slackware 8 05-23-2005 08:18 PM
xscreensaver installed, but no xscreensaver-demo command? dalesan Linux - Software 7 09-01-2004 02:06 PM
xscreensaver rhraz Linux - General 4 02-25-2004 08:26 AM
xscreensaver bigjohn Linux - Newbie 2 10-20-2003 07:58 AM
xscreensaver jonfa Linux - General 0 05-19-2003 10:20 PM


All times are GMT -5. The time now is 03:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration