LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-09-2014, 03:57 AM   #1
diablo046
LQ Newbie
 
Registered: Jun 2014
Posts: 21

Rep: Reputation: Disabled
Xsane root permission for Network Scanner (HP-2050)


Hi all,

I have configured a usb scanner (HP-2050) as Network Scanner for our company.I have installed sane server in a normal centos machine and make it as scan-server. I can print(Cups server) from any machine in our Network.But for scan , I have to set permission in server manually that is
# chmod 777 /dev/bus/usb/002/*. After that I can scan from any computer. Everytime the scanner connects with my server its ports changes randomly i.e /dev/bus/usb/002/003 or 004(it changes).
Is there any way to make this stop(by changing udev rules or something),so that if we connect the scanner, I don't have to manually change the permission (chmod 777 /dev/bus/usb/002/*) everytime.My OS is Centos 6.5.kindly help.
 
Old 08-09-2014, 11:44 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,889

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
These links might help:
http://marcin.juszkiewicz.com.pl/200...nner-and-udev/
http://pigeonsnest.com/stuff/ubuntu-udev-scanner.html
https://help.ubuntu.com/community/Se...nerPermissions
 
Old 08-11-2014, 11:26 PM   #3
diablo046
LQ Newbie
 
Registered: Jun 2014
Posts: 21

Original Poster
Rep: Reputation: Disabled
thank you
 
Old 09-08-2014, 06:51 AM   #4
diablo046
LQ Newbie
 
Registered: Jun 2014
Posts: 21

Original Poster
Rep: Reputation: Disabled
Today I found the solution. I have created a file name 88-scanner.rules in /etc/udev/rules.d and add the following lines
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="8711", MODE="0777"
The device idVendor and idProduct is shown in lsusb command.And now its working properly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Permission problem for Epson scanner - xsane only works as root acampbell Linux - Hardware 1 02-07-2014 04:42 AM
[SOLVED] Fedora 18 x64, xsane won't detect scanner even though sane-find-scanner does SharpyWarpy Linux - Hardware 8 03-17-2013 06:18 PM
[SOLVED] Brother MFC-7840W Network Scanner not Recognized in XSane Kaiser Soze Slackware 9 06-21-2011 11:40 PM
[SOLVED] xsane does not find scanner and libusb permission error H_TeXMeX_H Slackware 2 10-26-2010 03:35 AM
scanner with xsane rksprst Mandriva 3 02-10-2005 05:23 PM


All times are GMT -5. The time now is 04:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration