LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-08-2004, 06:46 PM   #1
dot hog
Member
 
Registered: Oct 2003
Location: Boondocks USA
Distribution: RH9
Posts: 50

Rep: Reputation: 15
XPInstall prob with Mozilla 1.7.2


Hi. Googled this many times over and have searched to frustration. One person asked my question on these boards but received no response, so I'm trying on both our behalf.

Trying to install extension in Mozilla. I click on the file at Mozilla's extensions page. Mozilla brings up box asking me what to do with file "xxxx.xpi" as file is of type "x-zip (XPInstall Install)". Where do I go from here? I've installed Java plugin, but that's all the extension/plugin installing I've done beyond installing mozilla 1.7.2 and setting up sym. links for mozilla and java in plugins.

Thanks for help if you've got it.
 
Old 09-08-2004, 09:46 PM   #2
CroMagnon
Member
 
Registered: Sep 2004
Location: New Zealand
Distribution: Debian
Posts: 900

Rep: Reputation: 33
Normally an XPI file is recognised and opened by Mozilla by default - I'm not running moz right now to check, but you should be able to select an "open in mozilla" type option, after which moz will install the plugin for you.
 
Old 09-09-2004, 09:40 AM   #3
dot hog
Member
 
Registered: Oct 2003
Location: Boondocks USA
Distribution: RH9
Posts: 50

Original Poster
Rep: Reputation: 15
I don't receive the "open in mozilla" option. I can either save the file or open it with a program of my choice. I chose Mozilla, but that didn't work out--another window opened and nothing happened.
 
Old 09-09-2004, 06:05 PM   #4
CroMagnon
Member
 
Registered: Sep 2004
Location: New Zealand
Distribution: Debian
Posts: 900

Rep: Reputation: 33
OK, I've got Firefox instead of Mozilla, so you might have to hunt around a little, but in your options, is there "allow websites to install software"?
 
Old 09-09-2004, 08:10 PM   #5
dot hog
Member
 
Registered: Oct 2003
Location: Boondocks USA
Distribution: RH9
Posts: 50

Original Poster
Rep: Reputation: 15
Thanks for sticking with me so far CM.

Yep, I have the box labelled "Enable Software Installations" checked in Mozilla's Preferences > Advanced > Software Installations.

Maybe I should be more specific: the .xpi I'm trying to install inparticular is the "Home Button" for Mozilla on my personal work laptop. Had no problems with .xpi files on my desktop at home--they zip right along at home. But for some reason, they just won't work on the laptop. I tried one other .xpi on the laptop, and it didn't go, either. Maybe I'm trying bum .xpi files.

Funny that I can't find anything in Mozilla's help, but I'm not giving up on this, not so long as there's somebody else out there who feels my frustration: http://www.linuxquestions.org/questi...ight=XPInstall
 
Old 09-09-2004, 09:10 PM   #6
CroMagnon
Member
 
Registered: Sep 2004
Location: New Zealand
Distribution: Debian
Posts: 900

Rep: Reputation: 33
Is there any chance the laptop Mozilla has been configured to mis-handle XPI files? Somewhere in the options is a list of filetypes and how to handle them.

Also, how long has Moz been running on the laptop? Would it be a big issue to re-install it? It seems something is just not configured right, and a reinstall should take care of that.

Wish I could help more :/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mozilla prob afrm Linux - Software 0 10-25-2003 12:13 PM
Prob w/Mozilla displaying buttons snatale1 Linux - Software 5 10-08-2003 09:13 AM
XFree keyboard problem, Quake prob and half-life prob cradlebin Linux - Software 0 09-21-2003 07:57 AM
Mozilla / Mouse prob Mdk 9.1 mohoelx Linux - Software 2 08-01-2003 11:45 PM
Mozilla 1.0, odd prob. Edward78 Linux - Software 1 06-22-2003 02:11 PM


All times are GMT -5. The time now is 09:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration