LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-04-2004, 08:46 PM   #1
Chaoskayne
LQ Newbie
 
Registered: Apr 2004
Posts: 17

Rep: Reputation: 0
Question XP pro/redhat multiboot problem


allright i have put a post up in linux software but no1 seams to be able to help me,

my setup: prime master:11gig windows drive
prime slave: dvd burner
secondary master:NONE
secondary slave:8gig red hat 9 linux drive

MY PROBLEM(WAHHHH):alright my problem, when i go to boot with grub, i can boot linux just great, as i am now, but when i go to boot windows, i have two selections red hat 9 and windows xp(renamed from dos), when it goes to boot it says this,
rootnoverify(hd0,0)
chainloader +1
_(blinks)

and after that it freezes, i have tried various numbers to boot from the windows drive but have had no luck, now i ask HELPPPPPPPPPP! I need to boot windows for programming reasons, but with this stuff going on i cant get on. ANY HELP WOULD BE AWESOME!

edit: PLZ HELP, i need help sooo much i am a newb. any help would be great

Last edited by Chaoskayne; 04-04-2004 at 09:12 PM.
 
Old 04-04-2004, 09:14 PM   #2
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
you grub.conf file should look something like this. NOTICE the windows XP section change that and nothing else.



# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,3)
# kernel /boot/vmlinuz-version ro root=/dev/hda4
# initrd /boot/initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,3)/boot/grub/splash.xpm.gz
title Fedora Core (2.4.22-1.2115.nptl)
root (hd0,3)
kernel /boot/vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/1 hdc=ide-scsi rhgb
initrd /boot/initrd-2.4.22-1.2115.nptl.img
title Windows XP
map(hd1)(hd0)
rootnoverify (hd1,0)
makeactive
boot
 
Old 04-04-2004, 09:14 PM   #3
Chaoskayne
LQ Newbie
 
Registered: Apr 2004
Posts: 17

Original Poster
Rep: Reputation: 0
update

PLZ PLZ HELP! i came here for help but no1 will help me, plz
 
Old 04-04-2004, 09:15 PM   #4
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
your grub.conf file is located at

/boot/grub/brub.conf

by the way
 
Old 04-04-2004, 10:08 PM   #5
Chaoskayne
LQ Newbie
 
Registered: Apr 2004
Posts: 17

Original Poster
Rep: Reputation: 0
YOUR MY HERO THX
 
Old 04-04-2004, 10:19 PM   #6
Chaoskayne
LQ Newbie
 
Registered: Apr 2004
Posts: 17

Original Poster
Rep: Reputation: 0
allright now everything seemed great but when i went to to boot it game me error 8:need kernal to boot(something like that)
 
Old 04-04-2004, 10:52 PM   #7
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
can you post your grub.conf file
 
Old 04-04-2004, 11:10 PM   #8
Chaoskayne
LQ Newbie
 
Registered: Apr 2004
Posts: 17

Original Poster
Rep: Reputation: 0
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd1,0)
# kernel /vmlinuz-version ro root=/dev/hdd2
# initrd /initrd-version.img
#boot=/dev/hdb
default=0
timeout=10
splashimage=(hd1,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-8)
root (hd1,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hda=ide-scsi
initrd /initrd-2.4.20-8.img
title Windows XP
map(hd1)(hd0)
rootnoverify (hd1,0)
makeactive
boot


that is my config
 
Old 04-04-2004, 11:34 PM   #9
Chaoskayne
LQ Newbie
 
Registered: Apr 2004
Posts: 17

Original Poster
Rep: Reputation: 0
help i am a
 
Old 04-04-2004, 11:39 PM   #10
phoenix
LQ Newbie
 
Registered: Jan 2003
Location: PA
Distribution: Gentoo
Posts: 27

Rep: Reputation: 15
It looks to me like the problem is in here:
Quote:
title Red Hat Linux (2.4.20-8)
root (hd1,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hda=ide-scsi
initrd /initrd-2.4.20-8.img
I believe your kernel line should look like this:
Code:
kernel (hd1,0)/vmlinuz-2.4.20-8 ro root=LABEL=/ hda=ide-scsi
And your initrd:
Code:
initrd (hd1,0)/initrd-2.4.20-8.img
Provided that hd1,0 is your boot partition

Mine looks like this because it is on my 3rd hard drive and my boot partition is the first partition on that drive:
Code:
kernel (hd2,0)/kernel-2.6.4 root=/dev/ram0 init=/linuxrc real_root=/dev/hdf3 vga=0x317 splash=verbose
initrd (hd2,0)/initrd-2.6.4
hope this helps...
 
Old 04-05-2004, 12:01 AM   #11
Chaoskayne
LQ Newbie
 
Registered: Apr 2004
Posts: 17

Original Poster
Rep: Reputation: 0
one question tho, why is both redhat and windows both 1,0, even tho my windows is the first hardrive first partion and linux is the second hardrive first partition

ps i am going to try wut u said right now.
 
Old 04-05-2004, 12:11 AM   #12
Chaoskayne
LQ Newbie
 
Registered: Apr 2004
Posts: 17

Original Poster
Rep: Reputation: 0
alright, i went and did that and i still for error 8:must have kernel started before boot.
I GOT NO CLUE WUT TO DO DARNIT. WUTS WITH THIS STUPID LINUX CRAP! MY FRIEND TOLD ME THAT IT WORKED WELL SO WUT DO I DO! I GO WASTED 2GIG OF MY 10GIG PER MONTH BANDWITH AND ABOUT 5+HOURS AND LOOK WHAT I GET! LIKE OMFG THIS IS DRIVING ME NUTS! CAN SOMEONE PLZ HELP HELP ME SOLVE THIS STUPID BOOT BULLCRAP!!!!!!! I AM SORRY I AM GETTING REALLY TICKED OFF BUT THIS IS DRIVING ME NUTS< WHY DOES LINUX HAVE TO BE SOOOO GAY< PLZ HELP ME I JUST WANT MY COMPUTER BACK TO THE WAY IT WAS WITHOUT CHANGiNG ANYTHING!!!!!!!!!!!!!!!
 
Old 04-05-2004, 12:15 AM   #13
phoenix
LQ Newbie
 
Registered: Jan 2003
Location: PA
Distribution: Gentoo
Posts: 27

Rep: Reputation: 15
In grub hard drives are numbered differently

in your case your windows drive is (hd0,0)
hd0 = the first hard drive
0 = the first partition on that drive

your linux boot partition would be (hd1,0)
hd1 = the second hard drive
0 = the first partition on that drive

It's a little confusing to start but you get the hang of it.

just remember that linux numbers ide devices hda, hdb, hdc, etc
grub only numbers the harddrives ex:

if you had 3 drives
pri master = hd0
sec master = hd1
sec slave = hd2
notice that even though pri slave may have a cdrom or some other ide device grub just skips straight to the next hard drive...

hope this helps...
 
Old 04-14-2004, 11:16 PM   #14
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
try this in your grub file to fix the kernel not loaded problem

title Windows XP
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1
 
Old 04-14-2004, 11:32 PM   #15
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
Quote:
Originally posted by Chaoskayne
alright, i went and did that and i still for error 8:must have kernel started before boot.
I GOT NO CLUE WUT TO DO DARNIT. WUTS WITH THIS STUPID LINUX CRAP! MY FRIEND TOLD ME THAT IT WORKED WELL SO WUT DO I DO! I GO WASTED 2GIG OF MY 10GIG PER MONTH BANDWITH AND ABOUT 5+HOURS AND LOOK WHAT I GET! LIKE OMFG THIS IS DRIVING ME NUTS! CAN SOMEONE PLZ HELP HELP ME SOLVE THIS STUPID BOOT BULLCRAP!!!!!!! I AM SORRY I AM GETTING REALLY TICKED OFF BUT THIS IS DRIVING ME NUTS< WHY DOES LINUX HAVE TO BE SOOOO GAY< PLZ HELP ME I JUST WANT MY COMPUTER BACK TO THE WAY IT WAS WITHOUT CHANGiNG ANYTHING!!!!!!!!!!!!!!!
nice sig. i guess you're not laughing right now. maybe you should've had your friend help you out with the install and configuration before you decided to foobar everything. but lucky for you, i don't mind helping nitwits who scream, shout, complain, cry, and can't figure out how to turn off the caps lock going back to windows.

put in your xp install cd. boot your computer and get into the bios so you can set the boot order to boot from the cd first before your hard drive. save your bios changes and exit the bios. when the cd boots up get into recovery mode and use the "fixmbr" command (with no quotes). that'll fix overwrite the mbr with how windows likes the mbr. now you can use windows partitioning tool to format that second hard drive. and why is your second hard drive on the slave channel? try it as the secondary master.

here's a nice link with nice pictures. http://www.wown.com/j_helmig/wxprcons.htm

Last edited by megaspaz; 04-14-2004 at 11:37 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with booting Redhat 9 & XP Pro together jtag86 Red Hat 2 10-08-2005 03:53 PM
Problem with xp pro and redhat 9 Chaoskayne Linux - Software 14 04-04-2004 08:31 PM
multiboot Win2K, WinXP and RedHat Linux escape Linux - General 7 08-14-2003 07:46 PM
multiboot win98 win2k and redhat 7.1 cmardhekar Linux - General 1 03-26-2002 07:18 AM
Does anyone know how to multiboot Windows and redhat 7.1 steinberg Linux - Software 1 11-09-2001 03:58 AM


All times are GMT -5. The time now is 12:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration