LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-17-2003, 07:20 PM   #1
ChopSueyX
Member
 
Registered: Nov 2003
Location: Planet M$
Distribution: Slack....
Posts: 46

Rep: Reputation: 15
Unhappy XP Mandrake Boot Problem with Lilo


prolly been asked multiple times but im Fux0r'd!!!! i have 2 HDD one for MicroShiteXP and one for Mandrake i re-installed 9.1 and neither XP or linux i dont know the technical term but to me as a n00b its Fux0r'd it tries to load XP an jus spams 99 99 99 ........ then restart i tried a rescue of linux to re- install boot loader but it jus boot from the XP hdd an 99 99 99... again im thinkin i need to boot from a floppy which i dont have but least i can boot from CD into knoppix but cant find any boot stuff and definatly cant edit the lilo.conf cos 1 i can see it and 2 i dont know how. im jus fed up


PS i cant re-install XP due to lack of install cd an i need alot of files from it
 
Old 11-17-2003, 08:01 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Right ... and now, back to normal English
and knoppix ... in konppix, which partitions
have you got mounted?

What was the original partitioning scheme
of your RedHat? When did the 99 99 output
start? Did you physically swap the HDD's?

Cheers,
Tink
 
Old 11-17-2003, 08:04 PM   #3
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Okay a few things first, what does your lilo.conf say. and how are the disks set up. (i.e. which ones hda, or IDE1 Primary etc..). Then we can go from there
 
Old 11-18-2003, 08:01 AM   #4
8nasmith
Member
 
Registered: Oct 2003
Location: Cornwall, UK
Distribution: Fedora Core 4
Posts: 268

Rep: Reputation: 30
been there done that but i shall worn you do not medal with the booting list becuase on my linux it boots windows from hd--3 and i changed it and trhe linux one and the hole thing corrupted.

sorry about thre spelling
 
Old 11-18-2003, 10:04 AM   #5
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
In knoppix, all your partitions will appear on your desktop. All you need to do is mount them and remount them as read-write (right-click them, you prob. can't/shouldn't remount as rw with NTFS). Then open the Linux partition, and look at the /etc/lilo.conf file (relative to where it is in knoppix, I'm guessing /mnt/hda2/etc/lilo.conf ). Then you can post it.
 
Old 11-18-2003, 10:53 AM   #6
david@aber
Member
 
Registered: Jul 2003
Distribution: Multiple
Posts: 34

Rep: Reputation: 15
I had the same problem a few times with bot 9.1 and 9.2, you have not been suceesful in installing your bootloader or you have changed your drives. I found this out by mistake and overwriting the MBR (master boot record) which windows installs. to fix this problem insert your installation cd 1 and boot. set up the installation as you normally would and when you get asked whether you want to install or upgrade select upgrade. this will take a few minutes and should solve your problem. if this doesn't try the rescue command on the cd. or you will have to reinstall both systems.

make sure that you configure the boot loader to be installed on your maindrive.
 
Old 11-19-2003, 10:41 AM   #7
ChopSueyX
Member
 
Registered: Nov 2003
Location: Planet M$
Distribution: Slack....
Posts: 46

Original Poster
Rep: Reputation: 15
Wink well its fixed

well i fixed it on my own due to lack of internet to get help from u lot in the end i think i could hav fixed it the way aaa said if i had the know-how do do that kinda stuff in knoppix or any linux tbh, but in the end i used the CD1 to rescue then re-installed MS boot loader on all drives then re-installed mandrake too some time but i think i got it down to a T, i hav 3+ linux's to boot from i want to shorten my list to just Linux Windows & floppy how do i do this without f00kin lilo up again? TIA
 
Old 11-19-2003, 10:48 AM   #8
ChopSueyX
Member
 
Registered: Nov 2003
Location: Planet M$
Distribution: Slack....
Posts: 46

Original Poster
Rep: Reputation: 15
Lightbulb my lilo.conf

this is my config, which linux should i boot into? the one label Linux? or the one labeled Linux Enterprise. how would i get it to jus display Linux, Windoze & floppy without fuckin up my boot loader like i did b4? TIA


boot=/dev/hde
map=/boot/map
vga=normal
default="windows"
keytable=/boot/uk.klt
prompt
nowarn
timeout=50
message=/boot/message
menu-scheme=wb:bw:wb:bw
disk=/dev/hde bios=0x80
disk=/dev/hdg bios=0x81
image=/boot/vmlinuz
label="linux"
root=/dev/hdg1
initrd=/boot/initrd.img
append="quiet devfs=mount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hdg1
initrd=/boot/initrd.img
append="devfs=mount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
read-only
image=/boot/vmlinuz-enterprise
label="linux-enterpris"
root=/dev/hdg1
initrd=/boot/initrd-enterprise.img
append="devfs=mount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hdg1
initrd=/boot/initrd.img
append="failsafe devfs=nomount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
read-only
other=/dev/hde1
label="windows"
table=/dev/hde
other=/dev/fd0
label="floppy"
unsafe
 
Old 11-19-2003, 11:00 AM   #9
david@aber
Member
 
Registered: Jul 2003
Distribution: Multiple
Posts: 34

Rep: Reputation: 15
You should be able to configure your boot loader in Linux. For example mandrake can be done using the control center. if select boot option from the list on the side, this will allow you to configure your bootloader. Don't change the position of the bootloader. just edit what is listed. say ok to changes and that should be all you need to do.
 
Old 11-19-2003, 11:00 AM   #10
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Try this file:

boot=/dev/hde
map=/boot/map
vga=normal
default="windows"
keytable=/boot/uk.klt
prompt
nowarn
timeout=50
message=/boot/message
menu-scheme=wb:bw:wb:bw
disk=/dev/hde bios=0x80
disk=/dev/hdg bios=0x81
image=/boot/vmlinuz
label="linux"
root=/dev/hdg1
initrd=/boot/initrd.img
append="quiet devfs=mount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
vga=788
read-only
#Remove this too if you still don't want it:
image=/boot/vmlinuz
label="failsafe"
root=/dev/hdg1
initrd=/boot/initrd.img
append="failsafe devfs=nomount hda=ide-scsi hdb=ide-scsi hdc=ide-scsi acpi=off"
read-only
#End failsafe section
other=/dev/hde1
label="windows"
table=/dev/hde
other=/dev/fd0
label="floppy"
unsafe
 
Old 11-20-2003, 10:08 AM   #11
ChopSueyX
Member
 
Registered: Nov 2003
Location: Planet M$
Distribution: Slack....
Posts: 46

Original Poster
Rep: Reputation: 15
:'( well ummm i fixed that problem now my XP hDD has totally died so i took it out! now mandrake wont boot i tried the rescue to reinstall the bootloader but didnt work :/ so now im in knoppix trying to edit lilo.conf but its 'read only' TIA
 
Old 11-20-2003, 11:04 AM   #12
ChopSueyX
Member
 
Registered: Nov 2003
Location: Planet M$
Distribution: Slack....
Posts: 46

Original Poster
Rep: Reputation: 15
Unhappy lo

ello.... can anyone help
 
Old 11-21-2003, 07:59 AM   #13
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
The 'remount as read-only' option when you right-click after mounting will help. Open a terminal and type 'su' to switch to root in knoppix, too. Use a nice editor like pico if possible. Remeber to run 'lilo' to apply changes. Also remeber that running lilo will install whatever is set in /etc/lilo.conf , so be sure to copy your Mandrake lilo.conf there in knoppix.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lilo with Ubuntu, dual boot with Mandrake ploosh Ubuntu 2 03-17-2005 07:34 PM
mandrake (lilo) cannot boot to other OS when linux hd is not connected ahmetcan Linux - Laptop and Netbook 6 10-29-2004 12:51 AM
How to boot Mandrake 10.1 without diskette or LILO? eltoro Mandriva 13 10-09-2004 05:56 AM
Lilo and Grub don't want to boot Mandrake malim Linux - Newbie 3 10-05-2004 05:48 PM
Editing Lilo.conf? Mandrake 10 won't boot midk Linux - Newbie 6 07-30-2004 12:08 AM


All times are GMT -5. The time now is 12:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration