LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-04-2010, 05:02 AM   #1
ssssshhhhh
LQ Newbie
 
Registered: Jun 2010
Posts: 4

Rep: Reputation: 0
XP - Fedora - Grub dual boot issue


I have a desktop box running XP

on a second internal hard drive i downloaded Fedora 12, (now 13)

on start up the box always boots into Fedora 13, and I have no way of booting into windows.

during the start up process i am given the option to enter into grub, but it only gives me 3 seconds to hit any key, and when i do hit a key it doesn't seem to register and we always boot into fedora.

What I would like to do is to automatically go to a grub screen and have the option of which to choose direct from start up.

All the grub tutorials I have found all seem to be slightly beyond my starting point of linux knowledge. is there a real simple guide or way to do this?

thanks in advance
 
Old 06-04-2010, 07:44 AM   #2
blue_print
Member
 
Registered: May 2010
Location: In world
Distribution: RHEL, CentOS, Ubuntu
Posts: 275
Blog Entries: 3

Rep: Reputation: 50
Please provide the content of the grub configuration file. The file is /boot/grub/menu.lst or /etc/grub.conf
 
Old 06-04-2010, 08:14 AM   #3
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,571

Rep: Reputation: 349Reputation: 349Reputation: 349Reputation: 349
Quote:
Originally Posted by ssssshhhhh View Post
I have a desktop box running XP

on a second internal hard drive i downloaded Fedora 12, (now 13)

on start up the box always boots into Fedora 13, and I have no way of booting into windows.

during the start up process i am given the option to enter into grub, but it only gives me 3 seconds to hit any key, and when i do hit a key it doesn't seem to register and we always boot into fedora.

What I would like to do is to automatically go to a grub screen and have the option of which to choose direct from start up.

All the grub tutorials I have found all seem to be slightly beyond my starting point of linux knowledge. is there a real simple guide or way to do this?

thanks in advance
As root, edit the file /boot/grub/grub.conf. There's a line that says:
Code:
timeout=3
(the actually number may differ). The number is the numbr of seconds for which your grub menu will appear. Just change it to something larger; I've got mine set to 65.
 
Old 06-04-2010, 09:35 AM   #4
ssssshhhhh
LQ Newbie
 
Registered: Jun 2010
Posts: 4

Original Poster
Rep: Reputation: 0
opening grub.conf or grub.lst

yes I will post the contents here, my problem is how do i open that file.

if through the terminal, how do i cut and paste that?

thanks
 
Old 06-04-2010, 11:20 AM   #5
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Highlight the text

Press ctrl+c to copy
press Ctrl+v to paste

work in both Linux and MS Winodws GUI
 
Old 06-04-2010, 01:21 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,107

Rep: Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478
from the terminal run gedit as root
you need to be root to edit the grub.conf file

Code:
su -
( your root password when asked ) 
gedit
also READ the fedora docs .this is a very well known problem and IS VERY WELL DOCUMENTED
http://docs.fedoraproject.org/en-US/index.html
 
Old 06-16-2010, 10:07 AM   #7
ssssshhhhh
LQ Newbie
 
Registered: Jun 2010
Posts: 4

Original Poster
Rep: Reputation: 0
sorry for the delay!

here is the boot/grub/menu.lst file

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd1,0)
# kernel /vmlinuz-version ro root=/dev/mapper/vg_penguin-lv_root
# initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=50
splashimage=(hd1,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.33.5-124.fc13.i686)
root (hd1,0)
kernel /vmlinuz-2.6.33.5-124.fc13.i686 ro root=/dev/mapper/vg_penguin-lv_root noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=uk rhgb quiet
initrd /initramfs-2.6.33.5-124.fc13.i686.img
title Fedora (2.6.33.5-112.fc13.i686)
root (hd1,0)
kernel /vmlinuz-2.6.33.5-112.fc13.i686 ro root=/dev/mapper/vg_penguin-lv_root noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=uk rhgb quiet
initrd /initramfs-2.6.33.5-112.fc13.i686.img
title Fedora (2.6.33.4-95.fc13.i686)
root (hd1,0)
kernel /vmlinuz-2.6.33.4-95.fc13.i686 ro root=/dev/mapper/vg_penguin-lv_root noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=uk rhgb quiet
initrd /initramfs-2.6.33.4-95.fc13.i686.img
title Other
rootnoverify (hd0,0)
chainloader +1

and the /etc/grub.conf file
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd1,0)
# kernel /vmlinuz-version ro root=/dev/mapper/vg_penguin-lv_root
# initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=50
splashimage=(hd1,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.33.5-124.fc13.i686)
root (hd1,0)
kernel /vmlinuz-2.6.33.5-124.fc13.i686 ro root=/dev/mapper/vg_penguin-lv_root noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=uk rhgb quiet
initrd /initramfs-2.6.33.5-124.fc13.i686.img
title Fedora (2.6.33.5-112.fc13.i686)
root (hd1,0)
kernel /vmlinuz-2.6.33.5-112.fc13.i686 ro root=/dev/mapper/vg_penguin-lv_root noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=uk rhgb quiet
initrd /initramfs-2.6.33.5-112.fc13.i686.img
title Fedora (2.6.33.4-95.fc13.i686)
root (hd1,0)
kernel /vmlinuz-2.6.33.4-95.fc13.i686 ro root=/dev/mapper/vg_penguin-lv_root noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=uk rhgb quiet
initrd /initramfs-2.6.33.4-95.fc13.i686.img
title Other
rootnoverify (hd0,0)
chainloader +1

thanks for any help
 
Old 06-16-2010, 10:09 AM   #8
ssssshhhhh
LQ Newbie
 
Registered: Jun 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Reading!

Quote:
Originally Posted by John VV View Post
...
also READ the fedora docs .this is a very well known problem and IS VERY WELL DOCUMENTED
http://docs.fedoraproject.org/en-US/index.html
Hi john
the documents are quite comprehensive but i couldn't find anything which would help with my problem?
could you point me to the right section of the documents as I was struggling to find an answer which was basic enough for me to understand?

thanks for the help.
 
Old 06-16-2010, 10:20 AM   #9
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 51
Hi,

you might want to put # into hiddenmenu to disable it

#hiddenmenu

and set default=0 to default=3 to boot directly to winxp

cmiiw
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] odd issue with GRUB on a dual-boot laptop Cultist Linux - General 6 02-08-2010 04:02 PM
Building dual boot Windows 7 & Fedora 11 machine. Fedora 11 boot issue tedscott Fedora 0 11-14-2009 09:57 PM
Grub dual boot issue jnav Linux - Newbie 15 08-21-2008 02:29 PM
Fedora Core 3 Dual Boot, Dual Hard drives, Grub Boot Loader Denali03 Linux - Newbie 1 03-04-2005 01:44 PM
Grub dual boot issue simvan Linux - Newbie 8 06-04-2004 04:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration