LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   XP Box won't take DHCP information or an IP from Linux gateway (http://www.linuxquestions.org/questions/linux-newbie-8/xp-box-wont-take-dhcp-information-or-an-ip-from-linux-gateway-245748/)

Diademed 10-21-2004 08:30 PM

XP Box won't take DHCP information or an IP from Linux gateway
 
My XP machine doesn't seem to want to take a DHCP lease from my linux gateway/firewall.... It worked for approx 1 day, almost to the hour, and then stopped.

This is sort of a clarification from this post:
http://www.linuxquestions.org/questi...hreadid=239953


Is there some reason my XP machine won't connect?

Apologies for the double post if it's considered thus, I'm looking at it now from a different angle.

When I disconnect it from the plug on the wall, and plug it into the linux box, it gets a funny IP, certainly not the 192.168.x.x it should, and refuses to connect to the lgateway. Request timed out, or DHCP server not available.

adamwenner 10-22-2004 02:40 PM

there is some special code you have to put in the dhcp conf file, but i forgot where i found it and am working though the same problem

do a google search

Diademed 10-22-2004 05:47 PM

Code:


2:/etc# cat dhcpd.conf
#dhcpd.conf
#
# Configuration file for ISC dhcpd (see 'man dhcpd.conf')

# Global options
default-lease-time 3600;        # 24h
max-lease-time 86400;          # 24h

subnet 192.168.1.0 netmask 255.255.255.0 {

        range 192.168.1.10 192.168.1.150;    #obviously the range of ips to use

        option subnet-mask 255.255.255.0;    #subnet mask to give to dhcp client
        option broadcast-address 192.168.1.255;    #broadcast address to give client

        option routers 192.168.1.1;        #this is your router (eth1 if you configure it like above)
        option domain-name-servers 128.95.120.1;      #uncomment this and add your isp's dns server
        #option domain-name-servers 192.168.1.1;      #unless your like me and have your own or have a second one
        option domain-name "glacier.ice";        #this is the domainname that will be given out
}
ddns-update-style none;


This is what is in my dhcp right now. fairly close anyway. you should try this and see how it works out for you.


All times are GMT -5. The time now is 09:30 PM.