LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-06-2004, 08:38 PM   #1
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Rep: Reputation: 30
xorg vs. xfree problem


Hey people, I have a quick question. I login to my Debian/GNU servers to do my work. I login from gentoo boxes, and my cygwin installation on windows. It seems that I keep having problems forwarding X packets through ssh though. Whenever I open emacs in X mode, and I try to highlight something with my mouse, I get:

Code:
X protocol error: BadWindow (invalid Window parameter) on protocol request 38
If I try to open ddd up, I get this:
Code:
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  3 (X_GetWindowAttributes)
  Resource id in failed request:  0x1400196
  Serial number of failed request:  7354
  Current serial number in output stream:  7355
  Widget hierarchy of resource:  unknown
Xlib: unexpected async reply (sequence 0x1f72)!
Exit 0
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  3 (X_GetWindowAttributes)
  Resource id in failed request:  0x14001be
  Serial number of failed request:  8049
  Current serial number in output stream:  8118
  Widget hierarchy of resource:  unknown

X error (invalid Window parameter).
Is this due to the fact that the Debian servers are running xfree, while I'm logging into them using xorg?
 
Old 11-07-2004, 02:54 PM   #2
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Original Poster
Rep: Reputation: 30
I found this post after putting mine up... Oops, what a rookie move on my part.
http://www.linuxquestions.org/questions/history/231248

Anyway, it was a local issue on my machines, so I just edited my ~/.ssh/config file with this information.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xfree -> Xorg Dannyarr SUSE / openSUSE 2 01-27-2005 11:42 PM
Xfree to Xorg RestricteD Slackware 2 12-22-2004 07:42 PM
xorg and xfree vdings Linux - Software 1 10-30-2004 09:25 PM
XOrg Vs. XFree Igman Linux - Software 8 08-14-2004 11:42 AM
Considering Xorg, Slack favors Xorg over Xfree Nichole_knc Slackware 7 06-13-2004 07:46 AM


All times are GMT -5. The time now is 10:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration