LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-24-2007, 11:09 PM   #1
twelvenine
Member
 
Registered: Sep 2006
Posts: 72

Rep: Reputation: 16
xorg screen blanking timeouts


i've been trying to edit my xorg.conf file so that x doesn't blank the screen every 10 minutes or so because it really interrupts up any videos and stuff that i watch. i've been able to change the blank timeout and the dpms timeouts using xset, but i really want it done automatically. i've added this to my xorg.conf file:
Code:
Section "Monitor"
    Identifier  "Monitor0"  
    HorizSync   31.5-90
    VertRefresh 59-75
    Option "DPMS"
    Option "blank time" "0"
    Option "standby time" "0"
    Option "suspend time" "0"  
    Option "off time" "0"
EndSection
i've also tried the same options without spaces and with captialized letters, etc.(i.e. "BlankTime) but when i startx and do a xset -q, the timeouts aren't set to 0.

I can't think of any other way to do this. running xset at boot up to set the options wont work because xset won't do anything unless x is running. i don't think there are any scripts that run on boot or x startup that would set these timeouts, i'm running slackware.

can anybody help me out with this?
 
Old 01-24-2007, 11:41 PM   #2
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,899

Rep: Reputation: 68
Run xscreensaver-demo and switch screensaver off. Does it help?
 
Old 01-25-2007, 12:02 PM   #3
twelvenine
Member
 
Registered: Sep 2006
Posts: 72

Original Poster
Rep: Reputation: 16
i did xscreensaver-demo and selected "disable screen saver" from the dropdown menu. it doesn't seem to have helped, xset -q still shows timeouts for screen blanking and dpms.
 
Old 01-25-2007, 01:59 PM   #4
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,899

Rep: Reputation: 68
xset dpms 0 0 0
 
Old 01-25-2007, 03:11 PM   #5
JDaniels
LQ Newbie
 
Registered: Jun 2004
Location: Salt Lake City, UT
Distribution: Slackware
Posts: 24

Rep: Reputation: Disabled
You can add this to your .xinitrc file:
Code:
xset dpms 0 0 0
or
Code:
xset -dpms
 
Old 01-25-2007, 10:22 PM   #6
twelvenine
Member
 
Registered: Sep 2006
Posts: 72

Original Poster
Rep: Reputation: 16
thx, i kinda forgot about .xinitrc. this solution works, but it's wierd that the xorg.conf settings don't do anything. either they just didn't work for whatever reason or some script that runs on x startup is undermining them.
 
Old 01-25-2007, 10:42 PM   #7
twelvenine
Member
 
Registered: Sep 2006
Posts: 72

Original Poster
Rep: Reputation: 16
it seems that the screen blanking and dpms settings go in the server layout section of xorg.conf, thats why they weren't working. i believe the option "dpms" line still belongs in the monitor section though.
 
Old 01-29-2007, 04:44 PM   #8
JDaniels
LQ Newbie
 
Registered: Jun 2004
Location: Salt Lake City, UT
Distribution: Slackware
Posts: 24

Rep: Reputation: Disabled
A side note, xscreensaver will override the dpms settings. xscreensaver will store the settings in ~/.xscreensaver
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Blanking b0mb3r Slackware 6 03-16-2005 03:39 PM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 01:50 PM
Screen blanking ? ... phoeniXflame Linux - General 12 07-20-2003 06:41 PM
Screen Blanking/non-X ldieter Linux - General 0 03-11-2002 10:05 PM
Screen Blanking bretthoward Linux - General 7 03-19-2001 06:50 AM


All times are GMT -5. The time now is 10:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration