LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-16-2014, 01:00 PM   #1
FreakofPurple
LQ Newbie
 
Registered: Aug 2014
Distribution: Ubuntu 14.10 Utopic Unicorn 64-bit
Posts: 13

Rep: Reputation: 0
Xorg nVidia Problems


I'm using Linux Mint 17 MATE 64-bit with nVidia GeForce 8600 GS and Intel Core 2 Duo. I've had this problem for about a week now. I was using my computer when it crashed on me. I turned it back on but it now had blue, red, and white lines everywhere. It booted fine, but a couple minutes later it crashed again. It then gave me an error saying that I had a problem with MDM. I set the grub boot to terminal and I installed various driver, such as the nVidia 340.24 driver. I ran startx but it gave me a log:

[ 120.094]
X.Org X Server 1.15.1
Release Date: 2014-04-13
[ 120.115] X Protocol Version 11, Revision 0
[ 120.122] Build Operating System: Linux 3.2.0-37-generic x86_64 Ubuntu
[ 120.137] Current Operating System: Linux freakofpurple-TRANSPORT-T2500-154-E 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64
[ 120.138] Kernel command line: BOOT_IMAGE=/vmlinuz-3.13.0-24-generic root=/dev/mapper/mint--vg-root ro text quiet_splash
[ 120.161] Build Date: 16 April 2014 01:36:29PM
[ 120.178] xorg-server 2:1.15.1-0ubuntu2 (For technical support please see http://www.ubuntu.com/support)
[ 120.186] Current version of pixman: 0.30.2
[ 120.204] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 120.204] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 120.242] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Aug 16 11:47:50 2014
[ 120.269] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 120.269] (==) No Layout section. Using the first Screen section.
[ 120.269] (==) No screen section available. Using defaults.
[ 120.269] (**) |-->Screen "Default Screen Section" (0)
[ 120.269] (**) | |-->Monitor "<default monitor>"
[ 120.269] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 120.269] (==) Automatically adding devices
[ 120.269] (==) Automatically enabling devices
[ 120.269] (==) Automatically adding GPU devices
[ 120.400] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/cyrillic,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[ 120.400] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 120.400] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 120.400] (II) Loader magic: 0x7f3da2f67d60
[ 120.400] (II) Module ABI versions:
[ 120.400] X.Org ANSI C Emulation: 0.4
[ 120.400] X.Org Video Driver: 15.0
[ 120.400] X.Org XInput driver : 20.0
[ 120.400] X.Org Server Extension : 8.0
[ 120.403] (--) PCI:*(0:1:0:0) 10de:0425:144d:c02f rev 161, Mem @ 0xca000000/16777216, 0xd0000000/268435456, 0xc8000000/33554432, I/O @ 0x00005000/128
[ 120.414] Initializing built-in extension Generic Event Extension
[ 120.425] Initializing built-in extension SHAPE
[ 120.436] Initializing built-in extension MIT-SHM
[ 120.447] Initializing built-in extension XInputExtension
[ 120.457] Initializing built-in extension XTEST
[ 120.468] Initializing built-in extension BIG-REQUESTS
[ 120.479] Initializing built-in extension SYNC
[ 120.490] Initializing built-in extension XKEYBOARD
[ 120.500] Initializing built-in extension XC-MISC
[ 120.510] Initializing built-in extension SECURITY
[ 120.520] Initializing built-in extension XINERAMA
[ 120.530] Initializing built-in extension XFIXES
[ 120.540] Initializing built-in extension RENDER
[ 120.549] Initializing built-in extension RANDR
[ 120.558] Initializing built-in extension COMPOSITE
[ 120.567] Initializing built-in extension DAMAGE
[ 120.575] Initializing built-in extension MIT-SCREEN-SAVER
[ 120.582] Initializing built-in extension DOUBLE-BUFFER
[ 120.589] Initializing built-in extension RECORD
[ 120.596] Initializing built-in extension DPMS
[ 120.602] Initializing built-in extension Present
[ 120.608] Initializing built-in extension DRI3
[ 120.613] Initializing built-in extension X-Resource
[ 120.619] Initializing built-in extension XVideo
[ 120.624] Initializing built-in extension XVideo-MotionCompensation
[ 120.628] Initializing built-in extension SELinux
[ 120.633] Initializing built-in extension XFree86-VidModeExtension
[ 120.637] Initializing built-in extension XFree86-DGA
[ 120.641] Initializing built-in extension XFree86-DRI
[ 120.644] Initializing built-in extension DRI2
[ 120.644] (II) LoadModule: "glx"
[ 120.707] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 121.210] (II) Module glx: vendor="NVIDIA Corporation"
[ 121.210] compiled for 4.0.2, module version = 1.0.0
[ 121.210] Module class: X.Org Server Extension
[ 121.223] (II) NVIDIA GLX Module 340.24 Wed Jul 2 15:04:31 PDT 2014
[ 121.226] Loading extension GLX
[ 121.226] (==) Matched nvidia as autoconfigured driver 0
[ 121.226] (==) Matched nouveau as autoconfigured driver 1
[ 121.226] (==) Matched modesetting as autoconfigured driver 2
[ 121.226] (==) Matched fbdev as autoconfigured driver 3
[ 121.226] (==) Matched vesa as autoconfigured driver 4
[ 121.226] (==) Assigned the driver to the xf86ConfigLayout
[ 121.226] (II) LoadModule: "nvidia"
[ 121.227] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 121.228] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 121.228] compiled for 4.0.2, module version = 1.0.0
[ 121.228] Module class: X.Org Video Driver
[ 121.228] (II) LoadModule: "nouveau"
[ 121.228] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[ 121.246] (II) Module nouveau: vendor="X.Org Foundation"
[ 121.246] compiled for 1.15.1, module version = 1.0.10
[ 121.246] Module class: X.Org Video Driver
[ 121.246] ABI class: X.Org Video Driver, version 15.0
[ 121.246] (II) LoadModule: "modesetting"
[ 121.246] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 121.246] (II) Module modesetting: vendor="X.Org Foundation"
[ 121.246] compiled for 1.15.0, module version = 0.8.1
[ 121.246] Module class: X.Org Video Driver
[ 121.246] ABI class: X.Org Video Driver, version 15.0
[ 121.246] (II) LoadModule: "fbdev"
[ 121.247] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 121.247] (II) Module fbdev: vendor="X.Org Foundation"
[ 121.247] compiled for 1.15.0, module version = 0.4.4
[ 121.247] Module class: X.Org Video Driver
[ 121.247] ABI class: X.Org Video Driver, version 15.0
[ 121.247] (II) LoadModule: "vesa"
[ 121.247] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 121.247] (II) Module vesa: vendor="X.Org Foundation"
[ 121.247] compiled for 1.15.0, module version = 2.3.3
[ 121.247] Module class: X.Org Video Driver
[ 121.247] ABI class: X.Org Video Driver, version 15.0
[ 121.247] (II) NVIDIA dlloader X Driver 340.24 Wed Jul 2 14:42:23 PDT 2014
[ 121.247] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 121.247] (II) NOUVEAU driver
[ 121.247] (II) NOUVEAU driver for NVIDIA chipset families :
[ 121.247] RIVA TNT (NV04)
[ 121.247] RIVA TNT2 (NV05)
[ 121.247] GeForce 256 (NV10)
[ 121.247] GeForce 2 (NV11, NV15)
[ 121.247] GeForce 4MX (NV17, NV18)
[ 121.247] GeForce 3 (NV20)
[ 121.247] GeForce 4Ti (NV25, NV28)
[ 121.247] GeForce FX (NV3x)
[ 121.247] GeForce 6 (NV4x)
[ 121.247] GeForce 7 (G7x)
[ 121.247] GeForce 8 (G8x)
[ 121.247] GeForce GTX 200 (NVA0)
[ 121.247] GeForce GTX 400 (NVC0)
[ 121.247] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 121.247] (II) FBDEV: driver for framebuffer: fbdev
[ 121.247] (II) VESA: driver for VESA chipsets: vesa
[ 121.247] (--) using VT number 7

[ 121.267] (II) Loading sub module "fb"
[ 121.267] (II) LoadModule: "fb"
[ 121.267] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 121.267] (II) Module fb: vendor="X.Org Foundation"
[ 121.267] compiled for 1.15.1, module version = 1.0.0
[ 121.267] ABI class: X.Org ANSI C Emulation, version 0.4
[ 121.267] (WW) Unresolved symbol: fbGetGCPrivateKey
[ 121.267] (II) Loading sub module "wfb"
[ 121.267] (II) LoadModule: "wfb"
[ 121.267] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 121.267] (II) Module wfb: vendor="X.Org Foundation"
[ 121.267] compiled for 1.15.1, module version = 1.0.0
[ 121.267] ABI class: X.Org ANSI C Emulation, version 0.4
[ 121.268] (II) Loading sub module "ramdac"
[ 121.268] (II) LoadModule: "ramdac"
[ 121.268] (II) Module "ramdac" already built-in
[ 121.311] (WW) Falling back to old probe method for modesetting
[ 121.311] (WW) Falling back to old probe method for fbdev
[ 121.311] (II) Loading sub module "fbdevhw"
[ 121.311] (II) LoadModule: "fbdevhw"
[ 121.311] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 121.311] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 121.311] compiled for 1.15.1, module version = 0.0.2
[ 121.311] ABI class: X.Org Video Driver, version 15.0
[ 121.311] (WW) Falling back to old probe method for vesa
[ 121.312] (II) NVIDIA(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 121.312] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[ 121.312] (==) NVIDIA(0): RGB weight 888
[ 121.312] (==) NVIDIA(0): Default visual is TrueColor
[ 121.312] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 121.312] (**) NVIDIA(0): Enabling 2D acceleration
[ 121.380] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please
[ 121.380] (EE) NVIDIA(GPU-0): check your system's kernel log for additional error
[ 121.380] (EE) NVIDIA(GPU-0): messages and refer to Chapter 8: Common Problems in the
[ 121.380] (EE) NVIDIA(GPU-0): README for additional information.
[ 121.380] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[ 121.380] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 121.380] (II) UnloadModule: "nvidia"
[ 121.380] (II) UnloadSubModule: "wfb"
[ 121.380] (II) UnloadSubModule: "fb"
[ 121.380] (EE) Screen(s) found, but none have a usable configuration.
[ 121.380] (EE)
Fatal server error:
[ 121.380] (EE) no screens found(EE)
[ 121.380] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 121.380] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 121.380] (EE)
[ 121.434] (EE) Server terminated with error (1). Closing log file.

As you can probably see, there are various errors in the log.
 
Old 08-16-2014, 02:14 PM   #2
johnston73
LQ Newbie
 
Registered: Aug 2013
Posts: 7

Rep: Reputation: Disabled
I have a nearly duplicate setup except I can't even boot with the Xorg drivers. To fix I booted in 'compatability/safe' mode and then used the Mint configuration tool to use the recommended proprietary nVidia drivers. Everything works great without issue now.
 
Old 08-16-2014, 02:31 PM   #3
FreakofPurple
LQ Newbie
 
Registered: Aug 2014
Distribution: Ubuntu 14.10 Utopic Unicorn 64-bit
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks for the reply. How do you boot into compatibility/safe mode?
 
Old 08-16-2014, 03:35 PM   #4
FreakofPurple
LQ Newbie
 
Registered: Aug 2014
Distribution: Ubuntu 14.10 Utopic Unicorn 64-bit
Posts: 13

Original Poster
Rep: Reputation: 0
I just installed nVidia driver 340.32 by the way.
 
Old 08-16-2014, 03:43 PM   #5
FreakofPurple
LQ Newbie
 
Registered: Aug 2014
Distribution: Ubuntu 14.10 Utopic Unicorn 64-bit
Posts: 13

Original Poster
Rep: Reputation: 0
I have a new error log to post. It has many new warnings after the update.
[ 92.732]
X.Org X Server 1.15.1
Release Date: 2014-04-13
[ 92.765] X Protocol Version 11, Revision 0
[ 92.776] Build Operating System: Linux 3.2.0-37-generic x86_64 Ubuntu
[ 92.799] Current Operating System: Linux freakofpurple-TRANSPORT-T2500-154-E 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64
[ 92.800] Kernel command line: BOOT_IMAGE=/vmlinuz-3.13.0-24-generic root=/dev/mapper/mint--vg-root ro text nomodeset
[ 92.835] Build Date: 16 April 2014 01:36:29PM
[ 92.859] xorg-server 2:1.15.1-0ubuntu2 (For technical support please see http://www.ubuntu.com/support)
[ 92.871] Current version of pixman: 0.30.2
[ 92.895] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 92.895] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 92.944] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Aug 16 15:37:44 2014
[ 92.998] (==) Using config file: "/etc/X11/xorg.conf"
[ 93.010] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 93.070] (==) ServerLayout "X.org Configured"
[ 93.070] (**) |-->Screen "Screen0" (0)
[ 93.070] (**) | |-->Monitor "Monitor0"
[ 93.071] (**) | |-->Device "Card0"
[ 93.071] (**) |-->Input Device "Mouse0"
[ 93.071] (**) |-->Input Device "Keyboard0"
[ 93.071] (==) Automatically adding devices
[ 93.071] (==) Automatically enabling devices
[ 93.071] (==) Automatically adding GPU devices
[ 93.199] (**) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/cyrillic,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins,
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/cyrillic,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[ 93.199] (**) ModulePath set to "/usr/lib/xorg/modules"
[ 93.199] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 93.199] (WW) Disabling Mouse0
[ 93.199] (WW) Disabling Keyboard0
[ 93.199] (II) Loader magic: 0x7fe50d9dcd60
[ 93.199] (II) Module ABI versions:
[ 93.199] X.Org ANSI C Emulation: 0.4
[ 93.199] X.Org Video Driver: 15.0
[ 93.199] X.Org XInput driver : 20.0
[ 93.199] X.Org Server Extension : 8.0
[ 93.204] (--) PCI:*(0:1:0:0) 10de:0425:144d:c02f rev 161, Mem @ 0xca000000/16777216, 0xd0000000/268435456, 0xc8000000/33554432, I/O @ 0x00005000/128
[ 93.217] Initializing built-in extension Generic Event Extension
[ 93.229] Initializing built-in extension SHAPE
[ 93.240] Initializing built-in extension MIT-SHM
[ 93.252] Initializing built-in extension XInputExtension
[ 93.264] Initializing built-in extension XTEST
[ 93.275] Initializing built-in extension BIG-REQUESTS
[ 93.286] Initializing built-in extension SYNC
[ 93.296] Initializing built-in extension XKEYBOARD
[ 93.307] Initializing built-in extension XC-MISC
[ 93.317] Initializing built-in extension SECURITY
[ 93.328] Initializing built-in extension XINERAMA
[ 93.338] Initializing built-in extension XFIXES
[ 93.348] Initializing built-in extension RENDER
[ 93.357] Initializing built-in extension RANDR
[ 93.365] Initializing built-in extension COMPOSITE
[ 93.373] Initializing built-in extension DAMAGE
[ 93.381] Initializing built-in extension MIT-SCREEN-SAVER
[ 93.389] Initializing built-in extension DOUBLE-BUFFER
[ 93.396] Initializing built-in extension RECORD
[ 93.402] Initializing built-in extension DPMS
[ 93.408] Initializing built-in extension Present
[ 93.414] Initializing built-in extension DRI3
[ 93.420] Initializing built-in extension X-Resource
[ 93.425] Initializing built-in extension XVideo
[ 93.430] Initializing built-in extension XVideo-MotionCompensation
[ 93.435] Initializing built-in extension SELinux
[ 93.439] Initializing built-in extension XFree86-VidModeExtension
[ 93.443] Initializing built-in extension XFree86-DGA
[ 93.447] Initializing built-in extension XFree86-DRI
[ 93.450] Initializing built-in extension DRI2
[ 93.450] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[ 93.450] (WW) "xmir" is not to be loaded by default. Skipping.
[ 93.450] (II) LoadModule: "glx"
[ 93.483] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 95.516] (II) Module glx: vendor="NVIDIA Corporation"
[ 95.516] compiled for 4.0.2, module version = 1.0.0
[ 95.516] Module class: X.Org Server Extension
[ 95.532] (II) NVIDIA GLX Module 340.32 Tue Aug 5 20:32:43 PDT 2014
[ 95.581] Loading extension GLX
[ 95.581] (II) LoadModule: "nvidia"
[ 95.581] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 95.755] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 95.755] compiled for 4.0.2, module version = 1.0.0
[ 95.755] Module class: X.Org Video Driver
[ 95.766] (II) NVIDIA dlloader X Driver 340.32 Tue Aug 5 20:13:04 PDT 2014
[ 95.766] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 95.768] (--) using VT number 7

[ 95.805] (II) Loading sub module "fb"
[ 95.805] (II) LoadModule: "fb"
[ 95.805] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 95.825] (II) Module fb: vendor="X.Org Foundation"
[ 95.825] compiled for 1.15.1, module version = 1.0.0
[ 95.825] ABI class: X.Org ANSI C Emulation, version 0.4
[ 95.825] (WW) Unresolved symbol: fbGetGCPrivateKey
[ 95.826] (II) Loading sub module "wfb"
[ 95.826] (II) LoadModule: "wfb"
[ 95.826] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 95.841] (II) Module wfb: vendor="X.Org Foundation"
[ 95.841] compiled for 1.15.1, module version = 1.0.0
[ 95.841] ABI class: X.Org ANSI C Emulation, version 0.4
[ 95.841] (II) Loading sub module "ramdac"
[ 95.841] (II) LoadModule: "ramdac"
[ 95.841] (II) Module "ramdac" already built-in
[ 96.486] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[ 96.486] (==) NVIDIA(0): RGB weight 888
[ 96.486] (==) NVIDIA(0): Default visual is TrueColor
[ 96.486] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 96.486] (**) NVIDIA(0): Enabling 2D acceleration
[ 96.615] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please
[ 96.615] (EE) NVIDIA(GPU-0): check your system's kernel log for additional error
[ 96.615] (EE) NVIDIA(GPU-0): messages and refer to Chapter 8: Common Problems in the
[ 96.615] (EE) NVIDIA(GPU-0): README for additional information.
[ 96.615] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[ 96.615] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 96.615] (II) UnloadModule: "nvidia"
[ 96.615] (II) UnloadSubModule: "wfb"
[ 96.615] (II) UnloadSubModule: "fb"
[ 96.615] (EE) Screen(s) found, but none have a usable configuration.
[ 96.615] (EE)
Fatal server error:
[ 96.615] (EE) no screens found(EE)
[ 96.615] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 96.615] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 96.615] (EE)
[ 96.668] (EE) Server terminated with error (1). Closing log file.
 
Old 08-16-2014, 03:54 PM   #6
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,374

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
Maybe look at this. See if your issues are similar. https://wiki.debian.org/KernelModesetting
 
Old 08-16-2014, 04:06 PM   #7
FreakofPurple
LQ Newbie
 
Registered: Aug 2014
Distribution: Ubuntu 14.10 Utopic Unicorn 64-bit
Posts: 13

Original Poster
Rep: Reputation: 0
I don't use Debian, and I don't use any of the mentioned drivers. I use the driver downloaded from the nVidia website, not the ones from APT. I've already added the nomodeset to the file. I will try blacklisting though. Thanks for the reply.

Last edited by FreakofPurple; 08-16-2014 at 04:08 PM.
 
Old 08-16-2014, 04:15 PM   #8
selfprogrammed
Member
 
Registered: Jan 2010
Location: Minnesota, USA
Distribution: Slackware 13.37
Posts: 290

Rep: Reputation: 55
There have been several postings about Linux Mint. Have to guess at the particulars that Linux Mint version. I do not know how many readers here will know Linux Mint version enough to respond without more details. In the log I found that it is Linux 3.2. There are many options in Linux compilation that can affect nVidia drivers and I do not know which are present in that Linux distribution.

I also have had trouble with nVidia drivers, 304.xx, on Linux 2.6. I have not heard of any newer versions of Xorg or Linux that fix these problems so I assume they are still relevant to the Linux that Mint contains.

The possible drivers for nVidia hardware are: nv driver, nouveau driver, vesa driver, and then there is the proprietary nVidia drivers such as 340.xx . The fb driver provides a framebuffer, and I suspect wfb is another version of framebuffer. Only one can be driving the video card. Your listing shows more than one loading.

Cannot have both proprietary nVidia and Nouveau driver, pick only one. They conflict badly.
The nouveau drivers uses the KMS (Kernel Mode Switch), which will lock-out the nVidia driver because it does not use it, and cannot work around it. The nVidia proprietary driver would prefer that the KMS feature brought in by the Kernel framebuffer option was not present in the kernel.

The Nouveau driver can be blacklisted so that driver cannot load. Search for Nouveau blacklisting for methods how. When nouveau is not around to activate KMS, it does not block the nVidia proprietary driver.

I have had to drop back to using 96.xx drivers because I cannot get a GeForce 6200 to hand-off to the console drivers with the 304.xx and 174.xx drivers. The 96.xx driver cannot handle suspend with this 6200. There are many possible bad interactions with kernel options such as KMS and kernel framebuffers and I have not solved the puzzle. I am ready to try nouveau again.

Last edited by selfprogrammed; 08-16-2014 at 04:36 PM.
 
1 members found this post helpful.
Old 08-16-2014, 07:34 PM   #9
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Have you checked Xorg.0.log for the additional info?
 
Old 08-16-2014, 08:03 PM   #10
FreakofPurple
LQ Newbie
 
Registered: Aug 2014
Distribution: Ubuntu 14.10 Utopic Unicorn 64-bit
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks to selfprogrammed, that helped me learn more. EDDY1, I've posted the log there you can take a look if you want.
 
Old 08-17-2014, 11:36 AM   #11
FreakofPurple
LQ Newbie
 
Registered: Aug 2014
Distribution: Ubuntu 14.10 Utopic Unicorn 64-bit
Posts: 13

Original Poster
Rep: Reputation: 0
Here's an updated log. I tried blacklisting nouveau but it didn't seem to help.

[ 74.389]
X.Org X Server 1.15.1
Release Date: 2014-04-13
[ 74.411] X Protocol Version 11, Revision 0
[ 74.418] Build Operating System: Linux 3.2.0-37-generic x86_64 Ubuntu
[ 74.434] Current Operating System: Linux freakofpurple-TRANSPORT-T2500-154-E 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64
[ 74.434] Kernel command line: BOOT_IMAGE=/vmlinuz-3.13.0-24-generic root=/dev/mapper/mint--vg-root ro text nomodeset
[ 74.458] Build Date: 16 April 2014 01:36:29PM
[ 74.475] xorg-server 2:1.15.1-0ubuntu2 (For technical support please see http://www.ubuntu.com/support)
[ 74.484] Current version of pixman: 0.30.2
[ 74.502] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 74.502] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 74.540] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 17 11:32:49 2014
[ 74.597] (==) Using config file: "/etc/X11/xorg.conf"
[ 74.608] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 74.680] (==) ServerLayout "Layout0"
[ 74.680] (**) |-->Screen "Screen0" (0)
[ 74.680] (**) | |-->Monitor "Monitor0"
[ 74.680] (**) | |-->Device "Device0"
[ 74.680] (**) |-->Input Device "Keyboard0"
[ 74.680] (**) |-->Input Device "Mouse0"
[ 74.680] (==) Automatically adding devices
[ 74.680] (==) Automatically enabling devices
[ 74.680] (==) Automatically adding GPU devices
[ 74.810] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/cyrillic,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[ 74.810] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 74.810] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 74.810] (WW) Disabling Keyboard0
[ 74.810] (WW) Disabling Mouse0
[ 74.810] (II) Loader magic: 0x7fd290b6ed60
[ 74.811] (II) Module ABI versions:
[ 74.811] X.Org ANSI C Emulation: 0.4
[ 74.811] X.Org Video Driver: 15.0
[ 74.811] X.Org XInput driver : 20.0
[ 74.811] X.Org Server Extension : 8.0
[ 74.814] (--) PCI:*(0:1:0:0) 10de:0425:144d:c02f rev 161, Mem @ 0xca000000/16777216, 0xd0000000/268435456, 0xc8000000/33554432, I/O @ 0x00005000/128
[ 74.825] Initializing built-in extension Generic Event Extension
[ 74.837] Initializing built-in extension SHAPE
[ 74.848] Initializing built-in extension MIT-SHM
[ 74.859] Initializing built-in extension XInputExtension
[ 74.870] Initializing built-in extension XTEST
[ 74.881] Initializing built-in extension BIG-REQUESTS
[ 74.892] Initializing built-in extension SYNC
[ 74.903] Initializing built-in extension XKEYBOARD
[ 74.913] Initializing built-in extension XC-MISC
[ 74.924] Initializing built-in extension SECURITY
[ 74.934] Initializing built-in extension XINERAMA
[ 74.944] Initializing built-in extension XFIXES
[ 74.954] Initializing built-in extension RENDER
[ 74.963] Initializing built-in extension RANDR
[ 74.972] Initializing built-in extension COMPOSITE
[ 74.980] Initializing built-in extension DAMAGE
[ 74.988] Initializing built-in extension MIT-SCREEN-SAVER
[ 74.995] Initializing built-in extension DOUBLE-BUFFER
[ 75.002] Initializing built-in extension RECORD
[ 75.009] Initializing built-in extension DPMS
[ 75.015] Initializing built-in extension Present
[ 75.021] Initializing built-in extension DRI3
[ 75.026] Initializing built-in extension X-Resource
[ 75.032] Initializing built-in extension XVideo
[ 75.037] Initializing built-in extension XVideo-MotionCompensation
[ 75.041] Initializing built-in extension SELinux
[ 75.046] Initializing built-in extension XFree86-VidModeExtension
[ 75.050] Initializing built-in extension XFree86-DGA
[ 75.053] Initializing built-in extension XFree86-DRI
[ 75.057] Initializing built-in extension DRI2
[ 75.057] (II) LoadModule: "glx"
[ 75.118] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 77.488] (II) Module glx: vendor="NVIDIA Corporation"
[ 77.488] compiled for 4.0.2, module version = 1.0.0
[ 77.488] Module class: X.Org Server Extension
[ 77.501] (II) NVIDIA GLX Module 340.32 Tue Aug 5 20:32:43 PDT 2014
[ 77.518] Loading extension GLX
[ 77.518] (II) LoadModule: "nvidia"
[ 77.518] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 77.666] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 77.666] compiled for 4.0.2, module version = 1.0.0
[ 77.666] Module class: X.Org Video Driver
[ 77.677] (II) NVIDIA dlloader X Driver 340.32 Tue Aug 5 20:13:04 PDT 2014
[ 77.677] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 77.679] (--) using VT number 7

[ 77.716] (II) Loading sub module "fb"
[ 77.716] (II) LoadModule: "fb"
[ 77.716] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 77.736] (II) Module fb: vendor="X.Org Foundation"
[ 77.736] compiled for 1.15.1, module version = 1.0.0
[ 77.736] ABI class: X.Org ANSI C Emulation, version 0.4
[ 77.737] (WW) Unresolved symbol: fbGetGCPrivateKey
[ 77.737] (II) Loading sub module "wfb"
[ 77.737] (II) LoadModule: "wfb"
[ 77.737] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 77.752] (II) Module wfb: vendor="X.Org Foundation"
[ 77.752] compiled for 1.15.1, module version = 1.0.0
[ 77.752] ABI class: X.Org ANSI C Emulation, version 0.4
[ 77.752] (II) Loading sub module "ramdac"
[ 77.752] (II) LoadModule: "ramdac"
[ 77.752] (II) Module "ramdac" already built-in
[ 78.355] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[ 78.355] (==) NVIDIA(0): RGB weight 888
[ 78.355] (==) NVIDIA(0): Default visual is TrueColor
[ 78.355] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 78.356] (**) NVIDIA(0): Enabling 2D acceleration
[ 78.498] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please
[ 78.498] (EE) NVIDIA(GPU-0): check your system's kernel log for additional error
[ 78.498] (EE) NVIDIA(GPU-0): messages and refer to Chapter 8: Common Problems in the
[ 78.498] (EE) NVIDIA(GPU-0): README for additional information.
[ 78.498] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[ 78.498] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 78.498] (II) UnloadModule: "nvidia"
[ 78.498] (II) UnloadSubModule: "wfb"
[ 78.498] (II) UnloadSubModule: "fb"
[ 78.498] (EE) Screen(s) found, but none have a usable configuration.
[ 78.498] (EE)
Fatal server error:
[ 78.498] (EE) no screens found(EE)
[ 78.498] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 78.498] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 78.498] (EE)
[ 78.536] (EE) Server terminated with error (1). Closing log file.
 
Old 08-17-2014, 11:40 AM   #12
FreakofPurple
LQ Newbie
 
Registered: Aug 2014
Distribution: Ubuntu 14.10 Utopic Unicorn 64-bit
Posts: 13

Original Poster
Rep: Reputation: 0
On another forum, someone mentioned something about the correct PCI bus in the string Failed to initialize the NVIDIA GPU at PCI:1:0:0. I don't know what that means, can anyone help?

Last edited by FreakofPurple; 08-17-2014 at 11:41 AM.
 
Old 08-17-2014, 11:58 AM   #13
FreakofPurple
LQ Newbie
 
Registered: Aug 2014
Distribution: Ubuntu 14.10 Utopic Unicorn 64-bit
Posts: 13

Original Poster
Rep: Reputation: 0
I am going to do a fresh install of Linux Mint again. Thanks for the help. I will notify you if this problem persists.
 
Old 08-17-2014, 09:45 PM   #14
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,374

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
By the way. Mint is based on Ubuntu which is based on Debian.

Use your problem and also search for each of those for answers. They tend to be the same.

Last edited by jefro; 08-17-2014 at 09:46 PM.
 
Old 08-19-2014, 06:23 PM   #15
selfprogrammed
Member
 
Registered: Jan 2010
Location: Minnesota, USA
Distribution: Slackware 13.37
Posts: 290

Rep: Reputation: 55
[ 78.498] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 78.498] (II) UnloadModule: "nvidia"
[ 78.498] (II) UnloadSubModule: "wfb"
[ 78.498] (II) UnloadSubModule: "fb"
[ 78.498] (EE) Screen(s) found, but none have a usable configuration.

This problem is in /etc/X11/Xorg.conf.
See:
>> man Xorg.conf

The Xorg.conf specifies a monitor, a video card and driver, keyboard, mouse each in separate sections. There can be more than one.
The Screen configuration section (last thing in the file) specifies a combination of monitor, video card driver, etc.

This problem occurs when the screen used does not specify a valid combination. This would happen if it was using the nouveau driver and now that driver is blacklisted.

[ 74.680] (**) |-->Screen "Screen0" (0)
[ 74.680] (**) | |-->Monitor "Monitor0"
[ 74.680] (**) | |-->Device "Device0"
[ 74.680] (**) |-->Input Device "Keyboard0"
[ 74.680] (**) |-->Input Device "Mouse0"

The proprietary nVidia driver install offers to update the Xorg.conf, but that does not mean it always gets it right.

This section shows the nVidia driver loading, but having an error.
[ 78.498] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please
[ 78.498] (EE) NVIDIA(GPU-0): check your system's kernel log for additional error
[ 78.498] (EE) NVIDIA(GPU-0): messages and refer to Chapter 8: Common Problems in the
[ 78.498] (EE) NVIDIA(GPU-0): README for additional information.
[ 78.498] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[ 78.498] (EE) NVIDIA(0): Failing initialization of X screen 0

We assume your nVidia card is at that PCI address.
It could be that KMS is active and that could be blocking the nVidia driver from accessing the hardware. Usually that happens after nouveau does setup on the video card, but it may be that something else (like framebuffer) getting KMS to grab the hardware.

It could also be something else. This Xorg is newer than the one I use and it looks to me to be loading several extraneous things. I see the KMS, which nVidia is not going to like.

To get that README, unpack the nVidia driver with the --extract_only switch. You will a directory with everything in it. The README is in there.

You might try uninstalling the nVidia driver and then trying to startx. The console will still work because it uses a generic VGA driver. If X starts, then there is another driver in that Xorg is using and that could be a conflict problem. The VESA driver makes calls to VESA information that comes from the video card itself. It would be interesting to see if the video card is responding. I do not see the video card identity in your Xorg log and it should be there. Check the system logs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] problems with xorg.conf and nvidia drivers 0zMe Slackware 10 01-30-2013 01:20 PM
nv Vs. nvidia in xorg.conf -- Resolution Problems treth Linux - Laptop and Netbook 2 03-30-2010 03:42 AM
Problems with Nvidia and Xorg 1.7.5 linus72 Linux - General 11 03-27-2010 04:12 PM
Xinerama, nVidia, Triple-head xorg problems livewire98801 Linux - Desktop 6 07-16-2008 06:36 PM
Xorg.conf Problems with Nvidia video card Ubuntu kickerkeeper Linux - General 3 03-16-2007 10:59 AM


All times are GMT -5. The time now is 02:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration