LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-05-2013, 08:59 PM   #1
doughyi8u
Member
 
Registered: Apr 2010
Posts: 229

Rep: Reputation: 10
xorg not starting under non-root user


I just upgraded to 7.1 "wheezy" and now am unable to log in to xwindows via gdm3 or startx but can start x w/ startx as root. I know I haven't given much info but if there's anything I can do to help you help me, let me know.

Thanks for any help.
 
Old 09-05-2013, 09:35 PM   #2
doughyi8u
Member
 
Registered: Apr 2010
Posts: 229

Original Poster
Rep: Reputation: 10
I created another non-root user and was able to login to xorg just fine. There was something wrong w/ that user evidently. I removed the user in question and added him back and it works fine. Does anyone know why that one user wouldn't login?
 
Old 09-05-2013, 10:00 PM   #3
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,654

Rep: Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255
Very likely the home directory was messed up some how. Specificlly, the ownership of the .Xauthority (depending on WHERE it is stored - the default is the users home directory, but gnome has the nasty habit of sticking it in other locations).
 
Old 09-07-2013, 05:41 PM   #4
doughyi8u
Member
 
Registered: Apr 2010
Posts: 229

Original Poster
Rep: Reputation: 10
thanks ipollard
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf.new only works as root, not as user..? Wiz22 Linux - Newbie 23 09-15-2005 12:11 PM
Some questions - root user, xorg cb951303 Slackware 4 08-18-2004 11:17 AM
Starting a service as non root user? dee3lmo Linux - General 2 07-30-2004 08:37 PM
X server not starting as non root user Draylath Linux - Newbie 16 06-25-2004 03:02 PM
Starting mysql daemon as user rather than root arubin Slackware 8 05-10-2004 05:03 PM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration