LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-09-2007, 11:31 AM   #1
RevenantSeraph
Member
 
Registered: Jan 2007
Distribution: Ubuntu
Posts: 66

Rep: Reputation: 15
Xorg -config "fatal server error"


Forgive my extreme newbishness... I'm just trying to change the Xorg configuration, as I've done many times, but all of a sudden it said:

> Xorg -configure

> Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


In a previous session I'd been using ssh, so I figured that it must still be connected or something, so I connected again and logged out, but it didn't help. Thus I went into /tmp and removed .X0-lock. Now when I try it,

> Xorg -configure

> Fatal server error:
Cannot move old log file ("/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old"


... Did I just do something very stupid?

Last edited by RevenantSeraph; 04-09-2007 at 11:36 AM.
 
Old 04-09-2007, 05:10 PM   #2
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Based on that stuff you posted, just copy the .old file to the same directory it is already in, but rename it without the .old extension.

As far as killing X on ubuntu, running Gnome, you have to run /etc/X11/gdm kill ( I **think** that's the command--- I have the /etc and /gdm right, but I'm not sure it's in /X11 )..
I'll come back in a moment with the right command.
And no, it isn't serious or very stupid

UPDATE: /etc/init.d/gdm stop is how to stop X when running Gnome.. type this in a root console.

Last edited by GrapefruiTgirl; 04-09-2007 at 05:13 PM.
 
Old 04-09-2007, 08:17 PM   #3
RevenantSeraph
Member
 
Registered: Jan 2007
Distribution: Ubuntu
Posts: 66

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by GrapefruiTgirl
Based on that stuff you posted, just copy the .old file to the same directory it is already in, but rename it without the .old extension...
UPDATE: /etc/init.d/gdm stop is how to stop X when running Gnome.. type this in a root console.
So, I killed X like you mentioned, then tried it again. It listed the first error I had, then I deleted the new tmp file, it gave me the second error. It had already come up with a new .old log and still had the regular log. So I tried deleting the not-old log as well as the old log, and then putting in its place the old log renamed as the not-old log. It then gave me error number two again.

What does it want from me? Is there any way to restore it to default so I can get Xorg -configure to actually run?

... And it's reassuring to know I'm not totally messing things up!

Last edited by RevenantSeraph; 04-09-2007 at 08:18 PM.
 
Old 04-09-2007, 08:20 PM   #4
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Are you running the -configure command as root, or as user? If using your user account, try using root..

Post if that works; if not I'll look into it further

Also, in a console, type 'top' and see if there is any X process running, which would be using the file. If there is, then it maybe won't be able to delete or move the file(s). If so, try killing the process (and the ssh process too, if it's still running.
I don't know the *exact* command to kill a process, but type 'man kill' in a console and it should tell you how to use it.... Something like:

kill 123
or
ps 123 -kill

Last edited by GrapefruiTgirl; 04-09-2007 at 08:23 PM.
 
Old 04-09-2007, 08:27 PM   #5
RevenantSeraph
Member
 
Registered: Jan 2007
Distribution: Ubuntu
Posts: 66

Original Poster
Rep: Reputation: 15
I tried sudo Xorg -configure, but it gave me error number one again. I'm going to try to rm that tmp file again, be back in a sec...
 
Old 04-09-2007, 08:30 PM   #6
RevenantSeraph
Member
 
Registered: Jan 2007
Distribution: Ubuntu
Posts: 66

Original Poster
Rep: Reputation: 15
It gives me error #2 again.
 
Old 04-09-2007, 08:35 PM   #7
RevenantSeraph
Member
 
Registered: Jan 2007
Distribution: Ubuntu
Posts: 66

Original Poster
Rep: Reputation: 15
Top tells me there's an Xorg running under root, even after I stopped GNOME (again) as mentioned earlier. I tried kill Xorg, but the syntax seems to be wrong.

Edit: so, I rebooted and typed top into Terminal as fast as possible, and watched. At first there was no Xorg, then it started again as I watched. I stopped the /etc process, but the top Xorg process didn't even blink.

Last edited by RevenantSeraph; 04-09-2007 at 08:42 PM.
 
Old 04-09-2007, 08:57 PM   #8
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Hmmm..
in the console, as root, type 'telinit 1'
This "should" kill *everything*, and drop you at single-user mode, with nothing running.
You will need to log in again. From there, try your xorg-configure stuff..
Let us know how it goes
Good luck, *fingers crossed*
 
Old 04-09-2007, 08:59 PM   #9
RevenantSeraph
Member
 
Registered: Jan 2007
Distribution: Ubuntu
Posts: 66

Original Poster
Rep: Reputation: 15
Before I do that, how do I un-telinit, so that I can come back once it's done?
 
Old 04-09-2007, 09:03 PM   #10
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Well, with ubuntu, if you telinit to any level other than 1, it will restart X again... I don't think you want that.
But, if you get done what you are trying to do, then use 'telinit 3' or 4 or 5.. Just not 0 or 6, or it will reboot.
 
Old 04-09-2007, 09:07 PM   #11
RevenantSeraph
Member
 
Registered: Jan 2007
Distribution: Ubuntu
Posts: 66

Original Poster
Rep: Reputation: 15
Okay, so it theoretically starts up Xorg -config, but now it says that it doesn't recognize my mouse, and just stops there. I imagine that's because that process was killed. What now?

And I am ***so*** extremely grateful for your time.
 
Old 04-09-2007, 09:11 PM   #12
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
do you need the mouse right now, absolutely ??

The mouse driver is generally installed by X (lol, catch 22) , so I'm not totally sure if you...
Well, try running the mouse server by typing 'gpm start' or '/etc/init.d/gpm start' .. I am not sure where the gpm file is located. I'll check my system for clues and get back to you..

And, you're welcome, I hope this works for you in the end

Last edited by GrapefruiTgirl; 04-09-2007 at 09:13 PM.
 
Old 04-09-2007, 09:13 PM   #13
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Mine is located at /usr/sbin/gpm so if yours is in the same place, try:
./usr/sbin/gpm
or
./usr/sbin/gpm start
or
/usr/sbin/gpm start
or just
gpm
..or if you have to, navigate to the directory and type 'gpm'

Last edited by GrapefruiTgirl; 04-09-2007 at 09:18 PM.
 
Old 04-09-2007, 09:19 PM   #14
RevenantSeraph
Member
 
Registered: Jan 2007
Distribution: Ubuntu
Posts: 66

Original Poster
Rep: Reputation: 15
It won't seem to let me get any further without a mouse.

I have tried gpm, gpm start, /usr/sbin gpm start, /usr/sbin/gpm start (there is no gpm in that directory), /etc/init.d/gpm start...

Can I look somewhere or have it tell me where mine is, in terminal or a gui?

Also, have you found a way just to kill the Xorg process? My reading of man kill has not amounted in much.

Edit: I have gone into xorg.conf, but it didn't tell me anything I found helpful. Maybe it will help you, but I think it won't tell you much.

xorg.conf:
...
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
...

Last edited by RevenantSeraph; 04-09-2007 at 09:31 PM.
 
Old 04-09-2007, 09:31 PM   #15
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
OK, in the manual, the mouse server says to just type gpm, and when I did, it said I didn't specify a device.
So I am guessing that 'gpm /dev/mouse' or whatever your mouse device is called, should work..
If you don't use gpm on ubuntu, I have no idea what to do next for the mouse..

For killing a process, use 'top' to get the process number and then:

kill -123

where 123 was the process number.
You might also try 'kill x' or 'kill X' or 'kill -X' as it claims you can use the process name too.

try 'man gpm' and see if you get the manual page for gpm, to see if it is even on your system.

EDIT: It really looks like GPM depends on X anyways.. It is asking me for a mouse#1, and my existing mouse is mouse#0, so... I guess it needs to be specified in X first..

EDIT: Here is the command my system uses to restart gpm:
/usr/sbin/gpm -m /dev/mouse -t imps2

Last edited by GrapefruiTgirl; 04-09-2007 at 09:38 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
XIO: fatal IO error 04 (connection reset by peer) on X server ":0.0" Kernel 2.6.5 Slackware 15 10-29-2007 12:53 AM
"Fatal server error. Caught signal 11, server aborting" please help ! Fear58 Linux - General 2 10-16-2007 11:33 PM
"Fatal server error: no screens found" in gentoo andrewshen123 Linux - Distributions 33 01-21-2007 06:57 PM
fatal IO error 104 (connection reset by peer) on X Server ":0.0" Post Modern Linux - Desktop 2 09-20-2006 12:14 AM
XFree86: "Fatal server error: no screens found" warkrime Linux - Newbie 9 09-23-2003 08:07 PM


All times are GMT -5. The time now is 02:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration