LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-29-2005, 12:41 PM   #1
firedance
Member
 
Registered: Dec 2003
Location: Sweden
Distribution: Arch Linux
Posts: 65

Rep: Reputation: 15
xorg.conf with dualscreen


Maybe there is something wrong with the search function because i didn't find anything.

OK, I'm using ARCH with radeon 9600 (fglrx driver)
I have managed to get both screens showing one desktop each (Where does it read the second desktops settings? They are default for me)

I want to have a xinerama desktop, where i can drag apps between the screens, but when trying to make this work in the xorg.conf the best i managed to get was that both screens showed exactly the same exept the mouse cursor, If i right-clicked the right screen I got a menu on both, but if i right-clicked the left screen I got no menu this made me think that there was a second part of the desktop but the left screen was showing the wrong part.
Anyone who has had this problem and knows how to solve it?
I use X Window System Version 6.8.2 and Fluxbox 0.1.14

-edit-
Also my tft screen blinks black (2 secs black) sometimes after I changed to the fglrx drivers.

Last edited by firedance; 04-29-2005 at 12:44 PM.
 
Old 04-29-2005, 01:17 PM   #2
camlinux
Member
 
Registered: Feb 2003
Location: north dakota
Distribution: Gentoo, Debian
Posts: 90

Rep: Reputation: 15
What does your xorg.conf look like, also what did you search for, their are probably 700 posts on this subject in the forum.
 
Old 04-29-2005, 02:42 PM   #3
firedance
Member
 
Registered: Dec 2003
Location: Sweden
Distribution: Arch Linux
Posts: 65

Original Poster
Rep: Reputation: 15
my search was 'dualscreen' and 'xorg dualscreen'


The xorg config had alot of comments so I removed most of them
I also uploaded the full one to http://www.webbportalen.com/firedance/xorg.conf.txt
Code:
Section "Module"
    Load        "dbe"  	# Double buffer extension
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
    Load        "type1"
    Load        "freetype"
    Load       "glx"
    Load       "dri"
        Load  "record"
	Load  "xtrap"
EndSection

Section "Files"
    RgbPath	"/usr/X11R6/lib/X11/rgb"
    FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath   "/usr/X11R6/lib/X11/fonts/TTF/"
    FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath   "/usr/X11R6/lib/X11/fonts/CID/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/local/"
    ModulePath "/usr/X11R6/lib/modules"
EndSection

Section "ServerFlags"
Option	    "Xinerama" "true"
EndSection



Section "InputDevice"
    Identifier	"Keyboard1"
    Driver	"kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"	"xorg"
    Option "XkbModel"	"rapidaccess2"
    Option "XkbLayout"	"se"
EndSection



Section "InputDevice"
    Identifier	"Mouse1"
    Driver	"mouse"
    Option "Protocol"    "PS/2"
    Option "Device"      "/dev/input/mice"
EndSection

Section "Monitor"
    Identifier  "Hansol 920P"
    HorizSync   31.5 - 82.0
    VertRefresh 50-100
   Option "DPMS" ##
EndSection

Section "Monitor"
	Identifier "IBM"
    Option "DPMS" ##
EndSection



Section "Device"
    Identifier	"Standard VGA"
    VendorName	"Unknown"
    BoardName	"Unknown"
    Driver     "vga"
EndSection


Section "Device"
    Identifier  "Radeon 9600x0"
    Driver      "fglrx"
    #Option                              "NoDDC"
    Option "no_accel"                   "no"
    Option "no_dri"                     "no"
 ##   Option "DesktopSetup"               "0x00000000" 
    Option "MonitorLayout"              "AUTO, AUTO"
    Option "IgnoreEDID"                 "off"
    Option "HSync2"                     "31.5 - 80.5" 
    Option "VRefresh2"                  "60 - 100" 
    Option "ScreenOverlap"              "0" 
    Option "NoTV"                       "no"     
    Option "TVStandard"                 "NTSC-M"     
    Option "TVHSizeAdj"                 "0"     
    Option "TVVSizeAdj"                 "0"     
    Option "TVHPosAdj"                  "0"     
    Option "TVVPosAdj"                  "0"     
    Option "TVHStartAdj"                "0"     
    Option "TVColorAdj"                 "0"     
    Option "GammaCorrectionI"           "0x00000000"
    Option "GammaCorrectionII"          "0x00000000"
    Option "Capabilities"               "0x00000000"
    Option "VideoOverlay"               "on"
    Option "OpenGLOverlay"              "off"
    Option "CenterMode"                 "off"
    Option "PseudoColorVisuals"         "off"
    Option "Stereo"                     "off"
    Option "StereoSyncEnable"           "1"
    Option "FSAAEnable"                 "no"
    Option "FSAAScale"                  "1"
   Option "FSAADisableGamma"           "no"
    Option "FSAACustomizeMSPos"         "no"
    Option "FSAAMSPosX0"                "0.000000"
    Option "FSAAMSPosY0"                "0.000000"
    Option "FSAAMSPosX1"                "0.000000"
    Option "FSAAMSPosY1"                "0.000000"
    Option "FSAAMSPosX2"                "0.000000"
    Option "FSAAMSPosY2"                "0.000000"
    Option "FSAAMSPosX3"                "0.000000"
    Option "FSAAMSPosY3"                "0.000000"
    Option "FSAAMSPosX4"                "0.000000"
    Option "FSAAMSPosY4"                "0.000000"
    Option "FSAAMSPosX5"                "0.000000"
    Option "FSAAMSPosY5"                "0.000000"
    Option "UseFastTLS"                 "2"
    Option "BlockSignalsOnLock"         "on"
    Option "UseInternalAGPGART"         "yes"
    Option "ForceGenericCPU"            "no"
    BusID "PCI:1:0:0"    # vendor=1002, device=4150
    Screen 0
EndSection

Section "Device"
       Identifier  "Radeon 9600x1"
       Driver      "fglrx"
	BusID "PCI:1:0:0"    # vendor=1002, device=4150
	Screen 1
EndSection
		


	# Any number of screen sections may be present.  Each describes
Section "Screen"
    Identifier  "Screen0"
    Device      "Radeon 9600x0"
    Monitor     "Hansol 920P"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
       Modes "1280x1024"
	# Modes       "1280x1024" "1024x768" "800x600" "640x480"
   EndSubsection
    Subsection "Display"
        Depth       16
     Modes "1280x1024"
	#   Modes       "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       24
       Modes "1280x1024"
	# Modes       "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device "Radeon 9600x1"
	Monitor "IBM"
	DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
	ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
    #	Modes "1024x768"  
      ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
     # Modes "1024x768" 
       ViewPort    0 0
    EndSubsection
EndSection

Section "ServerLayout"
Identifier "Multihead Layout"

Screen 0 "Screen0" 0 0  # LeftOf "Screen1"
Screen 1 "Screen1" LeftOf "Screen0" # 0 0

Option "Clone" "off"
Option "Xinerama" "on"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection

 Section "DRI"
    Mode 0666
 EndSection
 
Old 04-30-2005, 05:32 AM   #4
firedance
Member
 
Registered: Dec 2003
Location: Sweden
Distribution: Arch Linux
Posts: 65

Original Poster
Rep: Reputation: 15
Agh, got it working used fglrxconfig that made my config REALLY weird, but it works.

Last edited by firedance; 04-30-2005 at 06:25 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf satinet Slackware 4 02-21-2005 04:40 PM
xorg.conf Duo Slackware 4 01-07-2005 09:57 PM
xorg.conf chunlee Linux - Newbie 2 12-27-2004 03:59 PM
Where is xorg.conf? Royle Linux - General 5 11-07-2004 04:40 PM
Xorg Hard Crashes and corrupts xorg.conf Advocator Linux - General 0 07-15-2004 02:41 PM


All times are GMT -5. The time now is 08:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration