LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-06-2005, 01:47 PM   #1
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Rep: Reputation: 30
Xorg 915 "Sonoma" chipset


I have an Arch linux install and while X works using the vesa driver I can't get it to use the 915 or 810 driver. I had been getting this odd error about PCI:0:2:1 not having a device, but I was able to get that error to go away. Now I'm stuck with a vague no screens found error.

I've tried using i915 instead of i810 but it makes no difference (I modprobed the appropriate one and removed the unused one to test). Here is my xorg.conf file (X 6.8.2) and my log file showing the error at the end. Any help would be appreciated!

Code:
Section "ServerLayout"
	Identifier     "XFree86 Configured"
	Screen      0  "Screen0" 0 0
	Screen	    1  "Screen1" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "PS/2 Mouse" "CorePointer"
# Serial Mouse not detected
# USB Mouse not detected
EndSection

Section "ServerFlags"
	Option "AllowMouseOpenFail"  "true"
	
EndSection

Section "Files"
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	ModulePath   "/usr/X11R6/lib/modules"
	FontPath     "/usr/X11R6/lib/X11/fonts/misc:unscaled"
	FontPath     "/usr/X11R6/lib/X11/fonts/misc"
	FontPath     "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
	FontPath     "/usr/X11R6/lib/X11/fonts/75dpi"
	FontPath     "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
	FontPath     "/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath     "/usr/X11R6/lib/X11/fonts/PEX"
# Additional fonts: Locale, Gimp, TTF...
	FontPath     "/usr/X11R6/lib/X11/fonts/cyrillic"
#	FontPath     "/usr/X11R6/lib/X11/fonts/latin2/75dpi"
#	FontPath     "/usr/X11R6/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
	FontPath     "/usr/X11R6/lib/X11/fonts/Type1"
	FontPath     "/usr/share/fonts/ttf/western"
	FontPath     "/usr/share/fonts/ttf/decoratives"
	FontPath     "/usr/share/fonts/truetype"
	FontPath     "/usr/share/fonts/truetype/openoffice"
	FontPath     "/usr/share/fonts/truetype/ttf-bitstream-vera"
	FontPath     "/usr/share/fonts/latex-ttf-fonts"
	FontPath     "/usr/X11R6/lib/X11/fonts/defoma/CID"
	FontPath     "/usr/X11R6/lib/X11/fonts/defoma/TrueType"
EndSection

Section "Module"
        Load  "ddc"  # ddc probing of monitor
	Load  "GLcore"
	Load  "dbe"
	Load  "dri"
	Load  "extmod"
	Load  "glx"
        Load  "bitmap" # bitmap-fonts
	Load  "type1"
	Load  "freetype"
	Load  "record"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "keyboard"
        Option      "CoreKeyboard"
	Option "XkbRules" "xfree86"
	Option "XkbModel" "pc105"
	Option "XkbLayout" ""
	Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
	Identifier  "Serial Mouse"
	Driver      "mouse"
	Option      "Protocol" "Microsoft"
	Option      "Device" "/dev/ttyS0"
	Option      "Emulate3Buttons" "true"
	Option      "Emulate3Timeout" "70"
	Option	    "SendCoreEvents"  "true"
EndSection

Section "InputDevice"
	Identifier  "PS/2 Mouse"
	Driver      "mouse"
	Option      "Protocol" "auto"
	Option          "ZAxisMapping"          "4 5"
	Option      "Device" "/dev/psaux"
	Option      "Emulate3Buttons" "true"
	Option      "Emulate3Timeout" "70"
	Option	    "SendCoreEvents"  "true"
EndSection

Section "InputDevice"
        Identifier      "USB Mouse"
        Driver          "mouse"
        Option          "Device"                "/dev/input/mice"
	Option		"SendCoreEvents"	"true"
        Option          "Protocol"              "IMPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Buttons"               "5"
EndSection

# Auto-generated by Archie mkxcfg

Section "Monitor"
	Identifier "Monitor0"
	Option "DPMS" "true"
#	HorizSync    28.0 - 78.0 # Warning: This may fry very old Monitors
	HorizSync    28.0 - 96.0 # Warning: This may fry old Monitors
	VertRefresh  50.0 - 75.0 # Very conservative. May flicker.
#	VertRefresh  50.0 - 62.0 # Extreme conservative. Will flicker. TFT default.
EndSection

# Auto-generated by Archie mkxcfg

Section "Device"
	Identifier  "device0"
	Driver      "i810"
	VendorName  "Intel Corporation"
	BoardName   "Intel 915G"
	Screen 0
	BusID "PCI:0:2:0"
	Option "DPMS"
EndSection

Section "Device"
	Identifier "device1"
	Driver	   "i810"
	VendorName "Intel Corporation"
	BoardName  "Intel 915G"
	Screen 0
	BusID "PCI:0:2:1"
	Option "DPMS" 
EndSection
Section "Screen"
	Identifier "Screen0"
	Device     "device0"
	Monitor    "Monitor0"
	DefaultColorDepth 24
	Subsection "Display"
		Depth	24
		Modes "1024X768" "800x600" "640x480"
	EndSubSection
EndSection	
		
Section "Screen"
	Identifier "Screen1"
	Device     "device1"
	Monitor    "Monitor0"
	DefaultColorDepth 24
	SubSection "Display"
		Depth     1
		Modes "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     4
		Modes "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     8
		Modes "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     16
		Modes "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     24
		Modes "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     32
		Modes "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Mode 0666
EndSection
Log file:
Code:
(II) LoadModule: "i810"
(II) Loading /usr/X11R6/lib/modules/drivers/i810_drv.o
(II) Module i810: vendor="X.Org Foundation"
	compiled for 6.8.2, module version = 1.3.0
	Module class: X.Org Video Driver
	ABI class: X.Org Video Driver, version 0.7
(II) LoadModule: "keyboard"
(II) Loading /usr/X11R6/lib/modules/input/keyboard_drv.o
(II) Module keyboard: vendor="X.Org Foundation"
	compiled for 6.8.2, module version = 1.0.0
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.4
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="X.Org Foundation"
	compiled for 6.8.2, module version = 1.0.0
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.4
(II) I810: Driver for Intel Integrated Graphics Chipsets: i810, i810-dc100,
	i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G
(II) Primary Device is: PCI 00:02:0
(EE) No devices detected.
 
Old 07-28-2006, 01:57 AM   #2
slackster
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware
Posts: 12

Rep: Reputation: 0
dual device err

First of all, I'm afraid I don't have any answers for you. Sorry about that.

Second, I'm also having problems with the i915GM chip and X.org. But I have not even gotten rid of the dual device (PCI:0:2:0 PCI:0:2:1) problem. Could you please be so kind to tell me how you got that error to go away?

upd: I just scanned through your xorg.conf, is all it takes to add the 2nd device? because I believe I already tried that before (?)

Thanks a bunch

Last edited by slackster; 07-28-2006 at 01:58 AM.
 
Old 07-28-2006, 02:04 AM   #3
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
I can't remember.. it's been so long. But I think it had more to do with using a kernel that supported i915. Try using 2.6.15 or later and it should work.

It's supported out of the box with Dapper Drake..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DMA problem on chipset 915GM (Sonoma) unleashed Linux - Laptop and Netbook 4 01-09-2006 08:27 AM
trouble with forcedeth driver (have nvidia nforce chipset) under debian "sarge" baldy1324 Linux - Networking 1 10-17-2005 09:06 AM
How do you run "xorg.conf.back" file? in Toshiba laptop hajime_saitou0 Linux - Laptop and Netbook 1 09-14-2005 10:03 PM
Mandrake 10.1/GeForce 4600... xorg error "no screens found" SAFX Mandriva 8 10-18-2004 02:02 PM
**News** New Wireless Chipset "Rosedale" 30mi Range sovietpower Linux - Wireless Networking 3 09-09-2004 02:53 AM


All times are GMT -5. The time now is 09:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration