LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-26-2009, 04:31 PM   #1
adityasharma
Member
 
Registered: Jun 2009
Location: Noida
Distribution: RHEL 5
Posts: 39

Rep: Reputation: 16
Unhappy xmms unable to play songs


hi

i am stuck again i am unable to play songs on XMMS
it is intalled fine but what happen it the songa are not queuing up or can i play a single song

application does opens up but then when i try to add the song it does to plays it no error is shown. Below is an error i get when tried to open xmms from command line

also unabel to unistall it

aditya [working@localhost ~]$xmms
/usr/local/lib/xmms/Input/libmpg123.so: cannot restore segment prot after reloc: Permission denied
Message: device: default
 
Old 07-27-2009, 09:08 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Disable selinux.

http://michaelminn.com/linux/toshiba...5x-fedora5.php
Quote:
SELinux Issues: When I compiled and ran the open source media player at XMMS, I got the following error: are compilation issues with contemporary distributions

/usr/local/lib/xmms/Input/libmpg123.so: cannot restore
segment prot after reloc: Permission denied

The problem is caused by SELinux restricting the loading of dynamic libraries by programs. (reference) (reference) It's easy to fix by changing the security context of the XMMS libraries:

chcon -t texrel_shlib_t /usr/local/lib/xmms/*/*.so

The problem will also occur with Mozilla plugins and can be fixed with the same command

Alternatively, since this problem may appear for other packages, you can disable SELinux by changing a line in the /etc/sysconfig/selinux file to:

SELINUX=disabled
 
Old 07-30-2009, 01:50 AM   #3
adityasharma
Member
 
Registered: Jun 2009
Location: Noida
Distribution: RHEL 5
Posts: 39

Original Poster
Rep: Reputation: 16
Unhappy

Quote:
Originally Posted by Simon Bridge View Post
yes it is now working but have a new ploblem

please check the attache screen shot
Attached Images
File Type: jpg Screenshot.jpg (152.8 KB, 4 views)
 
Old 07-30-2009, 03:32 AM   #4
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Code:
Couldn't Open Audio
Please check that
Your soundcard is configured correctly
You have the correct output plugin selected
No other program is blocking the soundcard
It is most likely the second one. XMMS used to default to Arts and fedora uses alsa.

Go to the output plugins dialog - sorry, don't know where they keep it these days - and check.

Aside:
Seriously awesome wallpaper there dude!
Is it me or is your desktop just begging for conky?
http://i598.photobucket.com/albums/t...idge/conky.png
 
Old 07-30-2009, 09:02 AM   #5
adityasharma
Member
 
Registered: Jun 2009
Location: Noida
Distribution: RHEL 5
Posts: 39

Original Poster
Rep: Reputation: 16
Thumbs up

Quote:
Originally Posted by Simon Bridge View Post
Code:
Couldn't Open Audio
Please check that
Your soundcard is configured correctly
You have the correct output plugin selected
No other program is blocking the soundcard
It is most likely the second one. XMMS used to default to Arts and fedora uses alsa.

Go to the output plugins dialog - sorry, don't know where they keep it these days - and check.

Aside:
Seriously awesome wallpaper there dude!
Is it me or is your desktop just begging for conky?
http://i598.photobucket.com/albums/t...idge/conky.png

well just made it work

what was needed to be worked was the i/o directory it was some how not seeing the /dev/dsp just configured id

also how do u enable the feature to check u r cpu moniter what needs to be done
 
Old 07-30-2009, 09:18 AM   #6
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Well... that too

Quote:
also how do u enable the feature to check u r cpu moniter what needs to be done
Please write whole words.
Thank you.
 
  


Reply

Tags
songs, xmms


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xmms, Can't Add songs to play list blackspade Linux - Software 2 02-28-2006 09:42 AM
xmms doesnt play songs John_Emad Linux - Software 4 09-05-2005 08:02 AM
XMMS/Grip find CDs, and songs, but won't play? 95se Linux - Software 3 11-23-2004 09:56 AM
Weird juk error--won't play songs but xmms will?? magicvash Linux - Software 1 06-23-2004 08:45 PM
xmms cannot play songs if user is not root zhangxd6 Debian 3 01-25-2004 12:54 PM


All times are GMT -5. The time now is 06:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration