LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-27-2003, 01:55 AM   #1
yenonn
Member
 
Registered: Feb 2003
Location: Malaysia
Distribution: Redhat 8.0, 9, Slackware 9.1
Posts: 511

Rep: Reputation: 30
XMMS problem


Dear all,

i downloaded the mp3 codec plugin at www.xmmz.org and installed the plugin to the rh8 system. everything goes well until just a strange thing occured.

everytime, the audio player finished playing a mp3 file, then, a message pops out as such:

couldn't open audio
please check that:
1. you have output plugin selected.
2. no other programs is blocking soundcard
3. your soundcard is configured properly

after all, i just ignore the message box and press ok, then, continue click on the audio player to play mp3.
then, everything is ok again. but, after a song is finished, then, the routine will happen again.

what is exactly is happened is the audio player and the xmms plugins?

Thanks in advance.
 
Old 02-27-2003, 10:35 AM   #2
tcaptain
LQ Addict
 
Registered: Jul 2002
Location: Montreal
Distribution: Gentoo 2004 from stage 1 baby!
Posts: 1,403

Rep: Reputation: 45
hmmmm. I get that problem when some OTHER sound tries to play in between mp3s. Or at least I used to.

What WindowManager do you use? I know in KDE I would have this problem unless 1 - I shut down ARTS or 2 - I used the ARTS plugin in XMMS for audio output.

If you're using Gnome, maybe you can either select Esound as output within XMMS (not sure, I don't use Gnome), or change the command-line to invoke XMMS through the Esound server.

Or I could be wrong
 
Old 02-27-2003, 07:21 PM   #3
yenonn
Member
 
Registered: Feb 2003
Location: Malaysia
Distribution: Redhat 8.0, 9, Slackware 9.1
Posts: 511

Original Poster
Rep: Reputation: 30
tcaptain,

i am using gnome. but, then, what is ARTS? is that an application or a plugin? pls confirm. yes, i am using esound as my output plugin.

Last edited by yenonn; 02-27-2003 at 07:27 PM.
 
Old 02-27-2003, 07:44 PM   #4
tcaptain
LQ Addict
 
Registered: Jul 2002
Location: Montreal
Distribution: Gentoo 2004 from stage 1 baby!
Posts: 1,403

Rep: Reputation: 45
ARTS is the sound daemon for KDE, the equivalent of Esound for Gnome.
 
Old 02-27-2003, 10:19 PM   #5
camlinux
Member
 
Registered: Feb 2003
Location: north dakota
Distribution: Gentoo, Debian
Posts: 90

Rep: Reputation: 15
I found it easier to just uninstall the redhat package and install xmms from source. It worked fine after that, after I spent a good 2 or 3 hours trying to get the original package working.
 
Old 02-27-2003, 11:58 PM   #6
yenonn
Member
 
Registered: Feb 2003
Location: Malaysia
Distribution: Redhat 8.0, 9, Slackware 9.1
Posts: 511

Original Poster
Rep: Reputation: 30
how to do that camlinux? give me some steps. ok?
thanks in advance
 
Old 02-28-2003, 10:10 AM   #7
camlinux
Member
 
Registered: Feb 2003
Location: north dakota
Distribution: Gentoo, Debian
Posts: 90

Rep: Reputation: 15
Well first I just removed the package using Redhat's package manager. Then I went to the xmms site and downloaded the tar.gz file.
unzipped it used gunzip xmms_whateveryourfileis
untarred it using tar -xf xmms_whateveryourfileis
Then I moved into the directory that was just created and ./configure
make
then su to root and make install

that is what worked for me, I don't remember right off the top of my head if I had to install anything else to get it to work. I'm not sitting at my linux box right now so I can't remember how I created the shortcut to it but I'll let you know when I get back to it.
 
Old 10-18-2003, 04:47 PM   #8
MonkeyINAbaG
LQ Newbie
 
Registered: Oct 2003
Location: Brisbane, Australia
Distribution: Redhat 9, Redhat 7.3, FreeBSD 5, Gentoo 1.4
Posts: 1

Rep: Reputation: 0
Is this is a periodic problem, ie it only happens sometimes?
--edit: whoops, i just reread- it is....

If so, make sure you ENABLE your sound server startup through the redhat gnome sound preferences. (this is disabled by default, having little effect on sound output in most applications) Please note that this is different to your sound card configuration.

to access the gui:
type sound-properties OR gnome-sound-properties at the command prompt
check the box that says: enable sound server startup -or something similar
the problem should fix itself

Last edited by MonkeyINAbaG; 10-18-2003 at 04:54 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms problem please help zeus_iit Linux - Software 2 03-26-2005 09:16 AM
xmms problem. rvijay Debian 6 02-20-2005 05:30 PM
XMMS problem Cheechi Linux - Software 8 10-20-2004 05:02 PM
Xmms Plugin 1.2.8 [xmms-config problem] MDMA Mandriva 2 01-29-2004 10:55 AM
xmms problem nedo Linux - General 0 03-24-2001 05:52 AM


All times are GMT -5. The time now is 09:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration