LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-09-2004, 07:34 PM   #1
clonedmessiah
LQ Newbie
 
Registered: Jun 2004
Location: St Louis
Distribution: Mandrake 10
Posts: 1

Rep: Reputation: 0
XMMS ./config GLIB >= 1.2.2 not installed error


I know it's been asked before but from those threads, I couldn't figure out what to do. I ran the ./config and ended up with this:

checking for glib-config... no
checking for GLIB - version >= 1.2.2... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

Can someone point me in the direction to get glib or help me with some sort of soltion? I'm running Mandrake 10.
 
Old 06-09-2004, 11:52 PM   #2
Boby
Member
 
Registered: Feb 2004
Location: Sighisoara/Cluj-Napoca (Romania)
Distribution: CentOS 4, Fedora Core 6
Posts: 781

Rep: Reputation: 31
hello!

probably you have youre glib installed, but it can't be found 'cause you need the headers.
these are included in glib-devel-<version>.ix86.rpm. on youre distribution cd [i think #3] you can find glib-devel-1.2.2.ix86.rpm .or you can download it from the internet.
if you download it, make sure the devel version corresponds exactly your glib version.
then rpm -i glib-devel-1.2.2.ix86.rpm.
also you could install the devels for glibc and glib2.

try this: grep -qa | grep glib.it will give you all packages and versions installed on youre system, so you'll know what devels to install or wich are installed.

hope i could help!

boby

Last edited by Boby; 06-09-2004 at 11:54 PM.
 
Old 10-06-2006, 01:23 AM   #3
hafizakahbk
LQ Newbie
 
Registered: Oct 2006
Posts: 2

Rep: Reputation: 0
Cool libmpg123.so ???

1../configure,make,make install glib 1.2.2
2.go to etc/ld.so.confd,create new file and write this sentence
---> /usr/local/lib
4.save file and rename it as glib-1.2.2.conf

5./configure,make,make install gtk+1.2.2
6.go to etc/ld.so.confd create new file write this sentence
---> /usr/local/lib
7.save file and rename it as gtk+-1.2.2.conf

8.in the terminal type this,ldconfig

9../configure,make,make install xmms.finish.


But!i got problem when i run xmms
here is the prob --->

libmpg123.so,cannot restore segment prot after relocermission denied.

that i missing something during installation?anyone.....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing xmms on FC4 -> "glib-config not found"... gletare Linux - Software 11 10-06-2006 01:32 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
xmms glib pointer error / flac solution Bluesuperman Slackware 0 05-22-2005 01:19 PM
Installing XMMS Error with glib Egan Linux - Software 4 12-21-2004 10:31 AM
XMMS glib-config error (old conflicting version maybe?) Balkman Linux - Software 0 02-06-2004 04:28 PM


All times are GMT -5. The time now is 09:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration