LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-10-2003, 12:15 PM   #16
qeX][lenny-
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Original Poster
Rep: Reputation: 0

hm thanks but I didnt understand it properly...
if I go in my system configuration directory there's only alsa.d and no .asoundrc in it :/
so I dont know exactly what you mean :|
It would be very kind if you could explain it to a newb like me
thanks
 
Old 12-10-2003, 02:55 PM   #17
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
The .asoundrc goes in your home directory. If its not there you have to create it. Also you can make a file so ALSA is the same on everybody's account by creating asound.conf in your /etc directory. Below is what my .asoundrc file looks like.

Code:
pcm.snd-emu10k1 {
type dmix
ipc_key 1234
slave {
      pcm "hw:0,0"
      buffer_time 3000
      buffer_size 4194304
      }
}

ctl.snd-emu10k1 {
type hw
card 0
}
Also what does system.ini or user.ini looks like. The system.ini is located in UT's directory. The user.ini is located in home directory.

You may want find out if you have SDL installed. If you do not have it, install it.
 
Old 12-12-2003, 11:14 AM   #18
qeX][lenny-
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Original Poster
Rep: Reputation: 0
ok now I created the .asoundrc file in my home dir because it didnt exist on my machine.
I copied the text above in it cause I dont know what to change... but it didnt change anything the problem is the same as before what do I have to change in the file or elsewhere?
you said above "Also what does system.ini or user.ini looks like". I dont understand that exactly... I dont have a system.ini and I'm pretty sure I never had one o_O
and what has to be changed in the user.ini?
thx in advance
and yes I have SDL installed. at least my graphics driver in UT is SDL Glide so I suppose it's there

Last edited by qeX][lenny-; 12-12-2003 at 11:16 AM.
 
Old 12-12-2003, 05:18 PM   #19
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
My sound card is Creative Labs Soundblaster LIVE! so the text that I posted is for my sound card. It will be different for your sound hardware.

There is no system.ini but there is UnrealTournament.ini. There is user.ini in a hidden directory under ".loki". If you do not remember where UT installed. Type "whereis ut".

Look through http://faqs.lokigames.com

Like I said in previous posts. To be able to use different sound programs at the same time your sound card or modules (drivers) have to support it. You can try to install ALSA or find out if you have SDL mixer. Do a search in your SUSE installer or remover programs
 
Old 12-12-2003, 06:21 PM   #20
qeX][lenny-
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Original Poster
Rep: Reputation: 0
I'm sorry for being so nervy and such a noob but I really don't get the point
this file, .asoundrc, you talked about, what do I have to write in it? My soundcard is SoundBlaster AudioPCI128
As I said before, my soundcard should support it because it did/does it in windows too.
ok I know where my user.ini and unrealtournament.ini is but what do I have to change in it?
here's the sound section of the .ini :
Code:
[Audio.GenericAudioSubsystem]
UseFilter=True
UseSurround=False
UseStereo=True
UseCDMusic=False
UseDigitalMusic=True
UseSpatial=False
UseReverb=False
Use3dHardware=False
LowSoundQuality=False
ReverseStereo=False
Latency=40
OutputRate=22050Hz
Channels=16
MusicVolume=192
SoundVolume=192
AmbientFactor=0.700000
DopplerSpeed=0.000000

[ALAudio.ALAudioSubsystem]
UseFilter=True
UseSurround=False
UseStereo=True
UseCDMusic=False
UseDigitalMusic=True
UseSpatial=True
UseReverb=True
Use3dHardware=False
LowSoundQuality=False
ReverseStereo=False
Latency=40
OutputRate=22050Hz
Channels=16
MusicVolume=192
SoundVolume=192
AmbientFactor=0.700000
DopplerSpeed=0.000000
MusicBufferSize=16384
now whats to do?
the other point is what do you mean by saying "install alsa"? I use it already because its the only way to get sound in ut. ut doesnt work with aRTs but with normal alsa. but as long as I use alsa the sound device can only handle one sound-using program...
when I use aRTs its in a way possible to use sound in diff progs like xmms+TuxRacer or some other program but then it doesnt work with ut or winex emulated programs...

hm I searched for SDL components and I found quite a lot of them installed, the SDL mixer included.

I'd be glad if you'd the patience to continue to help me I'm sorry for being a noob and understanding nothing at all -.-
 
Old 12-13-2003, 03:55 AM   #21
gundelgauk
Member
 
Registered: Jul 2003
Distribution: Gentoo
Posts: 168

Rep: Reputation: 30
Well, artsd is a sound daemon like esd. Their job is to wait for programs that want to connect to /dev/dsp, take their audio output and mix it together so that the sound card can play them as one.

I can only give you an example of how I use arts:
The goal is to be able to listen to music via xmms and play Wolfenstein ET with sound at the same time.

First I start the arts daemon in the background (if not already running): /opt/kde/bin/artsd &
Now I run xmms via the artsdsp program which reroutes any program's audio (that would normally go to /dev/dsp) to the running arts daemon: /opt/kde/bin/artsdsp xmms
I start my playlist and finally launch the game, again with artsdsp: /opt/kde/bin/artsdsp -m et

Wolfenstein ET seems to need the -m switch for memory mapping. I don't know about UT, so you'll have to find out yourself.


Good luck!
 
Old 12-13-2003, 08:45 AM   #22
qeX][lenny-
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Original Poster
Rep: Reputation: 0
thank you gundelgauk I tried it :
the "artsd xmms" command worked properly but ut not :/
first I tried "/~/artsd ut" but it said it worked only with binaries
so I tried "/~/artsd /home/~/bin/ut" and got :

ALSA lib pcm_hw.c:1055snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy
Error while initializing the sound driver:
device: default can't be opened for playback (Device or resource busy)

what now? o_O
for some reason ut denies working with aRTs in general (( I dont get it
 
Old 12-13-2003, 03:54 PM   #23
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Try running that command as root. Be careful.

What do you have in your .asoundrc? You should have something similar to the code below.

Code:
pcm.ens1371 {
    type hw
    card 0
}

ctl.ens1371 {
    type hw
    card 0
}
You may have to read about making virtual channels.
 
Old 12-13-2003, 04:15 PM   #24
qeX][lenny-
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Original Poster
Rep: Reputation: 0
well, my .asoundrc ... I have exactly the code in it you posted above :
this pcm.snd-emu10k1 thing out of your file and designed for your soundcard.
it has not been changed so I guess there is no program that accesses or needs the file
it was not even there before you said I should look in it so I had to create it.
I named it .asoundrc and put it into /home/user/ was that right?
now I wrote the code above in it but there is no effect to see
do I have to link a program to this file before it works?
 
Old 12-13-2003, 04:34 PM   #25
gundelgauk
Member
 
Registered: Jul 2003
Distribution: Gentoo
Posts: 168

Rep: Reputation: 30
qeX][lenny-, it seems you misunderstood me there. At least that's what I read from your post in which you replied to me.

Let me explain further. There are actually two seperate programs you need.

The first one is the actual daemon which is listening to incoming connections. This one is artsd. You only need to start it once as a background program, it will then continue running.

But there is another program which is called artsdsp (careful about the spelling). This is a program which will run another program as a child process (like xmms or your game), intercept the child process' audio output and reroute it to the artsd which is running in the background. artsd will then remix the audio data it gets from artsdsp and send it to the audio card.
Another way to look at artsdsp is that it makes a program (like xmms, game) think that it is accessing the audio card when actually the audio data goes to artsd first. This way you should - in theory - be able to use any program with artsd that wants to access /dev/dsp.

So instead of the normal (direct) path
Program -> Audio card
the audio data will take another way to the audio card which looks like this:
Program -> artsdsp -> artsd -> Audio Card.

The clue is that once artsd is running you can run multiple programs via artsdsp, all whose audio data will be sent to the artsd daemon. The daemon will mix all those sound streams into one before sending it to the sound card. This way you are able to have multiple programs have access to your sound card.

Again, in my example I would execute the following three command lines to listen to music while playing ET:
Code:
/opt/kde/bin/artsd &
/opt/kde/bin/artsdsp xmms &
/opt/kde/bin/artsdsp et
(The & at the end of the line sends the program straight to background in case you didn't know)


I hope I made it more clear and understandable this time. It took me some time as well to understand how exactly this system works.


Good luck!
 
Old 12-13-2003, 07:33 PM   #26
qeX][lenny-
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Original Poster
Rep: Reputation: 0
ok thank you for your explanation it made to whole thing more clear
Nevertheless I knew that artsd is the daemon you only have to start just one time. as a matter of fact I start it with every kde start. I see that I wrote in my post above as a command artsd xmms and so on this was a spelling error of mine I meant artsdsp.
In the console I wrote artsdsp, the result is the same as the one described above.
the problem seems to be that ut has a problem with arts. whatever I try I cant get it to run with it :/ I also tried artsdsp xmms + several little games like tetris and it worked quite nicely. I heard sound from both programs... It seems like ut and winex-emulated games would be the only programs (I tried) that have problems with arts.
 
Old 12-14-2003, 05:49 AM   #27
gundelgauk
Member
 
Registered: Jul 2003
Distribution: Gentoo
Posts: 168

Rep: Reputation: 30
I see, then it was me who misunderstood you. It really seems that UT has a problem with arts. I didn't try UT with arts myself so I'm a bit out of ideas here... Except you could try using the EsounD daemon. As far as I know it is a sound daemon just like arts. I'm not very confident that it would work but you could give it a try.

Sorry that I can't help you any further.
 
Old 12-14-2003, 02:44 PM   #28
qeX][lenny-
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Original Poster
Rep: Reputation: 0
ok now I tried the same procedure with ET but I dont find the binary of it.
when I enter /opt/kde3/bin/artsdsp et I get "works only for binaries" but I dont know where to search for it. Aside from that I recognized that ET doesnt work with arts either so I guess there has to be something to be changed/configured because as you said, it works on your pc and should work... but I dont know what to change
 
Old 12-16-2003, 06:59 AM   #29
qeX][lenny-
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Original Poster
Rep: Reputation: 0
oO
 
Old 12-16-2003, 02:03 PM   #30
qeX][lenny-
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Original Poster
Rep: Reputation: 0
hm when I open the binaries with artsdsp I get something like "error while loading shared libraries: Engine.so: cannot open shared object file: No such file or directory"
someone told me to try something different. I opened the et shellscript and added the line
"alias et.x86='artsdsp et.x86' " so it now looks like this:
Code:
#!/bin/sh
# Needed to make symlinks/shortcuts work.
# the binaries must run with correct working directory
alias et.x86='artsdsp et.x86'
cd "/home/lenny/programs/EnemyTerritory/"
./et.x86 $*
exit $?
but this doesnt work either... the game still wants to access /dev/dsp directly without artsdsp :/ does anyone know another way or a possible change?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gaming browncow Ubuntu 1 05-26-2005 10:14 AM
ALSA w/ XMMS : No PCM control in xmms Astro Slackware 1 08-08-2004 11:19 PM
Xmms Plugin 1.2.8 [xmms-config problem] MDMA Mandriva 2 01-29-2004 09:55 AM
red hat 9 xmms and nvidia driver-xmms ronss Red Hat 3 09-26-2003 08:06 AM
Gaming without wm ? Skilless Linux - Newbie 8 12-11-2002 12:59 PM


All times are GMT -5. The time now is 04:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration