LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-02-2010, 12:34 PM   #1
nisagnel
LQ Newbie
 
Registered: Mar 2010
Location: India
Distribution: Centos
Posts: 28

Rep: Reputation: 2
Xlib: connection to ":0.0" refused by server


hi,
i typed the command "system-config-network",at the hostname field i gave "james@lee".after closing that window, again i typed the same command "system-config-network". but it gives the following error..

[student@james@lee ~]$ system-config-network
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

ERROR: Unable to initialize graphical environment. Most likely cause of failure is that the tool was not run using a graphical environment. Please either start your graphical user interface or set your DISPLAY variable.


Please help me.
 
Old 10-02-2010, 12:38 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,916

Rep: Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689
Quote:
Originally Posted by nisagnel View Post
hi,
i typed the command "system-config-network",at the hostname field i gave "james@lee".after closing that window, again i typed the same command "system-config-network". but it gives the following error..

[student@james@lee ~]$ system-config-network
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

ERROR: Unable to initialize graphical environment. Most likely cause of failure is that the tool was not run using a graphical environment. Please either start your graphical user interface or set your DISPLAY variable.
Please help me.
This has been covered MANY times on here before, all with good explanations. Give a quick search, and you'll find lots of answers.

Basically, the workstation you're connecting from has to have an X server to connect to, and has to allow incoming connections. You don't say what kind of workstation, how you're connecting, etc., so it's hard to help.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xlib: connection to ":0.0" refused by server Xlib: No protocol specified eyalkz Linux - Newbie 11 04-22-2015 10:17 AM
anybody familiar with this error "Xlib: connection to ":0.0" refused by server" ? rajnivanza Linux - Newbie 3 03-22-2009 06:10 PM
Xlib: connection to ":0.0" refused by server Xlib: No protocol ... ousoso@webmail.co.za Linux - Newbie 1 05-06-2008 08:46 AM
Xlib: connection to ":0.0" refused by server Xlib: No protocol specified rajnivanza Linux - Software 1 03-13-2008 02:16 PM
Xlib: connection to ":0.0" refused by server Xlib: No protocol specified eyalkz Programming 1 03-02-2004 09:22 AM


All times are GMT -5. The time now is 08:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration