LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-01-2015, 12:04 AM   #1
wingman358
Member
 
Registered: Mar 2008
Location: Northeast US
Distribution: Mint, Ubuntu, Backtrack
Posts: 69

Rep: Reputation: 16
xinit :2 gives error "Server already active for display 0"


I have a script:

Code:
$ cat /bin/starcraft
xinit /usr/bin/wine /home/me/StarCraft/starcraft.exe :2 -xorg.conf xorg.conf-starcraft
which I was hoping would start a new x server, :2, with the special xorg.conf-starcraft which has only one display mode, 640x480, to force my screen into that resolution. Running gives:

Code:
 $ starcraft

(EE) 
Fatal server error:
(EE) Server is already active for display 0
	If this server is no longer running, remove /tmp/.X0-lock
	and start again.
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 

(EE)

X connection to :0 broken (explicit kill or server shutdown).
Why is it giving me an error for display 0 if I am issuing a command to start up a new x server ":2"???

Last edited by wingman358; 10-01-2015 at 12:26 AM.
 
Old 10-01-2015, 12:26 AM   #2
wingman358
Member
 
Registered: Mar 2008
Location: Northeast US
Distribution: Mint, Ubuntu, Backtrack
Posts: 69

Original Poster
Rep: Reputation: 16
OK well I decided to simplify!

Rather than trying to start up a new x server and switch displays etc etc, I decided to just go straight for what I was trying to do - set the display to 640x480, then start starcraft.exe. This works:

Code:
xrandr -s 640x480
wait
wine /home/me/StarCraft/StarCraft.exe
wait
xrandr -s 1920x1080
and resets the resolution when I exit SC!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] "SDA must have a GPT disk label" error while installing RHEL6 - "IBM x3650 M3" Server garbagegigo@gmail.com Linux - Server 13 06-21-2017 07:03 PM
[SOLVED] X: "loading extension glx" "no screens found" "fatal server error" (w/ nvidia driver) Geremia Slackware 7 12-29-2014 11:00 AM
Xlib error "extension "GLX" missing on display" Trivelt Linux - Virtualization and Cloud 0 09-02-2014 12:45 PM
"Cannot open display" error when trying to start X Server Applications Endoro Linux - Newbie 2 01-02-2009 03:24 PM
How to active "X Window" or "X Server"..?? mhd_Ahmed Linux - Newbie 1 05-21-2003 01:51 PM


All times are GMT -5. The time now is 09:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration