LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-02-2008, 03:21 PM   #1
adwomack
LQ Newbie
 
Registered: Dec 2008
Posts: 1

Rep: Reputation: 0
Xinetd and tftp error


I'm getting the below error in my message log when trying to use the tftp server.

Dec 2 18:51:01 durnfx01 xinetd[2778]: START: tftp pid=2797 from=::ffff:136.141.140.25
Dec 2 18:51:01 durnfx01 in.tftpd[2797]: received address was not AF_INET, please check your inetd config
Dec 2 18:51:01 durnfx01 xinetd[2778]: EXIT: tftp status=76 pid=2797 duration=0(sec)

I've done several google searches and it apprears the problem is IPv6 related, but I can't find a fix anywhere.

Below is my tftp config file

service tftp
{
disable = no
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -s /tftpdir/pub
per_source = 11
cps = 100 2
}

And my xinetd.conf file is

defaults
{

log_type = SYSLOG daemon info
log_on_failure = HOST
log_on_success = PID HOST DURATION EXIT

cps = 50 10
instances = 50
per_source = 10

v6only = no

groups = yes
umask = 002

}

includedir /etc/xinetd.d

Any help would be appreciated.
 
Old 12-03-2008, 12:43 AM   #2
hasanatizaz
Member
 
Registered: Nov 2007
Location: Pakistan
Distribution: Redhat and Debian
Posts: 302
Blog Entries: 1

Rep: Reputation: 34
{
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -s /tftpboot
disable = yes
per_source = 11
cps = 100 2
flags = IPv4
}

the above file is the default see flags


have u disabled ipv6 from /etc/sysconfig/network
 
Old 12-03-2008, 12:46 AM   #3
chipotphe
Member
 
Registered: Nov 2007
Posts: 62

Rep: Reputation: 15
Is your service "tftpd" not blokked in your deny.hosts ? (I had this issue before)
I added "tftpd" also in allow.hosts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
after re-create tftp dir, tftp doesn't work anymore lastguy Linux - Networking 2 11-16-2007 03:33 PM
tftp in solaris error max- Solaris / OpenSolaris 2 09-14-2007 12:40 PM
tftp issue, unable to transfer kernel image using tftp to boot ltsp-client noobs4linux Linux - Networking 1 02-07-2007 01:53 AM
tftp and pix error trebek Linux - Networking 19 12-11-2006 05:41 PM
LTSP server TFTP file not found error LinuxRam Linux - Networking 11 09-02-2004 12:13 AM


All times are GMT -5. The time now is 05:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration