LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-13-2003, 11:37 PM   #1
cyberswami
Member
 
Registered: Jan 2003
Location: TVM,Kerala,INDIA
Distribution: Redhat 8.0
Posts: 47

Rep: Reputation: 15
xine problem


i use xine to watch movies but the problem is that in the fullscreen mode the frames tend to move slowly, if i resize the window to make it smaller the movie has more clarity, has it got to do with the refresh rates of my monitor or my resolution settings ,pls help
 
Old 02-14-2003, 12:24 AM   #2
mocnicom
LQ Newbie
 
Registered: Feb 2003
Location: Center of the Universe
Distribution: Gentoo
Posts: 25

Rep: Reputation: 15
What kind of video card do you have? it may not be powerfull enough for fullscreen video at high resolutions. If it is indeed not powerfull enough some solutions are to use a lower resolution, or play less intensive video formats like mpeg1, and of course you can close all uneeded programs and daemons. If you have a good enough card then you may need to change the video driver used by xine, recompile xine, or change your video driver for a better one.
 
Old 02-14-2003, 02:59 AM   #3
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
do you have DMA and 32bit support enabled ?

linux does not do this by default

if not search this site for hdparm posts and choppy dvd playback posts
 
Old 02-14-2003, 08:51 AM   #4
cyberswami
Member
 
Registered: Jan 2003
Location: TVM,Kerala,INDIA
Distribution: Redhat 8.0
Posts: 47

Original Poster
Rep: Reputation: 15
I have Riva TNT 2 32 MB Video Card
 
Old 02-14-2003, 09:33 AM   #5
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
32bit support and DMA are for the hard drive and cd-rom drive

this may be the reason why you're experiencing problems

open up a terminal, su to root and type the following

hdparm -d /dev/hda (if hda is your linux drive)

if it reports back that DMA is off
then type

hdparm -d1 /dev/hda

this will turn DMA on

repeat the process for cd-drives

if you get a "cannot turn DMA on, action not permitted" message when trying to turn on DMA on a cd-drive then you need to add the following lines to the /etc/modules.conf file and then reboot

options hdc-cd dma=1

this takes care of DMA

repeat above process but replace d with c

hdparm -c /dev/hda

to check whether 32bit support is on or off

hdparm -c1 /dev/hda turns it on

all this can be done automatically on boot by adding the following lines to /etc/rc.local

/sbin/hdparm -d1 /dev/hda
/sbin/hdparm -c1 /dev/hda

and so on

reboot after these lines are added

doing this on my machine has made full screen DVD's a reliable experience with Linux
 
Old 06-11-2003, 03:40 PM   #6
breadbin
Member
 
Registered: Sep 2002
Location: Dublin, Ireland
Distribution: Ubuntu Maverick Meercat
Posts: 96

Rep: Reputation: 23
I had choppy video using xine and dma was set on the drive as well as the hard disk. The thing I had to do to get proper video was to set it to 32-bit also. I used hdparm -c1 /dev/dvd as root and it worked straight away. Mandrake Linux 9.0 sets dma to on as default but 32-bit as off so 16-bit.
 
Old 06-29-2003, 07:03 PM   #7
MightyKC
Member
 
Registered: Feb 2003
Distribution: Ubuntu 7.10
Posts: 47

Rep: Reputation: 15
[QUOTE]Originally posted by salparadise
[B]

if you get a "cannot turn DMA on, action not permitted" message when trying to turn on DMA on a cd-drive then you need to add the following lines to the /etc/modules.conf file and then reboot

options hdc-cd dma=1

this takes care of DMA


I have been trying to optimize xine for hours and I have reached the point where I need to do this. But I do not know how to add a line to /etc/modules.conf file. Would you be kind enough to explain it. Also, /dev/hdd is the drive I need to turn on dma for. So would the line be:

options hdd dma=1 ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Xine problem - Xine running fine only in Xnest xgreen Slackware 3 01-24-2005 10:00 AM
problem with xine chash Linux - Software 1 04-16-2004 05:57 AM
xine.de is under construction - how to install - xine-lib-1-rc3a.tar.gz sanjaya Linux - Software 1 02-13-2004 09:36 PM
xine problem JbCrash Linux - Software 2 10-17-2003 07:28 AM
Problem w/ xine daihard Linux - Software 8 07-26-2003 09:10 PM


All times are GMT -5. The time now is 06:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration