LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-14-2004, 07:17 PM   #1
snakeo2
Member
 
Registered: Mar 2004
Location: Miami, Fl
Distribution: Red Hat 9/fedora core3/
Posts: 273

Rep: Reputation: 30
Xine issues??


Im trying to install Xine and im having some problems. I went to the xine's site and downloaded xine-lib-1-rc5.tar.gz and proceeded to install from source. The instructions at xine's site recommend that you
" Make sure your /etc/ld.so.conf contains /usr/local/lib and continue with: ldconfig", how do i do this??

everyting went fine with xine-lib-1-rc5, but when I installed xine-ui-0.99.2 , I get the following error
"checking for XINE-LIB version >= 1.0.0... no
*** Could not run XINE test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding XINE or finding the wrong
*** version of XINE. If it is not finding XINE, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
***
configure: error: *** You should install xine-lib first ***


Keep in mind that installed xine-lib before xine-ui-0.99. How can get around this problem? or is there a similar program to apt-get for FC2 so I can get xine that way. thanks in advance
 
Old 09-14-2004, 07:53 PM   #2
CroMagnon
Member
 
Registered: Sep 2004
Location: New Zealand
Distribution: Debian
Posts: 900

Rep: Reputation: 33
Quote:
Make sure your /etc/ld.so.conf contains /usr/local/lib and continue with: ldconfig", how do i do this??
Uh, well, you edit /etc/ld.so.conf to make sure it has /usr/local/lib in it (just that, on a line of it's own), and then (as root) you run ldconfig. Use ldconfig -v if you'd like to verify that it's doing something (it does work, but it doesn't tell you that it's working). Once you've done this, try rerunning the configure command.

I'm sure FC2 uses RPM, so all you have to do is find some Xine RPMs if you want to wuss out (j/k). Try rpmfind.net if that appeals to you.
 
Old 09-14-2004, 08:18 PM   #3
zuesse
LQ Newbie
 
Registered: Feb 2004
Distribution: Gentoo, Fedora,RHEL,WHitebox others...
Posts: 5

Rep: Reputation: 0
Assumptions:

1) your using bash

2) your compiling xine from source as you did xine-lib

In most cases when you compile from source you get instructions similar to:


cd /source/dir
./configure
make
make install

The default install path (most of the time) is /usr/local where executables end up getting put in say
/usr/local/bin and libraries- in this case shared objects get placed in /usr/local/lib

If this is the case with your build, you will probably need to add an entry for /usr/local/lib in /etc/ld.so.conf

As root
using your favorite editor, edit the file /etc/ld.so.conf

if there is no line that looks like:

/usr/local/lib

create one.

when finished run the following as root:

ldconfig -v

This will get the system up to date with what you've done but the changes may not be
available in your shell.
To add the changes to your current - I am assuming - terminal window type the following:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib

Based on the info you have provided and my assumptions you should now be able to
1) recompile and install the libraries

2) recompile and install the app and everything should work

XINE is a feature rich app with many compile time options and dependancies for those options.
You will learn much with this one. Keep reading.
 
Old 09-14-2004, 08:43 PM   #4
snakeo2
Member
 
Registered: Mar 2004
Location: Miami, Fl
Distribution: Red Hat 9/fedora core3/
Posts: 273

Original Poster
Rep: Reputation: 30
Ok I edited the ld.so.conf file as follows:
/usr/lib/mysql
/usr/X11R6/lib
/usr/lib/qt-3.3/lib
/usr/local/lib

ran as root the ldconfig -v
got a long output. Now i will continue to install from source. wish me luck
 
Old 09-14-2004, 08:58 PM   #5
snakeo2
Member
 
Registered: Mar 2004
Location: Miami, Fl
Distribution: Red Hat 9/fedora core3/
Posts: 273

Original Poster
Rep: Reputation: 30
thanks guys. Everything went fine and i'm now watching videos, mpegs, etc
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
2 Ubuntu problems - xine, mplayer, and totem issues KingSnake Linux - Software 7 11-29-2005 06:46 PM
VectorLinux and Sound (xine issues) Sando VectorLinux 1 04-29-2005 02:46 AM
xine.de is under construction - how to install - xine-lib-1-rc3a.tar.gz sanjaya Linux - Software 1 02-13-2004 09:36 PM
xine display and controls issues mr_mandrill Linux - Software 0 09-12-2002 07:33 AM
sound issues and Xine,Noatun,Gnomemeeting stram Linux - Software 0 05-27-2002 04:22 AM


All times are GMT -5. The time now is 04:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration