LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-30-2009, 02:14 AM   #1
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Rep: Reputation: 37
xine full screen mode


Hello all,

I've found some odd behaviour with xine and am wondering if anybody can think of a solution.

Scenario:

* Computer running Ubuntu 8.10 with the default Gnome Desktop/Metacity Window Manager

* Nvidia driver for Nvidia GeForce2 MX-420

* Two user accounts, Account-A was the initial account that was configured upon install. Account-B was added after install using the "Users and Groups" GUI.


Problem:

When logged in using Account-A, Xine can be launched straight into fullscreen mode no problem, using either xine -f or xine -F from the command line, and Xine goes full screen properly.

When logged in using Account-B, Xine will always leave the Gnome Panels at top and bottom of screen exposed when going full screen, using either xine -f or xine -F from the command line. (If I press 'f' twice after Xine is launched, then the correct fullscreen is acheived)

When logged in using Account-B, Xine will always launch underneath other windows when launched with just the command xine

Work around:

I can use sudo xine -f to get a correct full screen when logged in as Account-B, but I don't want to have to run Xine using sudo.


Does anyone know what is the problem?

Regards,
Greenie

PS: this is not the same problem as the known xine/metacity problem where the xine GUI does not appear in fullscreen mode.

Last edited by greengrocer; 05-30-2009 at 02:25 AM.
 
Old 05-30-2009, 02:24 AM   #2
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Original Poster
Rep: Reputation: 37
UPDATE

This problem can be partially solved by setting the "always_layer_above" attribute found on the 'gui' tab of the xine settings window.

However, the side effect of this is that the GUI controls for xine will never come to the top, even if Xine is not in its full screen mode.

This setting causes all windows to sit underneath the Xine video window. SO if you had Gedit underneath your Xine window, you could never bring Gedit to the front.
 
Old 05-30-2009, 03:54 AM   #3
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Original Poster
Rep: Reputation: 37
SOLVED

Switching off the splash screen solves the problem.

Either uncheck the "Display Splash Screen" checkbox on the 'gui' tab of the Xine settings window, or use "xine --no-splash -f" from the command line
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox in full screen mode mikedeatworld Linux - Software 2 03-31-2009 11:01 AM
Supertux in full screen mode greengrocer Linux - Newbie 0 07-24-2006 05:25 AM
full screen mode aRm1983 Linux - Software 1 10-24-2005 04:31 PM
Xine full screen quits doralsoral Linux - Software 0 02-05-2004 10:18 PM
help!!!! how to exit full screen mode in xine littlecap Linux - Software 7 03-10-2003 07:54 AM


All times are GMT -5. The time now is 07:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration