LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-23-2005, 03:21 PM   #16
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74

Quote:
Originally posted by Johnnycab
ClearType is not available for Windows 2000. XP only.
I see, I never used win2k so didn't know that.
 
Old 08-23-2005, 06:30 PM   #17
andy_england1985
LQ Newbie
 
Registered: Jun 2005
Posts: 20

Original Poster
Rep: Reputation: 0
Reddazz, those screen shots display a much higher quality in terms of fonts than on my system. The whole desktop looks better than mine, in fact. The icons are nice and the whole thing generally looks great. I'd post a shot of my desktop now, but I'm using Windows as I can't stand using Linux for too long (because of the font problems). Here's what I've done display-wise so far:
I changed the d.p.i. to 96, I now have all the Windows fonts installed into a directory within Linux, and K.D.E. is set to use Times New Roman as the font of choice. I've played around with the anti-aliasing. It makes the Times New Roman font worse, so it's turned off. Perhaps if you tell me what your font is, the size you use, and any anti-aliasing settings you have, I might be able to get my fonts to appear clearly. At the moment it is a far cry from your screen shots!
 
Old 08-24-2005, 04:27 AM   #18
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
I am using Verdana as my default font and the settings are default KDE settings. Have you tried fonts other than times new roman?
 
Old 08-24-2005, 11:08 AM   #19
PeterRJG
Member
 
Registered: Jun 2005
Location: Northern NSW, Australia
Distribution: LXLE
Posts: 123

Rep: Reputation: 15
Keep in mind that Times New Roman's default size is smaller than a lot of seriffed fonts. What looks great with say, Georgia, at 14pt, looks tiny with TNR at the same point size.

I have a page illustrating some font differences here. Keep in mind that if you don't have the fonts installed, it'll appear as your browser's sans-serif default.

I hope you get the font situation sorted out. I'm still not sure why you had to download xfsfs for. I thought it was bundled and automagically loaded with most modern distros.
 
Old 08-24-2005, 11:40 AM   #20
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
Quote:
Originally posted by andy_england1985

checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
not sure what your font problem is - but the above message indicates you need to install gcc. it will be on your install disks, or easily found with a search online.

as for font rendering in general - this thread has some great examples of what Linux/BSD can do with fonts - as you can see, it may take some configuring, but the results are far superior:

http://www.linuxquestions.org/questi...&pagenumber=87
 
Old 08-24-2005, 11:55 AM   #21
andy_england1985
LQ Newbie
 
Registered: Jun 2005
Posts: 20

Original Poster
Rep: Reputation: 0
Screen capture
That's the Verdana font. Anti-aliasing doesn't make any difference at all to its appearance. I've tried all sorts of fonts, but nothing works. Windows is still displaying fonts more clearly than Linux. All I want is for Linux to display in the same way as Windows, with the same clarity.
 
Old 08-24-2005, 12:07 PM   #22
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
That looks alright to me. It would look even better if you increased the font font size slightly on the menu and disabling shadowed text on your desktop. That even looks better than the Windows screenshots posted earlier.
 
Old 08-24-2005, 02:26 PM   #23
andy_england1985
LQ Newbie
 
Registered: Jun 2005
Posts: 20

Original Poster
Rep: Reputation: 0
Do you think so? The screen shot makes it appear better than it is. I should say 'better than it was', as I used the instructions on the web page I posted the link to earlier to enable FreeType native hinting (whatever that is). It's actually improved things slightly, believe it or not. It's still not as good as Windows, but I'm getting there... slowly. I'll give your ideas a try and post back.
 
Old 08-24-2005, 03:11 PM   #24
andy_england1985
LQ Newbie
 
Registered: Jun 2005
Posts: 20

Original Poster
Rep: Reputation: 0
Just a little update. I've managed to get my fonts looking good now. They're a little too big, but it's not a problem. At least now they are clear! It was the FreeType instructions and your suggestions that made it possible. Thank you everyone who lent a hand!
 
Old 08-24-2005, 03:23 PM   #25
PeterRJG
Member
 
Registered: Jun 2005
Location: Northern NSW, Australia
Distribution: LXLE
Posts: 123

Rep: Reputation: 15
Quote:
Originally posted by andy_england1985
Screen capture
That's the Verdana font. Anti-aliasing doesn't make any difference at all to its appearance. I've tried all sorts of fonts, but nothing works. Windows is still displaying fonts more clearly than Linux. All I want is for Linux to display in the same way as Windows, with the same clarity.
I personally can't see much wrong with that. It looks great.
 
Old 08-26-2005, 04:40 PM   #26
XOR007
Member
 
Registered: May 2005
Location: Africa
Distribution: Ubuntu, Redhat 6.2 to 9, Centos 4, Suse 8 Ent.,Suse 9 Ent.
Posts: 51

Rep: Reputation: 15
Quote:
Originally posted by andy_england1985
It's not a problem. Thanks for trying. If anyone else knows how to sort out the following problem, please, let me know! I have just realised that I messed up the link for the previous post. It should have been THIS. Following the instructions in that document led to this error message:

[andy@localhost andy]$ su
[root@localhost andy]# cd "/usr/local/src/freetype-2.1.10"
[root@localhost freetype-2.1.10]# ./configure --prefix=/usr
cd builds/unix; ./configure --prefix=/usr
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
make: *** [builds/unix/unix-def.mk] Error 1
[root@localhost freetype-2.1.10]#
You do not have the gcc/cc compilers installed if you were running RedHat 9 I would say install the "devellopment packages" modules. If you succed with freetype, please let me know.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 1 and True-Type font installations BarryTice Linux - Newbie 3 06-09-2005 08:25 AM
Slack 10, KDE and Mozilla, true type font how-to? Slovak Slackware 2 12-12-2004 01:00 PM
Web browsing - True Type font thread DrD Linux - Software 5 10-31-2004 04:39 AM
true type font on fedora 2 isso Fedora 2 06-24-2004 06:16 AM
Weird true type font... can't be installed?? romasport Linux - General 1 03-20-2004 02:51 AM


All times are GMT -5. The time now is 04:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration