LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   XFree86 colour depth (Slackware 8.0) (http://www.linuxquestions.org/questions/linux-newbie-8/xfree86-colour-depth-slackware-8-0-a-11894/)

bluskyambition 01-16-2002 07:50 AM

XFree86 colour depth (Slackware 8.0)
 
G'day all... although I've used linux briefly before, this is my first serious forage into the operating system. Having a load of fun so far, but I still have some issues with XFree86.

Running kernel 2.4.5, slackware 8.0 on an nvidia geforce2 MX card (4x agp, 32M card). XFree86 4.0.2 I believe.

First, the desktop (KDE 2.2.2) environment does not fill my screen. While I can stretch it out using the monitor's functions, I don't think this is desirable. I've used xvidtune a little, but it scares me (mommy!!). How do I change resolutions, etc.? Is this somewhere in /etc/X11/XF86Config? I've checked this and my .xinitrc (xinit.kde) and haven't had any luck yet.

Second, it appears as if I'm not using a truecolor setting - when i start up freeamp or xmms the app shows up all fuzzy and 16-bit ish. I've looked at /etc/X11/XF86Config, but I haven't seen a setting for color depth. I used 'XFree86 -configure' to create my settings. My understanding is that this command auto-detects most of my hardware and creates an XF86Config based on its findings. Is this accurate?

my thanks in advance!

therion12 01-16-2002 08:04 AM

Yes you are partially correct but here's the scoop about XF86Config files.

Usually the XF86Config file is only for the mouse and keyboard stuff, you will need to edit the XF86Config-4 file to change the resolutions in the "screens" section of the file. AThe color depth can be changed in the "defaultcolordepth" section of the file. Good luck and tell me if this helps.

For me the highest i got my color depth to work at is 24Bits, 32Bits will crash the server for some reasons unknown.

taz.devil 01-16-2002 12:19 PM

Do that, or perhaps have you yet configured X? xf86config? Then you can choose the driver (320 in the database for NVidia) and then pick the resolutions you'd like for the bitranges, also the monitor refresh as well. When I get to the question that looks something likeL
1. 8 bit screen
2. 16 bit
3. 24 bit
4 these settings are ok.
Before hitting 4, I go through them all and set it to only one res that I know i'm gonna use and say 'N'o to virtual screen. You should be good to go. Perhaps the driver as I specified above isn't the one you picked or so forth? Just some idears....Have a good one, i'm home sick! :(

bluskyambition 01-16-2002 08:25 PM

nope and nope!
 
Gentlemen - my thanks for your responses, however I have a couple of problems here.

1. no XF86Config-4. I'm guessing this is a slackware 8.0 thang.

2. the first time I attempted to run X server I used the xf86config with not particularly good results.

Thanks again for your help so far - I"m still working with subpar graphics right now!!!

therion12 01-16-2002 08:59 PM

do this:

locate XF86Config

taz.devil 01-17-2002 12:36 PM

Re: nope and nope!
 
Quote:

Originally posted by bluskyambition
Gentlemen - my thanks for your responses, however I have a couple of problems here.

1. no XF86Config-4. I'm guessing this is a slackware 8.0 thang.

2. the first time I attempted to run X server I used the xf86config with not particularly good results.

Thanks again for your help so far - I"m still working with subpar graphics right now!!!

Actually, Slack DOESN'T use XF86Config-4 and uses the plain 'ol XF86Config. I actually wonder why...But anywho, you may want to look into getting the Linux NVidia drivers.

taz.devil 01-17-2002 12:38 PM

Sorry, just got up and re-read your post and finally understood it the way it was meant. So disregard me, except the driver part. :o


All times are GMT -5. The time now is 11:48 PM.