LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   xfce4 setting file associations (http://www.linuxquestions.org/questions/linux-newbie-8/xfce4-setting-file-associations-197773/)

Gyper 06-25-2004 07:40 PM

xfce4 setting file associations
 
Hi, I'm new using Linux, actually its my third month using it. I've been using Gnome as my desktop manager but I decided to try out XFCE4 for a change. My problem is that the primary browser that I am using is Mozilla FireFox but the default associated browser for html files is Mozilla. Can anyone help me to change the default file association for the browser (of course, also for text editors, media players and such)? I've tried searching in google but with no avail :( Thanks in advance.

Tuttle 06-25-2004 08:16 PM

do you use xffm file manager? if so, when you double click on an icon a bar appears asking you which program to open the filetype with. select the program (eg. gedit for text, xine for mpgs, mozilla for html docs, soffice for word docs etc...) then, after you have tested that choice, open it again in the same way and tick the "remember" box.

Franklin 06-25-2004 09:28 PM

Right click on the panel icon that starts mozilla, pick properties, replace the command for mozilla with the command for firefox (or galeon or epiphany, or whatever). There is also an option to make the icon become a menu with multiple icons to start several choices of browser or whatever. If firefox doesn't start, it may not be in your path so you'll have to type the whole path and not just the name. You'll also see options to pick a custon icon etc. Sorry I can't be more specific, but I'm in kde now.


HTH

Tuttle 06-25-2004 09:57 PM

oops, misread it! thx franklin.

Franklin 06-25-2004 11:06 PM

Well...

The OP hasn't responded yet so we may both be wrong.

:D

Gyper 06-27-2004 05:18 AM

Hi all, sorry our phoneline was down for a day, just got online. Tuttle, I did not get the double clicking an icon and a bar appears asking you for a program, all it does is open the file. What I did is I right clicked the file and chose the open --> open with, and the bar that you are referring to appeared. And yes there is a remember check box, which will make the program you typed in the box its default. Tnx for the help.

Franklin, I already did what you suggested. Tnx also.


All times are GMT -5. The time now is 03:05 PM.