LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-09-2014, 05:32 AM   #1
Motte
LQ Newbie
 
Registered: May 2014
Location: Cologne
Distribution: Linux Mint/ Ubuntu
Posts: 18

Rep: Reputation: Disabled
Question XFCE: Changing the font colour of the taskbar


Hello everyone,
I have a problem concerning the customisation of my XFCE destkop. I use Linux Mint 16 Cinnamon edition but I noticed some performence issues because the laptop I installed it on is quite old. I guess around 6 years.

So I installed XFCE 4.10 and started playing around and I'm very satisfied how things are working.
My problem is: I want to change the taskbar to a dark grey colour but then I can't read anything. Tried searching for "xfce change font color taskbar" or similar terms on duckduckgo and LQ.
I found a tutorial about changing the font color of desktop icons, tried it but i can't find the .gtk-2.0 file

Did I do something wrong installing XFCE? I installed it using the synaptic-package manager.

Hope you guys can help me. Would be much appreciated
 
Old 05-09-2014, 09:41 AM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
Quote:
i can't find the .gtk-2.0 file
On my system its called .gtkrc-2.0 and its in my /home/username directory.

Quote:
Did I do something wrong installing XFCE?
Don't think so, if you used the package manager.

Just how are you trying to change the background, and the font colour? xfce is a little more difficult to configure than some other desktops.
 
Old 05-09-2014, 03:58 PM   #3
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,374

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
I don't know the answer but will say hello and welcome to LQ.
 
Old 05-09-2014, 05:56 PM   #4
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,004

Rep: Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620
The was I found to do this, though it may not be the best, was to install gtk-theme-config and go to "Theme Configuration" under "Settings" to use it. It's a bit clunky and I think it contradicts other settings so may not work perfectly immediately but I managed to have a dark panel and menus with white text.
 
Old 05-10-2014, 12:48 PM   #5
Motte
LQ Newbie
 
Registered: May 2014
Location: Cologne
Distribution: Linux Mint/ Ubuntu
Posts: 18

Original Poster
Rep: Reputation: Disabled
Tanks jefro!

I'm sorry camorri, I did mean the .gtkrc-2.0 file and it is supposed to be in my /home/username diretory.
I was using this tutorial: http://community.linuxmint.com/tutorial/view/1146
Maybe I didn't understand what the author wants me to do when he requests to "click on the default directory". I don't have this directory either. (Yes I selected show hidden files.)

I change the taskbar colour by using the GUI for bar customisation. (Not 100% sure if these are the correct terms because my system language is set to german.)

273, this solution sounds nice because I'd like to have a GUI for this. But which settings does it contradict and are there more issues to be expected because of this?
 
Old 05-10-2014, 12:52 PM   #6
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,004

Rep: Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620
I'm afraid I can just suggest you install it and try. If you turn off the settings from it it does not seem to interfere with anything after that.
 
Old 05-10-2014, 01:29 PM   #7
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
I'm on my 64 bit XFCE system today. Yesterday I was on a 32 bit system.

On the 64 bit system, I did't have the gtkrc-2.0 file. I created it, copy and pasted the lines as they are shown in the link you provided. I did boot the system, just because the instructions suggested it. Not sure that is necessary.

The short story is, the file has modified the colour of the text on the icons on the desktop. Unselected, the text is white, selected ( click once on the icon ) the text turns green, and transfer focus to another application that is open, the green text turns blue.

Interesting eye candy.

The only reason to edit the file as root, would be if root owned the file. Doesn't seem necessary.
 
Old 05-10-2014, 03:08 PM   #8
Motte
LQ Newbie
 
Registered: May 2014
Location: Cologne
Distribution: Linux Mint/ Ubuntu
Posts: 18

Original Poster
Rep: Reputation: Disabled
Hey,

again, I'm sorry. I totally forgot to give information about my system. Yep I'm running a 32bit system.
(But does the architecture have any influence on this sort of issues?)
From white over green to blue? "Interesting" indeed And it doesn't change the taskbar's font colour? Too bad...

I just tried the gtk-theme-configuration package as sugested by 273 and it just works nice. Only con is that the system has to be rebooted for the changes to take effect But it's ok for me because I won't use it often (I hope ).

The only "problem" (if you want to call it one) is that you have to change theme settings to system-style or otherwise the changes set in the Theme Configuration tool won't be applied.

Thanks guys for your quick help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set font colour for java... Bevin1990 Programming 1 08-27-2009 08:11 PM
SuSE 9.1: Font colour Cyberian Linux - Distributions 0 07-11-2004 11:31 PM
Changing the colour of text kamransoomro84 Programming 1 05-12-2004 09:57 AM
Changing Terminal background colour and font color dpbatagoda Linux - Newbie 0 12-05-2003 01:38 AM
How to set default font colour for amsn cdhgee Linux - Software 2 10-16-2003 01:07 PM


All times are GMT -5. The time now is 02:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration