LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-01-2005, 11:33 PM   #1
WiteOut
LQ Newbie
 
Registered: Nov 2005
Posts: 5

Rep: Reputation: 0
XF86Config-4, Debian, nVidia Drivers


I'd love to put the kernal vesion up, but I haven't a clue how to find it. All I know it's the newest release that Debian has going up (see as I downloaded it today which is November 2nd 2005).

Right now I'm trying to edit this file, because of a tutorial or guide that is posted up on these forums called "Installing new Accelerated Linux Drivers in 5 EASY Steps" posted by HolyLiaison. Anyway, followed the guide/article, but I'm running into a simple problem. I can't overwrite the file "XF86Config-4" with the changes he suggested. The chances are it's because I'm being denied access. I tried to go into the terminal and login as root there using the "su" command. Seems that didn't work. I then tried reseting, going through safe mode (unsure what the actual name of it is) and login as root there. Didn't know what I was going to be able to do in the command prompt so I then used "init 3" hoping that'd it'd bring me back to a solution (seeing as I've gone through so many guides that say to use init 3. This just brings the GUI on the screen). Simply enough, where am I supposed to login as the root so I can edit this file and continue installing the drivers?
 
Old 11-02-2005, 12:22 AM   #2
uberNUT69
Member
 
Registered: Jan 2005
Location: Tasmania
Distribution: Xen Debian Lenny/Sid
Posts: 578

Rep: Reputation: 30
This is the easiest method of know of:

Press CTRL+ALT+F1 to go to a terminal,

login as root,

stop your X session with:
# /etc/init.d/kdm stop
or
# /etc/init.d/gdm stop
(or whichever display manager you're using)

install module-assistant:
# apt-get install module-assistant

install nvidia drivers:
# m-a a-i nvidia

done
 
Old 11-02-2005, 09:19 PM   #3
WiteOut
LQ Newbie
 
Registered: Nov 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Not working.

Problems are:
A) "/etc/init.d/kdm stop" <= apparently does not exist

I got the module, but now I have to install this:
# apt-get install kernal-headers-2.4.27-2-386

I'm about to do this, but exactly how am I supposed to stop kde. Hopefully it will do it by itself. I'll keep this updated till I find a solution.

UPDATE:

Drivers installed. Everything updated. BIG problem.

I cannot get Debian to run on a higher resolution then 800x600 which is driving me to insanity. I'm running on a nVidia FX5700LE on a Viewsonic 17" PS-2, in which case, can go up to a maximum resolution of 1600x1200. Also, at Celeron 2.4ghz with 512mb of DDR400 RAM. Please help, as this is getting on my nerves.

Kernel version: 2.4.27-2-386

Last edited by WiteOut; 11-02-2005 at 09:45 PM.
 
Old 11-02-2005, 10:01 PM   #4
LeftyAce
Member
 
Registered: Oct 2005
Distribution: Debian
Posts: 69

Rep: Reputation: 15
Ok. I think it's as simple as editing the XF86Config file and telling it to use a higher resolution. To do this login as root, then cd into the directory /etc/X11 In this directory there should be a file called XF86Config.conf or XF86.conf or somthing similar (sorry for the vagueness; I'm running x.org so it's different). Open this file in your favorite editor (I use nano. Type nano <filename>.<extension>) and find the section "screen" and the line that says "modes 600x800" (might say "resolution" but it should be pretty obvious). Add the mode you want ("1600x1200") BEFORE the modes already listed. There may be many "Display" entries each with a different "depth" number listed. Just add 1600x1200 to each line you see that already has a resolution listed. Then reboot and it should work fine!
 
Old 11-02-2005, 10:09 PM   #5
uberNUT69
Member
 
Registered: Jan 2005
Location: Tasmania
Distribution: Xen Debian Lenny/Sid
Posts: 578

Rep: Reputation: 30
Try:
# apt-get install xdebconfigurator

Then ensure that you are using nvidia drivers rather than nv:
$ grep nv /etc/X11/XF86Config-4
# Driver "nv"
Driver "nvidia"

After (re)starting X, ensure that the driver loads:
# egrep "3D|nv" /var/log/XFree86.0.log
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
 
Old 11-02-2005, 11:42 PM   #6
WiteOut
LQ Newbie
 
Registered: Nov 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Alright.

Did all that. Still limited to a 800x600 resolution. What I don't get is why it's having problems when I've had a GeForce2 (same monitor) working at higher resolutions. Anyway, did the check to see if the drivers are being loaded, and they are. Exactly what you had said uberNUT69, but I noticed this when running through my XF86Config-4 file:

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
EndSection

That's all I have under my graphic card part.

I have this under if for the moniter and screen:
Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30-65
VertRefresh 50-75
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection

I'm going to try and see if I can change these values to what I need at a bare minimum (which is 1,280 x 1,024). I'll back up the origonal, just in case things go wrong. Otherwise, eager to hear any solutions anytime.
 
Old 11-03-2005, 12:04 AM   #7
WiteOut
LQ Newbie
 
Registered: Nov 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you!!

FINALLY! It's worked! I'm running at 1280x1024 and I'm truly satisfied! Thank you uberNUT69 and LeftyAce! You guys have literally made my day! I did add the resolution in the XF86Config-4 file, so it decided to finally work. Thank God. I am super happy now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nVidia Drivers + Debian Sarge... Tsumeone Debian 5 08-28-2004 12:33 PM
NVIDIA Drivers on Debian doctorwebbox Linux - Hardware 6 08-23-2004 03:03 PM
best way to update nvidia drivers in debian gonus Debian 34 08-13-2004 10:19 PM
Trouble booting up after nvidia drivers install & editing XF86Config-4 file /home/kyle Linux - Software 2 03-12-2004 11:27 PM
NVidia drivers in Debian 3.0 r2 morrolan Linux - Newbie 5 12-28-2003 02:27 PM


All times are GMT -5. The time now is 11:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration