LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-25-2006, 07:28 AM   #1
tiddy
Member
 
Registered: Mar 2006
Distribution: Ubuntu 7.04 Feisty
Posts: 67

Rep: Reputation: 15
Unhappy xdm loading gnome instead of WindowMaker (SuSE 10.0)


Hi, I've been using linux since Jan 06 and I really liked the gnome interface (switched from WinXP), but I thought the gnome apps were really crappy (just my opinion). So I thought that I could have the gnome interface with the KDE apps. I want into the yast sftware manager and decided against it when I saw the (long) list of clashes when I tried to do this. So, then I tried windowmaker and found it better than gnome anyway. So now I use windowmaker. Problem solved - you'd think. Nope. Because my linux partition is only so big, and I'd like to get rid of gnome because it's just sitting there doing nothing. As far as I can see the only way I can get into windowmaker is through the session menu at the gdm login prompt, obviously, if I get rid of gnome (and therefore gdm), I can't get into windowmaker because I'd have to login with xdm and that doesn't allow you to select which session you would like.
Sorry for the long post, any replies are welcome.

Thanks
 
Old 03-25-2006, 11:23 AM   #2
sub_pop_culture
Member
 
Registered: Jan 2003
Location: California
Distribution: Fedora Core 5
Posts: 31

Rep: Reputation: 15
xdm uses what GDM/KDM call "Xsession". There should be a file in your home directory called .xsession. Its a simple shell script, that you can list what you want to do on login. The last line you should put in the script is: exec wmaker. This will execute your window manager and dump you into the WindowMaker settings you've configured. Make sure .xsession is set to be executable (chmod u+x ~/.xesssion), otherwise xdm won't execute it.
 
Old 03-26-2006, 09:01 AM   #3
tiddy
Member
 
Registered: Mar 2006
Distribution: Ubuntu 7.04 Feisty
Posts: 67

Original Poster
Rep: Reputation: 15
It isn't there (there is .xsession-errors) should I create it?
 
Old 03-27-2006, 12:00 AM   #4
sub_pop_culture
Member
 
Registered: Jan 2003
Location: California
Distribution: Fedora Core 5
Posts: 31

Rep: Reputation: 15
Yes, create it and put
Code:
#!/bin/sh
exec wmaker
in it, setting it executable, and logging in with xdm again.
 
Old 06-17-2006, 09:43 AM   #5
tiddy
Member
 
Registered: Mar 2006
Distribution: Ubuntu 7.04 Feisty
Posts: 67

Original Poster
Rep: Reputation: 15
thanks! worked brilliantly!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa volume not loading with Windowmaker kak Slackware 2 01-22-2005 10:38 AM
Loading Gnome in Suse 9.2 Nigel Linux - General 0 01-16-2005 12:59 PM
xdm loading problem icpsvt Slackware 4 10-18-2004 01:30 AM
Help!!!!!!! gnome instead of windowmaker!!!!!!!!!!! Someguy Linux - Newbie 4 05-19-2002 04:00 PM
Changing from Gnome to Windowmaker... rick420 Linux - General 1 05-29-2001 11:37 AM


All times are GMT -5. The time now is 09:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration