LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-26-2011, 07:33 PM   #1
fetal
Member
 
Registered: Nov 2011
Distribution: Ubuntu 16.04
Posts: 33

Rep: Reputation: Disabled
xcompmgr and transparency


I got a laptop for Christmas and just installed Ubuntu 11.10 with fluxbox.
I'm trying to setup transparency using xcompmgr.

I've got an ati card


Here's my Xorg config file. It seems pretty short?
Code:
Section "Screen"
        Identifier      "Default Screen"
        DefaultDepth    24
EndSection

Section "Module"
        Load    "glx"
EndSection
Section "Extensions"
       Option "Composite" "Enable"
       Option "RENDER" "Enable"
       Option "backingstore" "true"
       Option "AllowGLXWithComposite" "true"
 EndSection
And my glxinfo

Code:
ame of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method, 
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample, 
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
client glx vendor string: ATI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory, 
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control, 
    GLX_MESA_swap_frame_usage, GLX_NV_swap_group, GLX_OML_swap_method, 
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync, 
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
    GLX_SGIX_swap_barrier, GLX_SGIX_swap_group, GLX_SGIX_visual_select_group, 
    GLX_EXT_texture_from_pixmap, GLX_EXT_framebuffer_sRGB, 
    GLX_ARB_fbconfig_float, GLX_AMD_gpu_association
GLX version: 1.4
And the tail of my Xorg.log

Code:
fetal@zen:~$ tail -f /var/log/Xorg.0.log
[ 93015.313] (II) fglrx(0): Printing DDC gathered Modelines:
[ 93015.313] (II) fglrx(0): Modeline "1366x768"x0.0   69.30  1366 1402 1442 1480  768 771 776 780 -hsync -vsync (46.8 kHz)
[ 93015.500] (II) fglrx(0): EDID vendor "LGD", prod id 754
[ 93015.500] (II) fglrx(0): Printing DDC gathered Modelines:
[ 93015.500] (II) fglrx(0): Modeline "1366x768"x0.0   69.30  1366 1402 1442 1480  768 771 776 780 -hsync -vsync (46.8 kHz)
[ 93015.616] (II) fglrx(0): EDID vendor "LGD", prod id 754
[ 93015.616] (II) fglrx(0): Printing DDC gathered Modelines:
[ 93015.616] (II) fglrx(0): Modeline "1366x768"x0.0   69.30  1366 1402 1442 1480  768 771 776 780 -hsync -vsync (46.8 kHz)
[ 93863.784] (II) fglrx(0): System Power Source: AC
[ 94078.437] Warning: LookupWindow()/SecurityLookupWindow() are deprecated.  Please convert your driver/module to use dixLookupWindow().
 
Old 12-26-2011, 09:20 PM   #2
MS3FGX
LQ Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
Do you get some kind of error when trying to start xcompmgr? What exactly happens when you try to enable transparency?
 
1 members found this post helpful.
Old 12-26-2011, 09:39 PM   #3
fetal
Member
 
Registered: Nov 2011
Distribution: Ubuntu 16.04
Posts: 33

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by MS3FGX View Post
Do you get some kind of error when trying to start xcompmgr? What exactly happens when you try to enable transparency?
fetal@zen:~$ xcompmgr
^C
fetal@zen:~$


That's all that happends, line just drops down. The screen flashes though, so it does start.
 
Old 12-26-2011, 09:40 PM   #4
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
You may need to enable compositing in Xorg.

Code:
Section "Extensions"
        Option      "Composite" "enable"
EndSection
Is how it looks in my debian + xfce install, with an Radeon HD 5770.
 
Old 12-26-2011, 09:48 PM   #5
MS3FGX
LQ Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
Quote:
Originally Posted by fetal View Post
fetal@zen:~$ xcompmgr
^C
fetal@zen:~$

That's all that happends, line just drops down. The screen flashes though, so it does start.
You haven't given xcompmgr any options, so it isn't going to do anything. At the very least you need to use -c to tell it to enable composite, but you also need to configure things like drop shadows from the xcompmgr switches.

Then, to enable per-window transparency, you'll need to use the transset tool.
 
Old 12-27-2011, 05:21 AM   #6
fetal
Member
 
Registered: Nov 2011
Distribution: Ubuntu 16.04
Posts: 33

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by MS3FGX View Post
You haven't given xcompmgr any options, so it isn't going to do anything. At the very least you need to use -c to tell it to enable composite, but you also need to configure things like drop shadows from the xcompmgr switches.

Then, to enable per-window transparency, you'll need to use the transset tool.
fetal@zen:~$ xcompmgr -c
^C
fetal@zen:~$

Does the same thing.
 
Old 12-27-2011, 08:00 AM   #7
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
So what makes you think something is wrong? Have you configured any applications to use transparency? You probably want to run xcompmgr in the background ("xcompmgr -c &") so that you can close the window you started it run.
 
1 members found this post helpful.
Old 12-27-2011, 03:02 PM   #8
fetal
Member
 
Registered: Nov 2011
Distribution: Ubuntu 16.04
Posts: 33

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by adamk75 View Post
So what makes you think something is wrong? Have you configured any applications to use transparency? You probably want to run xcompmgr in the background ("xcompmgr -c &") so that you can close the window you started it run.

How would I go about doing that?
 
Old 12-27-2011, 03:13 PM   #9
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Well, different applications (mostly terminal apps) have their own preferences for transparency. I'm not going to go into each one because, well, that would be ridiculous. There is also transset/transset-df as MS3FGX mentioned, which lets you click on a window to adjust the transparency level.

Adam
 
Old 12-27-2011, 03:35 PM   #10
MS3FGX
LQ Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
Quote:
Originally Posted by fetal View Post
fetal@zen:~$ xcompmgr -c
^C
fetal@zen:~$

Does the same thing.
Again, all you have done here is say "Turn on Compositing". Simply enabling compositing will have no obvious effect on the system until you start to configure it on a per-application basis. If you want something system wide, you can enable fading and drop shadows by giving xcompmgr different options on the command line (which xcompmgr will list in it's help output).

I'm not sure what you are expecting to see, but simply starting xcompmgr won't suddenly make your desktop explode into 3D graphics and effects like you are in "Hackers", everything has to be setup and configured manually, xcompmgr is just the backend that makes all that possible. Really, if you are looking for maximum visual effect, you should be using Compiz and one of the configuration tools designed to work with it.
 
Old 12-27-2011, 04:11 PM   #11
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
You haven't to enable those extensions in xorg.conf, they are enabled by default.
(You also may have some other configuration files in /etc/X11/xorg.conf.d directory)

As MS3FGX says, try use back end solution like compiz
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xcompmgr cb951303 Slackware 5 12-15-2005 03:30 AM
xcompmgr Rocker Linux - Software 0 04-21-2005 03:44 AM
xcompmgr and xv alphisb0t Linux - Software 2 03-13-2005 11:48 AM
using xcompmgr corbis_demon Linux - Newbie 1 03-11-2005 10:50 AM
X11 program setting transparency for xcompmgr frogb Programming 0 11-01-2004 07:17 PM


All times are GMT -5. The time now is 09:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration