LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-24-2012, 10:36 AM   #1
jlivin25
LQ Newbie
 
Registered: Feb 2012
Posts: 6

Rep: Reputation: Disabled
Wink xbmcbuntu & transmission-daemon


Hello All

Well its that point where as a relative Linux noob i have to ask for help as google has not been able to help me (please bare in mind i really have searched hard and experimented before getting to the point of asking for help as i do try to do it myself first)

I have a Acer Revo 3700 on which i am running (very happily) xbmcbuntu Eden (based on ubuntu 11.10).

Essentially it is configured to boot automatically into XBMC without showing any desktop environment, however if you choose to you can access this.(which i believe is based on 'openbox')

What i am trying to acheive is to have a torrent program start automatically on boot. Previously i had transmission to do this and used the desktop to 'add it to start up programs' and i added the 'minimised' switch so it didn't start with an open window.

I can't however replicate this in xbmcbuntu.

After a lot of reading i began to understand that i didn't want to use the GUI i needed to have transmission-daemon installed and have this run and access it via the remote client ability.

The problem is that as a traditionally GUI based user i'm struggling with correctly identifying how to configure transmission from the command prompt (via ssh)

i have successfully installed transmission using sudo apt-get install transmission-daemon.

i found the transmission website and followed the instructions there about what to change. (https://trac.transmissionbt.com/wiki/EditConfigFiles)

so i editited the original settings.json in the correct folder (original attached) with the code i believe i need to run transmission-daemon with an alternative speed limit enabled and access capable from my network (on the 192.168.0.* range)

i then restarted transmission-daemon using the command listed in the web page above but am blocked access.

Deciding to stop there adn see if i could get the daemon to start on boot i followed the instructions here (https://trac.transmissionbt.com/wiki/Scripts/initd) to place a script in the init.d folder. but it doesn't work.

Any ideas what i may have done wrong and how to make it start in boot?

I've attached the settings.json that i have 'concocted from the website, the original, and the inid.d transmission.daemon script i created as text files for reference

Thanks

James
Attached Files
File Type: txt settings (original).txt (506 Bytes, 7 views)
File Type: txt settings.txt (703 Bytes, 5 views)
File Type: txt transmission-daemon.txt (5.1 KB, 6 views)
 
Old 04-25-2012, 09:58 AM   #2
FNC
Member
 
Registered: Feb 2001
Location: South Africa
Distribution: Fedora, Mandriva, PCLOS, SUSE - anything a can get my hands on
Posts: 140

Rep: Reputation: 15
Hi jlivin25,

Make sure that you stop the transmission service before editing the settings.json
From the shell run:
Code:
sudo /etc/init.d/transmission-daemon stop
For you to be able to connect to the web interface you only need to change the "rpc-whitelist" option to match your network.
So if your network range is 10.0.x.x, change the rpc-whitelist like this"
Code:
"rpc-whitelist": "127.0.0.1,10.0.*.*",
Then start the transmission daemon
Code:
sudo /etc/init.d/transmission-daemon start
Once it is started you can access the web interface in a browser by going to "http://xbmcip:9091"
From there you can configure speed and other options as you like.
 
Old 04-25-2012, 04:24 PM   #3
jlivin25
LQ Newbie
 
Registered: Feb 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Smile transmission

Quote:
Originally Posted by FNC View Post
Hi jlivin25,

Make sure that you stop the transmission service before editing the settings.json
From the shell run:
Code:
sudo /etc/init.d/transmission-daemon stop
For you to be able to connect to the web interface you only need to change the "rpc-whitelist" option to match your network.
So if your network range is 10.0.x.x, change the rpc-whitelist like this"
Code:
"rpc-whitelist": "127.0.0.1,10.0.*.*",
Then start the transmission daemon
Code:
sudo /etc/init.d/transmission-daemon start
Once it is started you can access the web interface in a browser by going to "http://xbmcip:9091"
From there you can configure speed and other options as you like.
Thanks very much mate.

I have followed your instructions, thank you

However it doesn't appear to have worked.

I stopped the daemon.

edited settings.json, added 192.168.*.* as you can see from the attached screenshot (settings.jpeg)

Then restarted the daemon

tried to access through web browser and get a forbidden notice...

see 403 forbidden.jpeg, any other ideas?

James
Attached Images
File Type: jpg 403 forbidden.jpg (14.4 KB, 7 views)
File Type: jpg settings.jpg (50.4 KB, 6 views)
 
Old 04-26-2012, 01:31 AM   #4
FNC
Member
 
Registered: Feb 2001
Location: South Africa
Distribution: Fedora, Mandriva, PCLOS, SUSE - anything a can get my hands on
Posts: 140

Rep: Reputation: 15
Hi James,

I think you are editing the wrong file.
You should edit
Code:
/etc/transmission-daemon/settings.json
you might also want to change the
Code:
"rpc-username": "transmission",
and
Code:
"rpc-password": "{48d96e8514662f5f91da1b0b2a4caa309056889db31VOUi7",
The default password is "transmission"

You do not need edit or add any startup script, transmission-daemon should start automatically when you boot.

Last edited by FNC; 04-26-2012 at 03:15 AM.
 
Old 04-26-2012, 04:17 AM   #5
jlivin25
LQ Newbie
 
Registered: Feb 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Smile transmission-daemon

Quote:
Originally Posted by FNC View Post
Hi James,

I think you are editing the wrong file.
You should edit
Code:
/etc/transmission-daemon/settings.json
you might also want to change the
Code:
"rpc-username": "transmission",
and
Code:
"rpc-password": "{48d96e8514662f5f91da1b0b2a4caa309056889db31VOUi7",
The default password is "transmission"

You do not need edit or add any startup script, transmission-daemon should start automatically when you boot.
Hi FNC

Thanks for the advice I will give it a go as soon as I get near my computer. I genuinely thought I had the right file location, so will check I will also change username to transmission, I'll leave the password as transmission until I can confirm its fixed

Will update in about 9 hrs when home

James
 
Old 04-26-2012, 02:00 PM   #6
jlivin25
LQ Newbie
 
Registered: Feb 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Talking Solved

Quote:
Originally Posted by jlivin25 View Post
Hi FNC

Thanks for the advice I will give it a go as soon as I get near my computer. I genuinely thought I had the right file location, so will check I will also change username to transmission, I'll leave the password as transmission until I can confirm its fixed

Will update in about 9 hrs when home

James
Hello

Thats absolutely worked, thankyou!!!

i will now set to work configuring the other bits

Many thanks FNC!!
 
  


Reply

Tags
transmission, xbmc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission daemon permissions problem. SUID related??? cbass Linux - Software 2 10-19-2011 04:03 PM
transmission-daemon doesn't download zoran119 Slackware 1 10-19-2011 03:15 PM
[SOLVED] Shorewall rejecting allowed traffic for transmission-daemon RyanRahl Linux - Security 7 05-23-2011 03:05 PM
shared object & manually installed daemon mac-geek Linux - Software 1 07-23-2007 10:45 PM
HAL daemon & mount permissions tuxrules Fedora 1 01-19-2005 11:08 PM


All times are GMT -5. The time now is 02:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration