LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-13-2004, 08:17 AM   #1
Deep-Blue-ro
LQ Newbie
 
Registered: Mar 2004
Location: Romania - TM
Distribution: slackware10, rh9
Posts: 21

Rep: Reputation: 15
xawtv: does anybody know how to solve this ?


When i try to run xawtv (as root) i get this:

This is xawtv-3.93, running on Linux/i686 (2.4.26)
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Error: Can't open display: :0.0

on slackware 10.

i suppose that there is a problem with xserver but i can't figure out what can be.
radio works fine.
 
Old 11-13-2004, 09:48 AM   #2
Deep-Blue-ro
LQ Newbie
 
Registered: Mar 2004
Location: Romania - TM
Distribution: slackware10, rh9
Posts: 21

Original Poster
Rep: Reputation: 15
Normaly, it has to be something extremly simple: I have started xawtv from console as root but i have logged as a user. I had logged to system as root and with few ajustments (overlay changed to grab) it worked ok.

Does anybody know how to make xawtv run when i login as user pls ?
 
Old 11-13-2004, 04:15 PM   #3
karlan
Member
 
Registered: Aug 2003
Location: San Francisco, California
Distribution: Slackware
Posts: 158

Rep: Reputation: 30
this is nifty, you can also use this for remote connections

say you are logged in at :0 (Alt+F7 on slackware) as karlan

you open up a terminal and type the command
"xhost +127.0.0.1"


now you go to the root window, assuming you are using bash you type:

"DISPLAY=127.0.0.1:0"
"export DISPLAY"


now test it out with xlogo/xeyes, anything opened up in the root terminal should now open up in karlan's X session!

Your welcome
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I need help to solve this problem TheTiger Fedora 1 10-26-2005 01:01 PM
help..how i can solve this problem?// TAAN Linux - General 2 02-16-2005 07:53 AM
I don't know how to solve a problem in C nostrum Programming 5 07-20-2004 07:57 AM
X is not loading, How to solve it mfeoli Linux - Newbie 5 01-19-2004 04:59 PM
XawTV - Sound continues after closing XawTV ministre Linux - Software 5 11-05-2003 10:26 AM


All times are GMT -5. The time now is 08:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration