LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-07-2005, 10:52 AM   #1
thomasfingram
Member
 
Registered: Jun 2005
Location: Cary, NC
Distribution: Fedora Core 4
Posts: 44

Rep: Reputation: 15
xauth error with libXmuu.so.1


I just installed Slackware 10.1 on my really old laptop. Everything went fine until I tried 'startx'. When I type that it gives me the following error.
Code:
xauth: error while loading shared libraries:libXmuu.so.1: cannot open shared object file: No such file or directory
xauth: error while loading shared libraries:libXmuu.so.1: cannot open shared object file: No such file or directory
xauth: error while loading shared libraries:libXmuu.so.1: cannot open shared object file: No such file or directory
xauth: error while loading shared libraries:libXmuu.so.1: cannot open shared object file: No such file or directory
xauth: error while loading shared libraries:libX11.so.6: cannot open shared object file: No such file or directory
xauth: error while loading shared libraries:libXmuu.so.1: cannot open shared object file: No such file or directory
I did some checking on Google and found another post, http://www.linuxquestions.org/questi...48#post1337348. So I tried some of the commands I saw there. Here are my results:

Code:
x-configure
-bash: x-configure: command not found

Code:
xf86config
-bash: xf86config: command not found

Code:
echo $LD_LIBRARY_PATH
Does nothing

Code:
locate libXmuu
/usr/X11R6/lib/libXmuu.so.1.0
/usr/X11R6/lib/libXmuu.so
/usr/X11R6/lib/libXmuu.so.1
/usr/X11R6/lib/libXmuu.a

Please help me! I have no idea what to do, and the CLI isn't going to make me a Linux convert. Thank you all!

Last edited by thomasfingram; 07-10-2005 at 12:51 PM.
 
Old 07-07-2005, 03:38 PM   #2
thomasfingram
Member
 
Registered: Jun 2005
Location: Cary, NC
Distribution: Fedora Core 4
Posts: 44

Original Poster
Rep: Reputation: 15
Does nobody know how to fix this?
 
Old 07-10-2005, 01:31 PM   #3
thomasfingram
Member
 
Registered: Jun 2005
Location: Cary, NC
Distribution: Fedora Core 4
Posts: 44

Original Poster
Rep: Reputation: 15
Unhappy

Well I found a solution on another website. He said to add /usr/X11R6/lib to the /etc/ld.so.conf and then run lbconfig. I did so, but when I ran lbconfig it came back with 'Bus error' after waiting a minute. Then I saw that /usr/X11R6/lib was already in the file, so I opened it up and removed the second entry. Just for kicks I re-ran lbconfig and got the same error. Also I read that I need to use xorgconfig, since I am using Slackware 10.1. When I do that, I get this error:
Code:
xorgconfig: error while loading shared libraries: libxkbfile.so.1: cannot open shared object file: No such file or directory
So now I'm kinda thinking, maybe I should (re-)install an X server. Should I do that (and how?), or should I try something else? Somebody please help!
 
Old 07-11-2005, 02:35 AM   #4
thomasfingram
Member
 
Registered: Jun 2005
Location: Cary, NC
Distribution: Fedora Core 4
Posts: 44

Original Poster
Rep: Reputation: 15
Please forgive me, but why doesn't anybody even acknowledge my cry for help?!
 
Old 07-30-2005, 08:33 PM   #5
StevePhM
Member
 
Registered: Oct 2003
Distribution: SuSE10.1
Posts: 36

Rep: Reputation: 15
I am having exactly the same problem with my LFS install. Did you ever find a solution??
 
Old 07-30-2005, 09:10 PM   #6
Mr. New
Member
 
Registered: Oct 2004
Distribution: Kubuntu and Mac OS X
Posts: 80

Rep: Reputation: 15
ok this is almost guaranteed to be wrong, but did you try deleting .Xauthority, just earlier today I had a problem with xauth so I deleted it and it recreated the file and worked
other than that did you guys try running x as root?
If it works tell us all, but if it doesn't you did google for libxkbfile.so.1 right?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
about xauth? Chowroc Linux - General 6 05-24-2005 06:21 PM
How to use xauth? Chowroc Linux - Networking 1 05-22-2005 11:31 AM
How can I get xauth with startx? hypnos Linux - Software 1 01-15-2005 05:39 PM
xauth - where is it? (VNC) figmentium Linux - Newbie 6 07-19-2003 03:00 PM
su - and xauth .. doublefailure Linux - General 0 03-05-2003 04:46 PM


All times are GMT -5. The time now is 02:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration