LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-11-2009, 12:57 PM   #1
sladel
LQ Newbie
 
Registered: Oct 2007
Posts: 4

Rep: Reputation: 0
Xandros desktop display shows green word Volume


I am using Xandros version 4.1
The desktop screen has the word Volume written in large green letters with green bars across the screen. This unwanted display is always on top of every window, and it blocks everything behind it. I have tried restarting the session, starting a new session, completely shutting down the computer. The green Volume and bars always reappear. I cannot find any remedy in the Users Guide. I hope that someone has solved this problem and will post a reply.
 
Old 10-12-2009, 09:54 AM   #2
Laurens73
Member
 
Registered: Aug 2009
Location: Zeewolde, Flevoland NL
Distribution: Debian squeeze (Gnome) on netbooks; Debian Lenny on servers and Debian wheezy (XFCE) on new laptops
Posts: 144

Rep: Reputation: 23
Looks like an on screen display of a mixer or a audio / video player. What you could do (the dirty way) is to open a process manager, depending on the window manager you use (Gnome / Kde / Xfce / Lxde / Fvwm / Openbox) or open a console window and type
Code:
top
to see if a program like a mixer or player is getting in the way. Cancel the viewing by pressing [Ctrl]-[C]. If you see such a process, type
Code:
kill processid
until the green bars disappear. Don't do this as root / sudoer since system processes are not allowed to be killed when not neccesary.

Last edited by Laurens73; 10-12-2009 at 09:56 AM.
 
Old 10-17-2009, 02:18 PM   #3
sladel
LQ Newbie
 
Registered: Oct 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Thank you, Laurens73

I followed your advice and killed all processes related to audio/video/mixers, but the green Volume and bars didn't go away. Then I logged out and back in as Administrator, because I NEVER used any audio applications in an Administrator session. The green Volume showed up on the Administrator desktop background too !! That made me realize that the problem must be a hardware issue, not a running application process issue. Then I removed the USB external speaker, and finally the screen display went away. After some time, I was able to change the volume controls on the external speaker, and the green Volume display did not return, even when the speaker was re-attached.

Thanks to YOU, I learned about using "top" at the command line, and I was able to get to a solution for the problem.

Now a new issue has arrived. The external speaker can be selected from my SKYPE options, and it works perfectly. I cannot find out how to make the USB speaker the DEFAULT audio for all applications. Control Center, Hardware Detection identifies the external speaker as a "Generic Device" instead of an "Audio Device". I am trying to learn now how to make the USB device become the default audio device for use with the ALSA controller.
Best regards, sladel (who has fond memories of travel in Holland)
 
Old 10-18-2009, 11:56 PM   #4
Laurens73
Member
 
Registered: Aug 2009
Location: Zeewolde, Flevoland NL
Distribution: Debian squeeze (Gnome) on netbooks; Debian Lenny on servers and Debian wheezy (XFCE) on new laptops
Posts: 144

Rep: Reputation: 23
Since I also didn't know it myself I searched the internet and found something wich could help you out:

Quote:
Create a configuration file (either for the whole system at /etc/asound.conf or .asoundrc in your home directory) containing statements like the following ones:
Code:
defaults.ctl.card 1
defaults.pcm.card 1
defaults.timer.card 1
This file would make card 1 the default. The card number (1 in this example) is taken from the /proc/asound/cards file. For a description of the ALSA configuration file format see the ALSA library API documentation.
You said you had the same problem in other profiles (root) as well, the best choice for setting the standard device will be then creating the /etc/asound.conf file in stead of putting such a file in every home directory. Succes

Last edited by Laurens73; 10-18-2009 at 11:59 PM.
 
Old 10-20-2009, 02:43 PM   #5
sladel
LQ Newbie
 
Registered: Oct 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Thank you again, Laurens73
I used
aplay -l
to confirm that card 1 is the card that I wanted to use.

Then I did exactly as you suggested and created
/etc/asound.conf
with the exact text.
defaults.ctl.card 1
defaults.pcm.card 1
defaults.timer.card 1

Now everything is working perfectly, and ALL applications use the external USB speaker.
You have saved me weeks of headaches.
sladel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ls -l shows mounts with a green block of colour round them 0ddba11 Linux - Server 4 03-18-2015 10:18 AM
LXer: The Buzz Word Today Is Green LXer Syndicated Linux News 0 01-16-2008 06:51 PM
totem n other media player shows no video(Hz green lines??) after installing updates? The_neo Mandriva 0 07-15-2004 03:47 AM
desktop shows on TV but movie shows black screen litrelord Mandriva 6 07-05-2004 05:10 AM
Xandros to unveil new Corel variant "Xandros Desktop 1.0" kodiakmook Linux - Distributions 0 01-30-2002 11:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration