LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-07-2010, 08:49 AM   #1
Taylrl
Member
 
Registered: Jul 2010
Distribution: Ubuntu
Posts: 34

Rep: Reputation: 0
X11 connection rejected because of wrong authentication????????


Hi,

I am relatively new to linux but learning :-) At the moment I am trying to ssh into another machine and I want to be able to display the things on that machine on mine (A .pdf for example). I don't think its a problem with how I am logging as I am typing;

ssh -X username@externalhost

when I come to open a file or program that exists on that machine I am receiving the error;

X11 connection rejected because of wrong authentication
X connection to localhost:28.0 broken(explicit kill or server shutdown).

I have been having a look online and it does seem to be quite a common error which is normally resolved by editing the /etc/ssh/ssh_config file so that it says;

X11 Forwarding yes

instead of;

# X11 Forwarding no

Is this even right? Should I have removed the # and simply changed the "no" into a "yes"?? As you can probably see I am getting a bit confused and simply want to be able to display a .pdf remotely. Your help is most appreciated.

Thanks!!
Taylrl
 
Old 12-07-2010, 09:05 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,650

Rep: Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525
Yes, sort of. This is normally a server setting. You should set X11Forwarding (no space) to yes in /etc/ssh/sshd_config (with the d) on the externalhost and restart SSHD.

ssh_config (no d) is a client setting and while it's possible X forwarding is disabled by your client, it would be rare.

Last edited by AlucardZero; 12-07-2010 at 09:07 AM.
 
Old 12-07-2010, 09:19 AM   #3
Taylrl
Member
 
Registered: Jul 2010
Distribution: Ubuntu
Posts: 34

Original Poster
Rep: Reputation: 0
Ok, thanks! I thought the sshd_config file was the same as the ssh_config file and was changing it on the client.

I have now found the sshd_config file on the externalhost and it was already set to allow X11Forwarding. Having had a further look about on the net, I have found that some people have a had a problem because they have been unable to save a /.X11authority file in a /inet folder. I can't seem to find this folder of any files with that name. Might this be the problem?
 
Old 12-07-2010, 09:30 AM   #4
Taylrl
Member
 
Registered: Jul 2010
Distribution: Ubuntu
Posts: 34

Original Poster
Rep: Reputation: 0
The linux fairies seem to have been working their magic as I am no longer getting this problem. I am 99% sure its nothing I have done.

Thanks for the help again!!!

:-)
 
Old 12-07-2010, 10:51 AM   #5
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,650

Rep: Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525
Right, if you can't write to your home directory (wherever it is) then X forwarding won't work. Glad to hear it's working now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X11 connection rejected because of wrong authentication wmasry Linux - Newbie 1 10-19-2010 07:43 AM
Newbie: session manager: Authentication Rejected FredJones Debian 1 05-20-2008 08:26 AM
Authentication Rejected Gary L. Roach Linux - Security 2 04-28-2007 04:14 PM
Authentication rejected problem flycast Debian 1 12-11-2006 02:03 AM
mythtv authentication rejected ssfrstlstnm Linux - Software 7 01-18-2006 09:16 PM


All times are GMT -5. The time now is 01:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration