LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-14-2006, 07:32 PM   #1
Evok3
LQ Newbie
 
Registered: Feb 2006
Posts: 18

Rep: Reputation: 0
X wont start after update/Nvidia kernal/module problem


Hi, I just realised almost everything on my computer needed updating according to Synaptic. So after a lengthy download and update I rebooted my computer. Then when X was supposed to load up I got an error. I can't post that error because I couldn't copy&paste it, sorry. It was something about being unable to load Nvidia kernal module and module not found, aswell as not being able to find a screen(or one exists, but not configured). I've searched the forum but couldn't find the same error. The only way I can get x to load(and the reason I'm typing this now) is because I reistalled my xorg.conf file from my MEPIS installation disc.

What I did find was alot of post saying reinstall should help, so I got the Nvidia Driver from the Nvidia site and when I tried to install that I got another problem. First it couldn't download a kernal(I have no idea what most of this means btw) so when it said it would try and make one it failed on that too. Here is my nvidia install log:
Code:
dia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Apr 15 01:02:16 2006

option status:
  license pre-accepted    : false
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : false
  driver info             : false
  no precompiled interface: false
  no ncurses color        : false
  query latest driver ver : false
  OpenGL header files     : true
  no questions            : false
  silent                  : false
  no backup               : false
  kernel module only      : false
  sanity                  : false
  add this kernel         : false
  no runlevel check       : false
  no network              : false
  no ABI note             : false
  no RPMs                 : false
  force tls               : (not specified)
  force compat32 tls      : (not specified)
  X install prefix        : /usr/X11R6
  OpenGL install prefix   : /usr
  compat32 install prefix : (not specified)
  installer install prefix: /usr
  utility install prefix  : /usr
  kernel name             : (not specified)
  kernel include path     : (not specified)
  kernel source path      : (not specified)
  kernel output path      : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /tmp
  ftp mirror              : ftp://download.nvidia.com
  RPM file list           : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
   ke the installer to attempt to download a kernel interface for your kernel f
   rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
   this means that the installer will need to compile a kernel interface for
   your kernel.
-> Performing CC test with CC="cc".
ERROR: Unable to find the kernel source tree for the currently running kernel. 
       Please make sure you have installed the kernel source files for your
       kernel and that they are properly configured; on Red Hat Linux systems,
       for example, be sure you have the 'kernel-source' RPM installed.  If you
       know the correct kernel source files are installed, you may specify the
       kernel source path with the '--kernel-source-path' command line option.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.
Incase it helps.

The xorg.conf I'm using now doean't let me play a game which is one of the main reasons I use linux, another error. Anyway, this is the xorg.conf which DOESN'T work, which I need to work:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (randy@juliet2)  Fri Dec 30 21:53:37 PST 2005

# Settings for wacom eraser
# Settings for wacom cursor (mouse)

Section "ServerLayout"

 #Screen 0 "ATIScreen" 0 0
 #InputDevice "USB Mouse" "CorePointer"
 #InputDevice "Touchpad" "CorePointer"
 #InputDevice "Stylus" "CorePointer"
 #InputDevice "Eraser" "CorePointer"
 #InputDevice "Cursor" "CorePointer"
 #InputDevice "Serial Mouse" "CorePointer"
    Identifier     "XFree86 Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "PS/2 Mouse" "CorePointer"
EndSection

Section "Files"

# True type and type1 fonts
    RgbPath         "/usr/X11R6/lib/X11/rgb"
    ModulePath      "/usr/X11R6/lib/modules"
    FontPath        "/usr/X11R6/lib/X11/fonts/misc:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/Speedo"
    FontPath        "/usr/X11R6/lib/X11/fonts/PEX"
    FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath        "/usr/share/fonts/truetype/ttf-xfree86-nonfree"
    FontPath        "/usr/share/fonts/truetype/java"
    FontPath        "/usr/share/fonts/truetype/arphic"
    FontPath        "/usr/share/fonts/truetype/freefont"
    FontPath        "/usr/share/fonts/truetype/openoffice"
    FontPath        "/usr/share/fonts/truetype/ttf-bitstream-vera"
    FontPath        "/usr/share/fonts/ttf/western"
    FontPath        "/usr/share/fonts/ttf/decoratives"
    FontPath        "/usr/share/fonts/type1/gsfonts"
    FontPath        "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath        "/usr/X11R6/lib/X11/fonts/defoma/CID"
    FontPath        "/usr/X11R6/lib/X11/fonts/defoma/TrueType"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
    FontPath        "/usr/local/share/fonts"
    FontPath        "/usr/share/fonts"
    FontPath        "/usr/X11R6/lib/X11/fonts"
    FontPath        "/usr/share/fonts/afms"
    FontPath        "/usr/share/fonts/bitmap"
    FontPath        "/usr/share/fonts/truetype"
    FontPath        "/usr/share/fonts/ttf"
    FontPath        "/usr/share/fonts/type1"
    FontPath        "/usr/X11R6/lib/X11/fonts/defoma"
EndSection

Section "Module"
    Load           "bitmap"
    Load           "dbe"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "record"
    Load           "speedo"
    Load           "type1"
    Load           "vbe"
    Load           "synaptics"
EndSection

Section "ServerFlags"
    Option         "AllowMouseOpenFail" "true"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "CoreKeyboard"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
    Option         "XKbOptions" ""
EndSection

Section "InputDevice"
    Identifier     "Serial Mouse"
    Driver         "mouse"
    Option         "Protocol" "Microsoft"
    Option         "Device" "/dev/ttyS0"
    Option         "Emulate3Buttons" "false"
    Option         "Emulate3Timeout" "70"
EndSection

Section "InputDevice"
    Identifier     "Touchpad"
    Driver         "synaptics"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "LeftEdge" "1700"
    Option         "RightEdge" "5300"
    Option         "TopEdge" "1700"
    Option         "BottomEdge" "4200"
    Option         "FingerLow" "25"
    Option         "FingerHigh" "30"
    Option         "MaxTapTime" "180"
    Option         "MaxTapMove" "220"
    Option         "VertScrollDelta" "100"
    Option         "MinSpeed" "0.06"
    Option         "MaxSpeed" "0.12"
    Option         "AccelFactor" "0.0010"
    Option         "SHMConfig" "on"
    Option         "Repeater" "/dev/input/mice"
EndSection

Section "InputDevice"
    Identifier     "PS/2 Mouse"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "false"
    Option         "Emulate3Timeout" "70"
    Option         "ZAxisMapping" "4 5"
    Option         "Buttons" "5"
EndSection

Section "InputDevice"
    Identifier     "USB Mouse"
    Driver         "mouse"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ExplorerPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Buttons" "5"
EndSection

Section "InputDevice"
    Identifier     "Stylus"
    Driver         "wacom"
    Option         "Mode" "Absolute"
    Option         "Type" "stylus"
    Option         "Device" "/dev/input/wacom"
EndSection

Section "InputDevice"
    Identifier     "Eraser"
    Driver         "wacom"
    Option         "Mode" "Absolute"
    Option         "Type" "eraser"
    Option         "Device" "/dev/input/wacom"
EndSection

Section "InputDevice"
    Identifier     "Cursor"
    Driver         "wacom"
    Option         "Mode" "Absolute"
    Option         "Type" "cursor"
    Option         "Device" "/dev/input/wacom"
EndSection

Section "Monitor"

 #Option "DPMS" "true"
 # Warning: This may fry old Monitors
 # Very conservative. May flicker.
    Identifier     "Monitor0"
    VendorName     "unknown"
    ModelName      "unknown"
    HorizSync       30.0 - 82.0
    VertRefresh     50.0 - 70.0
    ModeLine       "640x480" 25.2 640 664 760 800 480 491 493 525
    ModeLine       "800x600" 40.1 800 848 968 1056 600 601 605 628
    ModeLine       "1024x768" 75.0 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
    ModeLine       "1024x768" 85.0 1024 1056 1152 1360 768 784 787 823
    ModeLine       "1152x864" 65.0 1152 1168 1384 1480 864 865 875 985 interlace
    ModeLine       "1152x864" 92.0 1152 1208 1368 1474 864 865 875 895
    ModeLine       "1152x864" 110.0 1152 1240 1324 1552 864 864 876 908
    ModeLine       "1152x864" 135.0 1152 1464 1592 1776 864 864 876 908
    ModeLine       "1152x864" 137.7 1152 1184 1312 1536 864 866 885 902 -hsync -vsync
    ModeLine       "1280x768" 80.1 1280 1344 1480 1680 768 769 772 795
    ModeLine       "1280x800" 80.6 1280 1344 1480 1680 800 801 804 827 -hsync -vsync
    ModeLine       "1280x1024" 80.0 1280 1296 1512 1568 1024 1025 1037 1165 interlace
    ModeLine       "1280x1024" 110.0 1280 1328 1512 1712 1024 1025 1028 1054
    ModeLine       "1280x1024" 126.5 1280 1312 1472 1696 1024 1032 1040 1068 -hsync -vsync
    ModeLine       "1280x1024" 135.0 1280 1312 1456 1712 1024 1027 1030 1064
    ModeLine       "1280x1024" 135.0 1280 1312 1416 1664 1024 1027 1030 1064
    ModeLine       "1280x1024" 157.5 1280 1344 1504 1728 1024 1025 1028 1072 +hsync +vsync
    ModeLine       "1280x1024" 181.8 1280 1312 1440 1696 1024 1031 1046 1072 -hsync -vsync
    ModeLine       "1440x900" 106.5 1440 1520 1672 1904 900 901 904 932 +hsync +vsync
    ModeLine       "1400x1050" 129.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
    ModeLine       "1600x1200" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
    ModeLine       "1600x1200" 189.0 1600 1664 1856 2160 1200 1201 1204 1250 -hsync -vsync
    ModeLine       "1600x1200" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
    ModeLine       "1600x1200" 220.0 1600 1616 1808 2080 1200 1204 1207 1244 +hsync +vsync
    ModeLine       "1680x1050" 147.1 1680 1784 1968 2256 1050 1051 1054 1087
    ModeLine       "1800x1440" 230.0 1800 1896 2088 2392 1440 1441 1444 1490 +hsync +vsync
    ModeLine       "1800x1440" 250.0 1800 1896 2088 2392 1440 1441 1444 1490 +hsync +vsync
    ModeLine       "1920x1200" 230.0 1920 1936 2096 2528 1200 1201 1204 1250 +hsync +vsync
EndSection

Section "Monitor"

 #Option "DPMS" "true"
 # Warning: This may fry old Monitors
 # Very conservative. May flicker.
    Identifier     "ATIMonitor"
    VendorName     "unknown"
    ModelName      "unknown"
    HorizSync       30.0 - 82.0
    VertRefresh     50.0 - 70.0
EndSection

Section "Device"

 #BusID  "PCI:1:0:0"
 #Option "sw_cursor" # needed for some ati cards
 #Option "hw_cursor"
 #Option "NoAccel"
 #Option "ShowCache"
 #Option "ShadowFB"
 #Option "UseFBDev"
 #Option "Rotate"
 #Option "NoUseBios" # needed for some Savage cards
    Identifier     "Card0"
    Driver         "nvidia"
    BoardName      "unknown"
EndSection

Section "Screen"

  # Only the official NVIDIA driver supports twinview
  # these setting are an example
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    16
    Option         "TwinView" "false"
    Option         "SecondMonitorVendorName" "unknown"
    Option         "SecondMonitorModelName" "unknown"
    Option         "SecondMonitorHorizSync" "30-82"
    Option         "SecondMonitorVertRefresh" "50-70"
    Option         "MetaModes" "1024x768, 1024x768"
    Option         "TwinViewOrientation" "RightOf"
    Option         "ConnectedMonitor" "dfp,dfp"
    Option         "UseInternalAGPGART" "no"
# nvidia special options, use with care
    Option         "CursorShadow" "1"
    Option         "CursorShadowAlpha" "63"
    Option         "CursorShadowYOffset" "2"
    Option         "CursorShadowXOffset" "4"
    Option         "FlatPanelProperties" "Scaling = native"
    Option         "NoLogo" "false"
    Option         "IgnoreEdid" "true" # needs to be true for some nvidia cards
    SubSection     "Display"
        Depth       8
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       32
        Modes      "1024x768"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "ATIScreen"
    Device         "Card0"
    Monitor        "ATIMonitor"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1024x768"
    EndSubSection
EndSection
I don't know if getting that xorg.conf to work will fix it, or if I have to reinstall thta driver will, or both(if they are related), so I figured I'd post both. I'm running Mepis 3.4 and the 2.6.15-1-586tsc Kernal(That's what uname -r says anyway), any info you need whih I've missed, let me know.

Thanks and regards,
--Evok3--

EDIT: I just searched around Synaptic and installed a few files, I serched rof "kernel-source" and installed the nvidia-kernel-source aswell as a kernel-source 2.4(I think), retried but still didn't work. The nI looked for "nvidia" and installed the 586tsc kernel but that didn't work either. I'm totaly stumped now, no idea what else I could try.

Last edited by Evok3; 04-14-2006 at 08:11 PM.
 
Old 04-15-2006, 09:02 AM   #2
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
Hello
Quote:
ERROR: Unable to find the kernel source tree for the currently running kernel
The answer is there: you need the kernel source of your running kernel.
If 'uname -r' says 2.6.15-1-586tsc kernel, you need this kernel source, not another one. The two must match.
As for the xorg.conf file, after you will have successfully installed the nVidia driver, you can re-use the xorg.conf you need, because the problem is not there.
Good luck.
 
Old 04-15-2006, 01:32 PM   #3
Evok3
LQ Newbie
 
Registered: Feb 2006
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks for your reply but I already tried that:
Quote:
Then I looked for "nvidia" and installed the 586tsc kernel but that didn't work either
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
linux wont start after kernel update avinashtn Linux - Software 3 03-28-2005 12:45 PM
Mismatch between NVIDIA Kernal and X module ccin1492 Linux - Distributions 10 03-01-2004 12:14 PM
nvidia driver 5328 redhat 9 module wont load restlekak Linux - Hardware 1 01-24-2004 02:21 PM
Kernal update through RHN, NVIDIA no longer loads.... DraaX Linux - Newbie 3 09-21-2003 06:50 PM
Kernal update via RHN, NVIDIA won't load.... DraaX Red Hat 0 09-21-2003 04:34 PM


All times are GMT -5. The time now is 11:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration