LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-14-2003, 07:22 PM   #1
dstrozzi
LQ Newbie
 
Registered: Jul 2001
Location: Cambridge, MA
Distribution: RedHat 7.1
Posts: 4

Rep: Reputation: 0
X won't start on Matrox Millneium II, Debian


Hi,

Today I installed Debian 3.0 r1 for i386 from CD images downloaded w/ jigdo. I have a Matrox Millenium II video card (almost positive it has an mga chipset). The installation went smooth, except X doesn't work. When I boot, the system tries to start gdm. It's can't. The last error is:

(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

(I'll post the whole XFree86.0.log file at the end)

During the boot process, however, a picture of a pengiun appears, and the text for kernel messages seems to be some 'graphical font' and not the standard built-in 80x25 text you get when you boot in DOS. The penguin turns psychedelic colors at some point (like something from a Ken Kesey Acid Test).

After gdm fails to start, linus asks me if I want to see the log file, and then if I want to try to fix it. I answer yes, and a bare-bones X interface starts (I think it's xf86cfg or xf86config, whichever is graphical) with a diagram of a monitor, mouse, system, and directions for how to use the keypad in case the mouse doesn't work.

Well, it turns out the mouse doesn't work! I have a logitech 3-button mouse on a serial port (windoze claims it's on com1). I tried configuring it as a logitech mouse and microsoft mouse, niether works.

So,

1. How do I get the graphical part of X to work, and

2. How do I get my mouse to work?

Long ago I installed redhat 7.3 on this very hardware, so it is linux-compatible.

Thanks very very much!

Here's the Xfree86.0.log file:


This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs)

XFree86 Version 4.1.0.1 / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 21 December 2001
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/FAQ)
Build Operating System: Linux 2.4.17 i686 [ELF]
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Sat Jun 14 17:50:24 2003
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Generic Monitor"
(**) | |-->Device "Generic Video Card"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
(**) |-->Input Device "Generic Mouse"
(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(**) FontPath set to "unix/:7100,/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100dpi/:unscaled,/usr/lib/X11/fonts/75dpi/:unscaled,/usr/lib/X11/fonts/Type1,/usr/lib/X11/fonts/Speedo,/usr/lib/X11/fonts/100dpi,/usr/lib/X11/fonts/75dpi"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 9

(WW) Cannot open APM
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.4
XFree86 XInput driver : 0.2
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.2
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,0597 card 0000,0000 rev 04 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1106,8598 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:07:0: chip 1106,0586 card 1106,0000 rev 41 class 06,01,00 hdr 80
(II) PCI: 00:07:1: chip 1106,0571 card 0000,0000 rev 06 class 01,01,8a hdr 00
(II) PCI: 00:07:3: chip 1106,3040 card 0000,0000 rev 10 class 06,00,00 hdr 00
(II) PCI: 00:09:0: chip 102b,051a card 102b,0000 rev 03 class 03,00,00 hdr 00
(II) PCI: 00:0a:0: chip 127a,1024 card 144f,1008 rev 01 class 07,80,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) Host-to-PCI bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x04 (VGA_EN is cleared)
(II) Bus 1 I/O range:
[0] -1 0 0x0000d000 - 0x0000d0ff (0x100) IX[B]
[1] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[B]
[2] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[B]
[3] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
(II) Bus 1 non-prefetchable memory range:
(II) Bus 1 prefetchable memory range:
(II) Bus -1: bridge is at (0:7:0), (0,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(II) Bus -1: bridge is at (0:0:0), (-1,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus -1 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus -1 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(--) PCI:*(0:9:0) Matrox MGA 1064SG rev 3, Mem @ 0xe4000000/23, 0xe5000000/14, 0xe6000000/23, BIOS @ 0xe7000000/16
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) Active PCI resource ranges:
[0] -1 0 0xe8000000 - 0xefffffff (0x8000000) MX[B]E
[1] -1 0 0xe0000000 - 0xffffffff (0x20000000) MX[B]E
[2] -1 0 0xe7000000 - 0xe700ffff (0x10000) MX[B](B)
[3] -1 0 0xe6000000 - 0xe67fffff (0x800000) MX[B](B)
[4] -1 0 0xe5000000 - 0xe5003fff (0x4000) MX[B](B)
[5] -1 0 0xe4000000 - 0xe47fffff (0x800000) MX[B](B)
[6] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]E
[7] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]E
(II) PCI Memory resource overlap reduced 0xe0000000 from 0xffffffff to 0xe3ffffff
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xe8000000 - 0xefffffff (0x8000000) MX[B]E
[1] -1 0 0xe0000000 - 0xe3ffffff (0x4000000) MX[B]E
[2] -1 0 0xe7000000 - 0xe700ffff (0x10000) MX[B](B)
[3] -1 0 0xe6000000 - 0xe67fffff (0x800000) MX[B](B)
[4] -1 0 0xe5000000 - 0xe5003fff (0x4000) MX[B](B)
[5] -1 0 0xe4000000 - 0xe47fffff (0x800000) MX[B](B)
[6] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]E
[7] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]E
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xe8000000 - 0xefffffff (0x8000000) MX[B]E
[6] -1 0 0xe0000000 - 0xe3ffffff (0x4000000) MX[B]E
[7] -1 0 0xe7000000 - 0xe700ffff (0x10000) MX[B](B)
[8] -1 0 0xe6000000 - 0xe67fffff (0x800000) MX[B](B)
[9] -1 0 0xe5000000 - 0xe5003fff (0x4000) MX[B](B)
[10] -1 0 0xe4000000 - 0xe47fffff (0x800000) MX[B](B)
[11] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[12] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[13] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]E
[14] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]E
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) LoadModule: "bitmap"
(II) Reloading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Loading font Bitmap
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.1.9
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Reloading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Loading extension GLX
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "pex5"
(II) Loading /usr/X11R6/lib/modules/extensions/libpex5.a
(II) Module pex5: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension X3D-PEX
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension RECORD
(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
(II) Module speedo: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Speedo
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "vbe"
(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "xie"
(II) Loading /usr/X11R6/lib/modules/extensions/libxie.a
(II) Module xie: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension XIE
(II) LoadModule: "mga"
(II) Loading /usr/X11R6/lib/modules/drivers/mga_drv.o
(II) Module mga: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.1
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.2
(II) MGA: driver for Matrox chipsets: mga2064w, mga1064sg, mga2164w,
mga2164w AGP, mgag100, mgag100 PCI, mgag200, mgag200 PCI, mgag400
(II) Primary Device is: PCI 00:09:0
(--) Assigning device section with no busID to primary device
(--) Chipset mga1064sg found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xe8000000 - 0xefffffff (0x8000000) MX[B]E
[6] -1 0 0xe0000000 - 0xe3ffffff (0x4000000) MX[B]E
[7] -1 0 0xe7000000 - 0xe700ffff (0x10000) MX[B](B)
[8] -1 0 0xe6000000 - 0xe67fffff (0x800000) MX[B](B)
[9] -1 0 0xe5000000 - 0xe5003fff (0x4000) MX[B](B)
[10] -1 0 0xe4000000 - 0xe47fffff (0x800000) MX[B](B)
[11] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[12] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[13] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]E
[14] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]E
(II) resource ranges after probing:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xe8000000 - 0xefffffff (0x8000000) MX[B]E
[6] -1 0 0xe0000000 - 0xe3ffffff (0x4000000) MX[B]E
[7] -1 0 0xe7000000 - 0xe700ffff (0x10000) MX[B](B)
[8] -1 0 0xe6000000 - 0xe67fffff (0x800000) MX[B](B)
[9] -1 0 0xe5000000 - 0xe5003fff (0x4000) MX[B](B)
[10] -1 0 0xe4000000 - 0xe47fffff (0x800000) MX[B](B)
[11] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
[12] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B]
[13] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B]
[14] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[15] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[16] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]E
[17] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]E
[18] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
[19] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(**) MGA(0): Depth 16, (--) framebuffer bpp 16
(==) MGA(0): RGB weight 565
(**) MGA(0): Option "UseFBDev" "true"
(II) MGA(0): Matrox HAL module not found - using builtin mode setup instead
(--) MGA(0): Chipset: "mga1064sg"
(==) MGA(0): Using AGP 1x mode
(**) MGA(0): Using framebuffer device
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.0.2
ABI class: XFree86 Video Driver, version 0.4
(II) UnloadModule: "mga"
(II) UnloadModule: "fbdevhw"
(II) Unloading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
 
Old 06-14-2003, 07:26 PM   #2
darin3200
LQ Guru
 
Registered: Dec 2002
Distribution: Gentoo!
Posts: 1,153

Rep: Reputation: 45
have your tried running xf86config to get everything set up to your computer?
 
Old 06-15-2003, 12:14 AM   #3
footfrisbee
Member
 
Registered: Apr 2003
Distribution: Debian Sarge
Posts: 259

Rep: Reputation: 30
As root run

# dpkg-reconfigure xserver-xfree86

This will use debconf to handle the installation of the server. Have the info for your video card and monitor handy. "lspci -vv" is useful for getting info for your video card.

As for your mouse, when debconf asks about the mouse try /dev/ttyS0, that's COM1 in windows.

Chris
 
Old 06-15-2003, 09:40 AM   #4
dstrozzi
LQ Newbie
 
Registered: Jul 2001
Location: Cambridge, MA
Distribution: RedHat 7.1
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for getting back to me!

I've tried xf86config and xf86cfg (text and graphical version), to no avail. I also tried the dpkg approach today, still no lucl. I get the same output in the log file...

One thing I didn't enter in the dpkg approach was a bus ID for my card. The info on the screen before tells me not to worry about it if I'm not using PowerPC and have just one video card (which describes me). I couldn't figure out from what lspci said what the bus ID is.

Upon looking closer at the screen dump when X fails, the following lines toward the end look suspicious:

(**) MGA(0): Option "UseFBDev" "true"
(II) MGA(0): Matrox HAL module not found - using builtin mode setup instead
(--) MGA(0): Chipset: "mga1064sg"
(==) MGA(0): Using AGP 1x mode
(**) MGA(0): Using framebuffer device
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.0.2
ABI class: XFree86 Video Driver, version 0.4
(II) UnloadModule: "mga"


*** Questions:

1. Should I worry that the Matrox HAL is not found?
2. It claims it's working in AGP mode, but this is a PCI card. There's no AGP port on my motherboard at all.
3. Why is it unloading the MGA module?

My video card is a matrox mystique and mga is the right driver for the chipset (I gather).

Thanks.
 
Old 06-15-2003, 01:31 PM   #5
Qzukk
Member
 
Registered: Jun 2003
Posts: 132

Rep: Reputation: 15
When all else fails, try

X -configure

This nifty new option in XFree86 4.x usually beats the old manual configuration tools, and even provides instructions on how to test and use the new config file it generates.

It will probably fail at detecting your mouse, which should be on /dev/ttyS0. It will give you instructions on how to set that in the new config file. Also, debian renamed "XFree86" to just "X" to fit the naming scheme that X used forever... when it tells you to test the file by running XFree86, just ignore it and use X instead.

Also, the penguin-on-boot is due to the Framebuffer. It may be that while the kernel is using the videocard for the Framebuffer, X cannot use the video card too. (I don't know if this is true, I use a geforce without a framebuffer You might have to use the "fbdev" framebuffer X server device instead of mga. It may also be unloading because its looking for an AGP card instead of PCI, you should check your /etc/X11/XF86Config file (or -4... not sure which filename Debian 3 uses)
 
Old 06-15-2003, 04:01 PM   #6
footfrisbee
Member
 
Registered: Apr 2003
Distribution: Debian Sarge
Posts: 259

Rep: Reputation: 30
Don't give up hope dstrozzi! A quick google turned up a page at lists.debian.org that suggests you should turn off use of the kernel framebuffer device when using the dpkg method.

Chris

Last edited by footfrisbee; 06-15-2003 at 04:03 PM.
 
Old 06-16-2003, 12:46 PM   #7
dstrozzi
LQ Newbie
 
Registered: Jul 2001
Location: Cambridge, MA
Distribution: RedHat 7.1
Posts: 4

Original Poster
Rep: Reputation: 0
It worked!

X -configure worked like a charm. Thanks a lot! Too bad the debian installer didn't work like a charm...

You have earned merit which will help your soul in the afterlife (or your hard drive after the next formatting).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
success with matrox g400/XF86 Dualhead 2 monitor display in Debian arjay Linux - Hardware 0 08-14-2005 07:12 AM
Can't start X on Debian carlosinfl Debian 6 10-21-2004 01:35 PM
Can start the X Windows in Debian explorer1979 Debian 6 08-27-2004 01:35 AM
Matrox Millenium P650 with Debian corwax Linux - Hardware 3 03-06-2004 09:07 PM
Debian / X won't start kwong Linux - General 4 03-03-2003 01:45 PM


All times are GMT -5. The time now is 10:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration