LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-12-2007, 03:47 PM   #1
Rahiiyja
LQ Newbie
 
Registered: Jan 2007
Posts: 10

Rep: Reputation: 0
X won't start after fresh Debian install


Hi.
I have recently installed Debian 3.1, after using Slackware 11.0 for some time. The reason I decided to migrate to Debian was mainly apt.
Anyway, I started the installer and chose "desktop environment" as the only package option, since I don't use my computer as a server in any way. Everything went fine and I finally got to the prompt, but when I typed: 'startx' I got the message that X doesn't exist.

Since I did a beginner install and everything went fine I believe that I am just accustomed to using Slackware, should I type something else than 'startx'?
 
Old 01-12-2007, 04:59 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Did you hit the spacebar so that there was a[*] in front of the Desktop option? If not, you installed just a base system with no X.

The nice thing about apt/aptitude is that you don't need to reinstall (although you can if you want). Instead, you can do aptitude install x-window-system-core kdebase I think kdebase is a stripped down version of KDE without games, koffice, etc. If you want full kde, you would use "kde" instead.

Or you can use apt-cache search string to find the package name of the desktop environment you want.

I personally like to build my systems from the ground so that they're lean and mean. I can always add what I want later w/ aptitude.

Last edited by pljvaldez; 01-12-2007 at 05:00 PM.
 
Old 01-12-2007, 05:01 PM   #3
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 59
Most likely you need to type "aptitude install gnome-core gdm" ... assuming you want Gnome. You'd have been way better off to install Etch instead of Sarge.
 
Old 01-12-2007, 05:03 PM   #4
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Quote:
Originally Posted by rickh
Most likely you need to type "aptitude install gnome-core gdm" ... assuming you want Gnome. You'd have been way better off to install Etch instead of Sarge.
He's right. You can do a dist-upgrade before adding your desktop with minimal pain. Just edit /etc/apt/sources.list and change every "stable" or "sarge" to "etch". Then type aptitude update && aptitude dist-upgrade as root.
 
Old 01-12-2007, 05:28 PM   #5
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,238

Rep: Reputation: 121Reputation: 121
"Anyway, I started the installer and chose "desktop environment" as the only package option, since I don't use my computer as a server in any way."

I did this on one of my laptops and got exactly what you describe. I reinstalled with both the top (server) and bottom(desktop) options enabled and it came out OK. I don't know what's going on, other than to note that those two are the default options in the installer.
 
Old 01-12-2007, 06:28 PM   #6
justin_p
Member
 
Registered: Jan 2004
Location: Virginia, USA
Distribution: slack 13; I've used it all :)
Posts: 433

Rep: Reputation: 30
What is the output when you type "startx"? Having just completed a fresh etch install last week I had the same error. Once you get the error, post it back.
 
Old 01-12-2007, 06:53 PM   #7
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
It is also posible that aptitude didn't install. Aptitude is a modified version of the command apt-get. First, you should not be running stable. That is not for desktops, stable is ancient, and is designed for servers that you never want to change. For a desktop system, the choices are testing or unstable. I use unstable exclsively on my desktop and laptop. In any case, change every sarge or stable in your /etc/apt/sources.list file to testing. Then you should run:
Code:
apt-get update
apt-get dist-upgrade
apt-get install kde (or gnome, or xfce, or whatever you like)
Also, check out the stickied thread on the Debian forums on how to set up a machine from the base install http://www.linuxquestions.org/questi...d.php?t=224547
peace,
JimBass

Last edited by JimBass; 01-12-2007 at 06:55 PM.
 
Old 01-12-2007, 09:10 PM   #8
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 455Reputation: 455Reputation: 455Reputation: 455Reputation: 455
I would go with Etch, newer kernel and way newer apps.

Debian 4.0 Installation Guide
http://d-i.alioth.debian.org/manual/

Sarge is ancient, testing or even unstable is the way to go for a desktop system.

at a text prompt as root use nano /etc/apt/sources.list to edit your sources.list to point to etch

A quick read of the Etch release notes will help you avoid any upgrade issues.
Release Notes for Debian GNU/Linux 4.0 ("etch"), Intel x86 - Upgrades from previous releases
http://www.debian.org/releases/testi...rading.en.html
 
Old 01-13-2007, 02:03 AM   #9
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,238

Rep: Reputation: 121Reputation: 121
"I reinstalled with both the top (server) and bottom(desktop) options enabled and it came out OK."

Don't know what I was thinking of when I posted this. I've just done a fresh etch install to a hard disk I'm messing with, and here is what I did to setup xorg after the Debian install.

1. apt-get install xserver-xorg

When I did step 1, the display suggested that I install these packages, so I did.

2. apt-get install xfonts-100dpi
3. apt-get install xfonts-75dpi
4. apt-get install xfonts-scalable
5. apt-get install xserver-xorg-video-all

The system asked me which video resolutions I wanted to use.

6. apt-get install xserver-xorg-input-all
7. apt-get install xresprobe
8. apt-get install mdetect
9. apt-get install discover1
10. apt-get install discover
11. apt-get install xfonts-base

Restarted the hung gdm with the following
1. /etc/init.d/gdm stop
2. /etc/init.d/gdm start

Magic happened, and I got the graphical login.

Hope this helps.
 
Old 01-13-2007, 08:11 AM   #10
Rahiiyja
LQ Newbie
 
Registered: Jan 2007
Posts: 10

Original Poster
Rep: Reputation: 0
Hello everybody, thanks for all the help.
Since I cannot install my NIC using the Debian installer (onboard NIC), it is impossible for me to add Etch content at the moment. I am downloading Etch through jigdo and burning it to dvd now.

I see now that Sarge doesn't have X or Gnome, so I guess problem is solved after I've installed Etch. ;-)
I just went with Sarge because "stable" sounded better than "testing".
 
Old 01-13-2007, 09:45 AM   #11
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
The 14 CD set of Sarge has X, but the single CD does not. That is also true of testing. Debian installs with the asumption that you have an ethernet connectionl and grabs all the updates you ask for online.

Testing (Etch) comes with a 2.6.17 kernel now I believe, so it should detect your NIC without a problem. Of course you say DVD install, they might pack all of the 14 CDs onto 2 Dvds, but it is much easier just to get the 150 Mb net install image, and let that rock.

Peace,
JimBass
 
Old 01-14-2007, 07:59 AM   #12
Rahiiyja
LQ Newbie
 
Registered: Jan 2007
Posts: 10

Original Poster
Rep: Reputation: 0
JimBass:

Strange, I downloaded the 2 DVD set of Sarge, which I think corresponds with the 14 CD set when it comes to size? But there was no X installed.
 
Old 01-14-2007, 09:41 AM   #13
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 59
Go back and follow the advice given by PJValdez and me in the first two responses. It will install from your DVDs. If that doesn't work, then Sarge is probably too old for your hardware.

It can still be fixed, but Sarge is still a bad idea.

Last edited by rickh; 01-14-2007 at 09:43 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fresh install stops at hotplug start Dachra Slackware - Installation 4 12-29-2006 11:01 AM
FC6 fresh install won't start from XP CD to install XP 2nd ask_save Fedora 2 11-17-2006 06:23 AM
X won't start on fresh install! ? pmzq Mandriva 4 02-11-2006 11:02 PM
Slack 10, fresh install, mysqld start problem. jml75 Slackware 6 08-17-2004 09:26 PM
X Server Won't Start on Fresh Install Thray Debian 4 04-04-2004 05:28 PM


All times are GMT -5. The time now is 06:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration