LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-31-2010, 12:59 PM   #1
cyberblade
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Rep: Reputation: 0
X Won't start


System was running fine, rebooted it and X no longer starts:

# startx
xauth: creating new authority file /root/.serverauth.2225

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.el5 i686 Red Hat, Inc.
Current Operating System: Linux k2 2.6.18-194.8.1.el5 #1 SMP Thu Jul 1 19:07:06 EDT 2010 i686
Build Date: 13 May 2010
Build ID: xorg-x11-server 1.1.1-48.76.el5_5.1
Before reporting problems, check (url removed)
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 31 09:40:21 2010
(==) Using config file: "/etc/X11/xorg.conf"

(EE) I810(0): Cannot open /dev/mem
(EE) I810(0): VBE initialization failed.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

System is CentOS, Linux version 2.6.18-194.8.1.el5

If anyone could point me towards whatever documentation I need or what steps I should try next I'd much appreciate it.
 
Old 08-31-2010, 01:02 PM   #2
CincinnatiKid
Member
 
Registered: Jul 2010
Posts: 431

Rep: Reputation: 33
Are you trying to log in as root? You shouldn't do this. Try a regular user, if you don't have a user created other than root, do the following:

Code:
adduser username
passwd username
 
Old 08-31-2010, 01:05 PM   #3
cyberblade
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by lewisforlife View Post
Are you trying to log in as root? You shouldn't do this. Try a regular user, if you don't have a user created other than root, do the following:

Code:
adduser username
passwd username
I am able to log in fine thank you.

I'm attempting this as root currently to avoid permissions issues.
 
Old 08-31-2010, 01:09 PM   #4
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Did you upgraded something before the reboot?
 
Old 08-31-2010, 01:16 PM   #5
CincinnatiKid
Member
 
Registered: Jul 2010
Posts: 431

Rep: Reputation: 33
Quote:
Originally Posted by cyberblade View Post
I am able to log in fine thank you.

I'm attempting this as root currently to avoid permissions issues.
It is not a good idea to run X is root ever no matter what you are trying to do.

Try this:

Code:
mv /etc/X11/xorg.conf /etc/X11/xorg.conf-bak
Xorg -configure
Then try to 'startx' with a non-root user.
 
Old 08-31-2010, 01:27 PM   #6
cyberblade
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by repo View Post
Did you upgraded something before the reboot?
No, I didn't.

Quote:
Originally Posted by lewisforlife View Post
It is not a good idea to run X is root ever no matter what you are trying to do.

Try this:

Code:
mv /etc/X11/xorg.conf /etc/X11/xorg.conf-bak
Xorg -configure
Then try to 'startx' with a non-root user.
I moved the conf file, and ran Xorg -configure

Then tried it as a non root user:

# su alex_
[alex_@k2 root]$ startx
xauth: creating new authority file /home/alex_/.serverauth.2501

Fatal server error:
PAM authentication failed, cannot start X server.
Perhaps you do not have console ownership?


giving up.
xinit: Connection refused (errno 111): unable to connect to X server
xinit: No such process (errno 3): Server error.
Couldnt get a file descriptor referring to the console


If I try it as root I get the following:

# startx
xauth: creating new authority file /root/.serverauth.2524

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.el5 i686 Red Hat, Inc.
Current Operating System: Linux k2 2.6.18-194.8.1.el5 #1 SMP Thu Jul 1 19:07:06 EDT 2010 i686
Build Date: 13 May 2010
Build ID: xorg-x11-server 1.1.1-48.76.el5_5.1
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 31 10:26:38 2010
(EE) Unable to locate/open config file
New driver is "i810"
(==) Using default built-in configuration (55 lines)

(EE) open /dev/fb0: No such file or directory
(EE) I810(0): Cannot open /dev/mem
(EE) I810(0): VBE initialization failed.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.
 
Old 08-31-2010, 01:42 PM   #7
CincinnatiKid
Member
 
Registered: Jul 2010
Posts: 431

Rep: Reputation: 33
Take a look at this, to see if it applies to your situation: https://www.centos.org/modules/newbb...topic_id=26859
 
Old 08-31-2010, 02:17 PM   #8
cyberblade
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
With that fix now I get the same error as a user as I do as root:

startx
xauth: creating new authority file /home/alex_/.serverauth.2176

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.el5 i686 Red Hat, Inc.
Current Operating System: Linux k2 2.6.18-194.8.1.el5 #1 SMP Thu Jul 1 19:07:06 EDT 2010 i686
Build Date: 13 May 2010
Build ID: xorg-x11-server 1.1.1-48.76.el5_5.1
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 31 11:16:31 2010
(==) Using config file: "/etc/X11/xorg.conf"

(EE) I810(0): Cannot open /dev/mem
(EE) I810(0): VBE initialization failed.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.
Couldnt get a file descriptor referring to the console
 
Old 08-31-2010, 02:44 PM   #9
10110111
Member
 
Registered: Jun 2008
Location: St.-Petersburg, Russia
Distribution: (B)LFS, Ubuntu, SliTaz
Posts: 402

Rep: Reputation: 51
Quote:
(EE) I810(0): Cannot open /dev/mem
(EE) I810(0): VBE initialization failed.
You seem to have incorrect permissions for /dev/mem. Give output of
Code:
ls -l /dev/mem
 
Old 08-31-2010, 03:17 PM   #10
cyberblade
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by 10110111 View Post
You seem to have incorrect permissions for /dev/mem. Give output of
Code:
ls -l /dev/mem
$ ls -l /dev/mem
ls: /dev/mem: No such file or directory
 
Old 08-31-2010, 05:12 PM   #11
CincinnatiKid
Member
 
Registered: Jul 2010
Posts: 431

Rep: Reputation: 33
You can try creating it, not sure if it will work:

Code:
mknod -m 660 /dev/mem c 1 1 
chown root:mem /dev/mem
Sounds like something is seriously wrong with your system.
 
Old 08-31-2010, 06:24 PM   #12
alan99
Member
 
Registered: Mar 2010
Distribution: Debian
Posts: 180

Rep: Reputation: 31
Quote:
Originally Posted by 10110111 View Post
You seem to have incorrect permissions for /dev/mem. Give output of
Code:
ls -l /dev/mem
/dev/mem should only be accessed by the kernel so I wouldn't mess with the permissions of that. It sounds like something 'broke' with the memory management and you can't access the framebuffer.
I don't know what would have caused that. Is there some way to test the memory? As for running X by a non-root user, X has to run as root, but you shouldn't run it from a shell, you should let your init scripts run it.
 
Old 08-31-2010, 06:32 PM   #13
cyberblade
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by lewisforlife View Post
You can try creating it, not sure if it will work:

Code:
mknod -m 660 /dev/mem c 1 1 
chown root:mem /dev/mem
Sounds like something is seriously wrong with your system.
I tried this, I now get:

(EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)
(EE) I810(0): Failed to allocate framebuffer. Is your VideoRAM set too low ??

A bit of googling seems to show that there's an issue with kernel modules?

Everything was working alright this morning, so I'm confused as to what all went haywire.

Is it worth my time to fight with it or am I better off backing up stuff and reinstalling?

If I reinstall it, how do I know that this won't happen again?
 
Old 09-01-2010, 03:18 PM   #14
10110111
Member
 
Registered: Jun 2008
Location: St.-Petersburg, Russia
Distribution: (B)LFS, Ubuntu, SliTaz
Posts: 402

Rep: Reputation: 51
Have you tried rebooting? Usually /dev contents are created on system startup in a tmpfs, so this might help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
start script bash when system start,stop,reeboot, how ?? melmar Linux - General 4 12-10-2009 07:58 AM
when i try to start samba pdc's smb service nmbd failed to start . sandeepchau123 Linux - Newbie 2 10-20-2007 02:59 PM
How to start bash commands automatically every time I start the computer brgsousa Linux - Software 2 10-18-2007 12:26 PM
Computer doesn't start; fans start then stop; 1 long, 1 short beep PatrickMay16 General 18 09-26-2007 08:48 PM
fc2-gnome : Applications dont start / very slow to start nox104 Linux - Software 0 08-18-2004 09:53 PM


All times are GMT -5. The time now is 10:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration