LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-20-2013, 01:19 PM   #1
devnull10
Member
 
Registered: Jan 2010
Location: Lancashire
Distribution: Slackware Stable
Posts: 548

Rep: Reputation: 116Reputation: 116
X suddenly won't start


Hi all, I'm using Slackware 14 and everything has been fine for years however I turn my PC on today and do the usual login, "startx" then... nothing. Just a black screen, freezes and can't do anything - have to restart using the power button. I've not changed anything at all on the machine since last using it (when it worked fine).
Tried reinstalling the NVIDIA driver, regenerating xorg.conf etc, but nothing. Everything works fine on the command line.
Nothing at all shows up in /var/log/Xorg.0.log (nothing is even written to it).

Any ideas?!??
 
Old 07-20-2013, 07:45 PM   #2
devnull10
Member
 
Registered: Jan 2010
Location: Lancashire
Distribution: Slackware Stable
Posts: 548

Original Poster
Rep: Reputation: 116Reputation: 116
Hmmm... after a lot of messing about tonight it seems it was the graphics card!! Strange as it's been working great for several years and with no change. I have taken it, re-enabled the onboard one and all works well. I've lost hardware GL now but that's not too big a worry any more.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg suddenly won't start (EE) ioctl EVIOCGNAME failed kevmccor Slackware 4 09-25-2010 03:39 PM
CentOS Suddenly Won't Update cmnorton Red Hat 3 04-01-2009 11:43 AM
System Suddenly Won't Boot jmdme SUSE / openSUSE 2 05-15-2007 02:49 AM
my hdg suddenly won't mount drummerdan Slackware 4 08-05-2006 01:09 PM
FC1 suddenly won't install Phaethar Fedora - Installation 1 06-25-2005 06:02 PM


All times are GMT -5. The time now is 12:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration