LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-16-2013, 11:03 AM   #1
sysbox
Member
 
Registered: Jul 2005
Posts: 117

Rep: Reputation: 15
X Server rebooting, or logging me out?


Hi. I have newbie question. I recently installed CentOS 6.3 64-bit on my machine. It seems like every 15 or 30 minutes or so, and always while I'm typing on the keyboard, either the system automatically logs me out, or the X server crashes. Either way, I have to log back in, and I lose everything I was working on.

I can't be 100 percent sure what I was doing exactly when this happens, but it seems to involve some combination of Shift or Alt or Ctrl key presses. I did turn of the 'Log Out' in 'Keyboard Shortcuts' which was CTRL+ALT+DELETE, but it still occurs.

Does anyone know why this is occurring? Is this a bug or a feature? Most importantly, how can I turn this off?
 
Old 03-16-2013, 11:41 AM   #2
shivaa
Senior Member
 
Registered: Jul 2012
Location: Grenoble, Fr.
Distribution: Sun Solaris, RHEL, Ubuntu, Debian 6.0
Posts: 1,800
Blog Entries: 4

Rep: Reputation: 286Reputation: 286Reputation: 286
It seems that you press Ctrl + Alt + Backspace key combinations, which actually kills your current X session and returns you to the login screen (see here).

So can you once try this key combination on your running session for testing and check if it's causing the problem. However, one solutions would be to not use this key combinations.
 
Old 03-16-2013, 12:47 PM   #3
sysbox
Member
 
Registered: Jul 2005
Posts: 117

Original Poster
Rep: Reputation: 15
Yes, Ctrl+Alt+Backspace is causing this to happen.

However, I use emacs (which stands for Esc Meta Alt Ctrl Shift) for editing files, and it's difficult not to inadvertently press this every so often.

Can I somehow turn off the Ctrl+Alt+Backspace feature so that it doesn't restart the X server?
 
Old 03-16-2013, 02:33 PM   #4
shivaa
Senior Member
 
Registered: Jul 2012
Location: Grenoble, Fr.
Distribution: Sun Solaris, RHEL, Ubuntu, Debian 6.0
Posts: 1,800
Blog Entries: 4

Rep: Reputation: 286Reputation: 286Reputation: 286
You can do it from, System > Preferences > Keyboard Shortcuts

A keyboard shortcut may be disabled simply by clicking on the shortcut in the Keyboard shortcuts dialog and pressing the Back Space key. The selected shortcut will subsequently display a Disabled status.

(Source: See here)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL5.8 server rebooting on it's own - Why? felbvts Linux - Newbie 5 09-05-2012 04:27 PM
Logging out... But can't get back to GUI without rebooting kasl33 Arch 11 09-17-2011 03:23 PM
Server rebooting sp149 Linux - Newbie 3 08-18-2008 12:29 PM
Logging in and logging out of a server in a script frankie_DJ Linux - Newbie 4 01-28-2007 12:03 AM
X-server rebooting Mr-D Linux - Newbie 13 08-17-2003 03:43 PM


All times are GMT -5. The time now is 04:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration