LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-03-2004, 10:44 AM   #1
bahuguna_n
LQ Newbie
 
Registered: Jul 2003
Location: India
Posts: 8

Rep: Reputation: 0
x server crashes


hi all, i have a strange problem. i was running rh linux 8 well. i switched on to rh linux 9 and tried to start x windows, it gave an error message saying x server crashed. no screens found. there was no problem with gui when i reinstalled rh linux 8. but when i switched on to rh linux9, it was unable to start x windows. i tried it with fedora as well, but the same problem occured.
my processor is amd athelon XP 2000+
video card is S3 Prosavage KM133

i am pasting the file XFree86.0.log. here it goes -


XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-72) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.18-11smp i686 [ELF]
Build Host: daffy.perf.redhat.com

Module Loader present
OS Kernel: Linux version 2.4.20-8 (bhcompile@stripples.devel.redhat.com) (gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)) #1 Thu Mar 13 17:18:24 EST 2003
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Mon May 3 18:58:11 2004
(==) Using config file: "/etc/X11/XF86Config"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Videocard0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "DevInputMice"
(**) FontPath set to "unix/:7100"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.5
XFree86 XInput driver : 0.3
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.3
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,3116 card 1106,3116 rev 00 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1106,b091 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:11:0: chip 1106,3177 card 1106,3177 rev 00 class 06,01,00 hdr 80
(II) PCI: 00:11:1: chip 1106,0571 card 1462,3901 rev 06 class 01,01,8a hdr 00
(II) PCI: 00:11:5: chip 1106,3059 card 1462,3901 rev 50 class 04,01,00 hdr 00
(II) PCI: 01:00:0: chip 5333,8d04 card 1462,3908 rev 00 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0c (VGA_EN is set)
(II) Bus 1 I/O range:
(II) Bus 1 non-prefetchable memory range:
[0] -1 0xe0000000 - 0xe1ffffff (0x2000000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0xd8000000 - 0xdfffffff (0x8000000) MX[B]
(II) Bus -1: bridge is at (0:17:0), (0,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:0:0) S3 unknown chipset (0x8d04) rev 0, Mem @ 0xe1000000/19, 0xd8000000/27
(II) Addressable bus resource ranges are
[0] -1 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0x00000000 - 0x000000ff (0x100) IX[B]
(II) Active PCI resource ranges:
[0] -1 0xd0000000 - 0xd7ffffff (0x8000000) MX[B]
[1] -1 0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
[2] -1 0xe1000000 - 0xe107ffff (0x80000) MX[B](B)
[3] -1 0x0000b000 - 0x0000b0ff (0x100) IX[B]
[4] -1 0x0000ac00 - 0x0000ac0f (0x10) IX[B]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0xd0000000 - 0xd7ffffff (0x8000000) MX[B]
[1] -1 0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
[2] -1 0xe1000000 - 0xe107ffff (0x80000) MX[B](B)
[3] -1 0x0000b000 - 0x0000b0ff (0x100) IX[B]
[4] -1 0x0000ac00 - 0x0000ac0f (0x10) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0xd0000000 - 0xd7ffffff (0x8000000) MX[B]
[6] -1 0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
[7] -1 0xe1000000 - 0xe107ffff (0x80000) MX[B](B)
[8] -1 0x0000ffff - 0x0000ffff (0x1) IX[B]
[9] -1 0x00000000 - 0x000000ff (0x100) IX[B]
[10] -1 0x0000b000 - 0x0000b0ff (0x100) IX[B]
[11] -1 0x0000ac00 - 0x0000ac0f (0x10) IX[B]
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "fbdevhw"
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.0.2
ABI class: XFree86 Video Driver, version 0.5
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension RECORD
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.1.10
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font FreeType
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.1
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "savage"
(II) Loading /usr/X11R6/lib/modules/drivers/savage_drv.o
(II) Module savage: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.1.20
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.5
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.3
(II) SAVAGE: driver (version 1.1.20) for S3 Savage chipsets: Savage4,
Savage3D, Savage3D-MV, Savage2000, Savage/MX-MV, Savage/MX,
Savage/IX-MV, Savage/IX, ProSavage PM133, ProSavage KM133,
ProSavage PN133, ProSavage KN133, SuperSavage/MX 128,
SuperSavage/MX 64, SuperSavage/MX 64C, SuperSavage/IX 128,
SuperSavage/IX 128, SuperSavage/IX 64, SuperSavage/IX 64,
SuperSavage/IXC 64, SuperSavage/IXC 64
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.



thanks in advance
NIshchaya Bahuguna
Bangalore, India
 
Old 05-04-2004, 07:17 AM   #2
bahuguna_n
LQ Newbie
 
Registered: Jul 2003
Location: India
Posts: 8

Original Poster
Rep: Reputation: 0
Angry nobody's replying, x server problem

it seems people are busy fixing their own problems. i posted this problem earlier and waited and waited and ......

i was running rh linux 8 well. i switched on to rh linux 9 and tried to start x windows, it gave an error message saying x server crashed. no screens found. there was no problem with gui when i reinstalled rh linux 8. but when i switched on to rh linux9, it was unable to start x windows. i tried it with fedora as well, but the same problem occured.
my processor is amd athelon XP 2000+
video card is S3 Prosavage KM133

i am pasting the file XFree86.0.log. here it goes -


XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-72) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.18-11smp i686 [ELF]
Build Host: daffy.perf.redhat.com

Module Loader present
OS Kernel: Linux version 2.4.20-8 (bhcompile@stripples.devel.redhat.com) (gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)) #1 Thu Mar 13 17:18:24 EST 2003
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Mon May 3 18:58:11 2004
(==) Using config file: "/etc/X11/XF86Config"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Videocard0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "DevInputMice"
(**) FontPath set to "unix/:7100"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.5
XFree86 XInput driver : 0.3
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.3
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,3116 card 1106,3116 rev 00 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1106,b091 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:11:0: chip 1106,3177 card 1106,3177 rev 00 class 06,01,00 hdr 80
(II) PCI: 00:11:1: chip 1106,0571 card 1462,3901 rev 06 class 01,01,8a hdr 00
(II) PCI: 00:11:5: chip 1106,3059 card 1462,3901 rev 50 class 04,01,00 hdr 00
(II) PCI: 01:00:0: chip 5333,8d04 card 1462,3908 rev 00 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0c (VGA_EN is set)
(II) Bus 1 I/O range:
(II) Bus 1 non-prefetchable memory range:
[0] -1 0xe0000000 - 0xe1ffffff (0x2000000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0xd8000000 - 0xdfffffff (0x8000000) MX[B]
(II) Bus -1: bridge is at (0:17:0), (0,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:0:0) S3 unknown chipset (0x8d04) rev 0, Mem @ 0xe1000000/19, 0xd8000000/27
(II) Addressable bus resource ranges are
[0] -1 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0x00000000 - 0x000000ff (0x100) IX[B]
(II) Active PCI resource ranges:
[0] -1 0xd0000000 - 0xd7ffffff (0x8000000) MX[B]
[1] -1 0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
[2] -1 0xe1000000 - 0xe107ffff (0x80000) MX[B](B)
[3] -1 0x0000b000 - 0x0000b0ff (0x100) IX[B]
[4] -1 0x0000ac00 - 0x0000ac0f (0x10) IX[B]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0xd0000000 - 0xd7ffffff (0x8000000) MX[B]
[1] -1 0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
[2] -1 0xe1000000 - 0xe107ffff (0x80000) MX[B](B)
[3] -1 0x0000b000 - 0x0000b0ff (0x100) IX[B]
[4] -1 0x0000ac00 - 0x0000ac0f (0x10) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0xd0000000 - 0xd7ffffff (0x8000000) MX[B]
[6] -1 0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
[7] -1 0xe1000000 - 0xe107ffff (0x80000) MX[B](B)
[8] -1 0x0000ffff - 0x0000ffff (0x1) IX[B]
[9] -1 0x00000000 - 0x000000ff (0x100) IX[B]
[10] -1 0x0000b000 - 0x0000b0ff (0x100) IX[B]
[11] -1 0x0000ac00 - 0x0000ac0f (0x10) IX[B]
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "fbdevhw"
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.0.2
ABI class: XFree86 Video Driver, version 0.5
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension RECORD
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.1.10
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font FreeType
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.1
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "savage"
(II) Loading /usr/X11R6/lib/modules/drivers/savage_drv.o
(II) Module savage: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.1.20
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.5
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.3
(II) SAVAGE: driver (version 1.1.20) for S3 Savage chipsets: Savage4,
Savage3D, Savage3D-MV, Savage2000, Savage/MX-MV, Savage/MX,
Savage/IX-MV, Savage/IX, ProSavage PM133, ProSavage KM133,
ProSavage PN133, ProSavage KN133, SuperSavage/MX 128,
SuperSavage/MX 64, SuperSavage/MX 64C, SuperSavage/IX 128,
SuperSavage/IX 128, SuperSavage/IX 64, SuperSavage/IX 64,
SuperSavage/IXC 64, SuperSavage/IXC 64
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.


finally, i reinstalled rh 8 and x worked fine and again UPGRADED THE KERNEL only AND DIDN'T DO ANYTHING WITH X, STILL UNABLE TO FIX IT.

what could be the problem??

Nishchaya Bahuguna
Bangalore, India
 
Old 05-04-2004, 07:45 AM   #3
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Rep: Reputation: 30
Posted where ?? waited for how long ??

Anyways,
Upgrade your kernel with an precompiled image? or you made acustom kernel?
If was a custom kernel are you sure you included your vid card support in the kernel?
Did you compiled the drivers for your card agains the new kernel?

Try configuring your xserver using the 'vesa' driver for now untill you narrow the problem.

Hint: The xserver is not recognizing your vid card.
 
Old 05-04-2004, 11:03 AM   #4
Grymme
Member
 
Registered: Apr 2004
Location: Sweden
Distribution: Slackware
Posts: 44

Rep: Reputation: 15
There are lots of threads about the s3 prosavage already it seems (my search on your card generated 99 threads). Have you looked in there?

I don't know how to solve it but that's at least a pointer to where you can find a possible solution.
 
Old 05-05-2004, 10:33 AM   #5
bahuguna_n
LQ Newbie
 
Registered: Jul 2003
Location: India
Posts: 8

Original Poster
Rep: Reputation: 0
yeah, i tried both options, custom upgradation as well as with a precompiled image. i reported this problem to xfree86 as well and they suggested me to switch on to xfree86 4.4 instead of 4.2

do i have any other options??
 
Old 05-05-2004, 02:03 PM   #6
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
You will notice that I have merged your 2 threads.

Please do not double post, it is against the Rules you agreed to when you signed up to LQ.

If you feel your thread isn't getting the attention it deserves, etiquette and protocol say that you should wait for 24 hours and then reply to your own post with any more information: such as what you have tried in the meantime.
 
Old 06-01-2004, 11:01 PM   #7
csantos67
LQ Newbie
 
Registered: May 2004
Location: Wyoming
Distribution: Mint, Debian, PCLOS, CentOS
Posts: 6

Rep: Reputation: 0
Hi,

I'm getting the same problem on my 4th fresh install of Debian 'testing' ( I know I know its testing) this machine has a SIS630 video chipset (I don't have all the output, I rebooted using a knoppix CD ) its one of those integrated shared memory jobs ( I know they suck, but knoppix 3.4 works fine :-p ) so anyway the output of agpgart says "maximum video ram avauilable 232 MB"
this is news to me as there is only 256MB+64MB in the system, and the max BIOS option for video ram is 128MB
I'm still using the default 24.x kernel could this do it? I haven't tried vesa yet, although I have used xf86config a few times
... anyone have any ideas?

thanks in advance!
 
Old 06-02-2004, 12:04 AM   #8
csantos67
LQ Newbie
 
Registered: May 2004
Location: Wyoming
Distribution: Mint, Debian, PCLOS, CentOS
Posts: 6

Rep: Reputation: 0
Lightbulb found *an* answer

Hi All,

after reading yet more threads on this error, I rebooted into my debian install, and tried a few things ....

I used xf86config .. only to learn that is saves its settings in XF86Config , and GDM, XDM, and KDM are looking for XF86Config-4 .. hmmm I wonder if I should report that as a bug? (this is testing, and I am new to Debian)

ALSO I did apt-get install x-window-system and it got some packages

THEN I did pico XF86Config-4 (yap, and old Slakware/pine geek), and found (as someone suggested, THANKS!) that is was looking at bus 0:1:0 so I changed this to 1:0:0

then startx brings up the KDE configuration wizard ... so now thanks to all kinds of people posting all kinds of things to look for my little franken computer lives

THANKS!!!

BTW: speaking of things to report for the Debian testing ... I used the tasksel and had it install a GUI ... the result was a seemingly incomplete GUI install, and that error ?
so I guess I'll mosey on over and see if its reportable
 
Old 06-02-2004, 11:10 PM   #9
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Rep: Reputation: 30
Quote:
I used xf86config .. only to learn that is saves its settings in XF86Config , and GDM, XDM, and KDM are looking for XF86Config-4 .. hmmm I wonder if I should report that as a bug? (this is testing, and I am new to Debian)
No bug there. You just failed to read the messeges presented to you during the install of XFree86.

Each time you install such package, you are warned about the fact. The NEW version of XFree86 will use the file XF86Config-4. The old config file is kept for backwards compatibility reasons. You can find more detailed information about this in the Xfree86 documentation or in their website.
 
Old 10-01-2004, 03:49 AM   #10
GustavoRuiz
LQ Newbie
 
Registered: Oct 2004
Posts: 4

Rep: Reputation: 0
A lot of people (including me) were having the same problem... RedHat9 + ProSavage
There is a poorly documented option, named UseBIOS. This option that enables or disables the video BIOS of the ProSavage video card... If you disabled it, the X-Windows work!

Example of my XF86Config with option UseBIOS disabled:

Section "Device"
Identifier "Videocard0"
Driver "savage"
VendorName "Videocard vendor"
BoardName "S3 ProSavage KM133"
Option "UseBIOS" "no"
EndSection

More info: http://www.die.net/doc/linux/man/man4/savage.4.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X-Server Crashes tiredoflogins Linux - Software 4 10-26-2004 03:01 PM
X Server Crashes Alfanut Mandriva 2 12-28-2003 03:34 PM
X server crashes lasalsademuerte Slackware 3 12-15-2003 07:49 PM
Redhat 9 x server crashes joenjeru Linux - Hardware 3 11-03-2003 01:02 PM
x server crashes jayakrishnan Linux - General 1 01-08-2003 08:41 AM


All times are GMT -5. The time now is 05:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration