LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-28-2004, 08:24 PM   #1
m00mba
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware 10
Posts: 12

Rep: Reputation: 0
Unhappy X.org problem in Slackware 10


Hey, im sorta a linux noob and i just installed Slackware 10 for a dual boot with XP.
So far i have had no probs until after i tried installing Enemy Territory which didnt work. (ut2k4 works fine) Now whenever i shutdown the X server i am left with a big black screen with little colored dots which im assuming is a huge blowup of the text which should be the console. I can still type "startx" and get X.org back up but this means i am either in X or seeing nothing in console. Any help would be very appreciated.
 
Old 08-28-2004, 09:14 PM   #2
Dialore
Member
 
Registered: Aug 2004
Location: Toronto, Canada
Distribution: Debian, Mandrake, Fedora
Posts: 38

Rep: Reputation: 15
Looks like you have a framebuffer driver installed. Try to find it and remove. There are also kernel boot parameters that disable it (can't help you here, sorry.)
 
Old 08-29-2004, 09:45 AM   #3
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
try passing in 'vga=normal' at the boot line (if you are using LILO -- can't remember exactly what the command is for GRUB). This would override any framebuffer settings and boot you up in 80x25 resolution
 
Old 08-29-2004, 09:57 AM   #4
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
if you use grub...

as root user, open the file /boot/grub/menu.lst

you will see a line (or maybe more) that look like....
" kernel /boot/vmlinuz root=/dev/hda2 ro vga=???"

if it has the option vga= on the line, then remove it... this will turn off vga.
 
Old 08-30-2004, 01:24 AM   #5
m00mba
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware 10
Posts: 12

Original Poster
Rep: Reputation: 0
I am pretty sure this has something to do with the nvidia driver. I use a frame buffer for the boot which works. It isnt until after i am in X with the nvidia driver that i am unable to leave X without seeing messed up stuff.
 
Old 08-30-2004, 07:18 AM   #6
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
some framebuffer drivers conflict with nvidia's driver.... (did you get that warning in the logs ? whilst installing)

i think you must use the generig frame buffer driver in the kernel, Not the nvidia framebufffer kernel.

anyways.......
dont just ignore the advice you got so far...
the results will greatly help diagnose the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.1 - XFree86 or X.org? Vgui Slackware 3 07-29-2005 05:05 PM
Slackware book purchase vs. URL: http://www.slackware.org/book/ jtp51 Slackware 5 11-28-2004 05:30 PM
Slackware 9.1 and X.org X11R6.8 drspangle Slackware 5 09-06-2004 11:50 PM
freedesktop.org on slackware uglyugly Slackware 3 02-18-2004 04:54 AM
slackware-live.org Anibal Slackware 2 08-25-2003 11:55 AM


All times are GMT -5. The time now is 08:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration