LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-04-2011, 08:04 AM   #1
taespark
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Rep: Reputation: Disabled
"x" key does not work on xterm


Hi,

It used to work. I had no problem typing the letter "x" on my xterm. But starting yesterday, pressing "x" key does not print anything on xterm. I first thought it was bad keyboard, so I replaced with a new one, but the problem still exists. Strangely, the "x" key works if I am in the vi editor or su to root. So, my guess is I have accidentally set the "x" key to do something in xterm, but I do not know how to reset it. I tried the "reset" command, but that does not work. Any suggestion? thank you so much !

Last edited by taespark; 07-04-2011 at 10:10 AM.
 
Old 07-04-2011, 12:28 PM   #2
taespark
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Ahh!! problem solved

I had put the following line in .inputrc file

xset b off

thinking that was to turn off the beep in xterm

But that line caused the "x" key to not work in xterm. When I removed the line, the problem went away

Cheers!
 
Old 07-04-2011, 12:41 PM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Thanks for posting back your solution. Please mark your thread as solved using the thread tools on top of the thread.
 
Old 07-05-2011, 04:20 AM   #4
tommyttt
Member
 
Registered: Oct 2009
Location: Federal Way, WA
Distribution: openSUSE 11.4 x86_64, openSuSE 12.1, Fedora 15
Posts: 207

Rep: Reputation: 34
Quote:
Originally Posted by taespark View Post
Ahh!! problem solved

I had put the following line in .inputrc file

xset b off

thinking that was to turn off the beep in xterm

But that line caused the "x" key to not work in xterm. When I removed the line, the problem went away

Cheers!
So, did you figure out how to turn the beep off? If you're using KDE 4+ desktop, go to Start > Configure Desktop > Applications & System Notifications > Manage Notifications > Player Settings and click the "no audio output" button.

Tom
 
Old 07-05-2011, 06:03 AM   #5
taespark
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
Thanks for posting back your solution. Please mark your thread as solved using the thread tools on top of the thread.
yes, done
 
Old 07-05-2011, 06:05 AM   #6
taespark
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by tommyttt View Post
So, did you figure out how to turn the beep off? If you're using KDE 4+ desktop, go to Start > Configure Desktop > Applications & System Notifications > Manage Notifications > Player Settings and click the "no audio output" button.

Tom
Thanks for the suggestion.
Yes, I did turn it off using the method in this URL

http://www.cyberciti.biz/faq/how-to-...-for-terminal/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] "Insert" & "Delete" key returns "~" in a terminal. sharky Linux - General 15 04-26-2011 09:36 AM
"sudo su - someuser -c xterm" doesn't work kenneho Linux - Newbie 1 10-02-2009 09:08 AM
"Enter Key" not working, how to map "Enter Key" functionality to "F9" Key srinihi Linux - Newbie 1 04-03-2009 03:46 PM
PS2 keyboard doesn't work after the "Enter" key is used gonefishing SUSE / openSUSE 1 11-06-2004 11:02 PM
The program Screen, "delete" key doesn't work TroelsSmit Linux - Newbie 0 10-13-2004 08:55 AM


All times are GMT -5. The time now is 02:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration