LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-19-2004, 11:49 AM   #1
mfeoli
Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 92

Rep: Reputation: 15
X is not loading, How to solve it


Hi all,

Here we go again,

I was trying to change mouse from serial to ps2 with SAX, and now the graphical interfase wont start.

Where shall I start to solve this?


thanx
 
Old 01-19-2004, 12:35 PM   #2
alar
Member
 
Registered: Sep 2003
Location: Canada
Distribution: CentOS 5.5, Ubuntu 10.04, Linux Mint 11 gnome 64 bit
Posts: 336

Rep: Reputation: 36
What happens when you type startx?
 
Old 01-19-2004, 01:24 PM   #3
mfeoli
Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 92

Original Poster
Rep: Reputation: 15
Shows this

XFree86 Version 4.0.2 / X Window System
(protocol Version 11, revision 0, vendor release 6400)
Release Date: 18 December 2000
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/FAQ)
Operating System: SuSE Linux [ELF] SuSE
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Jan 19 11:55:07 2004
(==) Using config file: "/etc/X11/XF86Config"
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (??) unknown.
(==) ServerLayout "Layout[all]"
(**) |-->Screen "Screen[fbdev]" (0)
(**) | |-->Monitor "Monitor[0]"
(**) | |-->Device "Device[fbdev]"
(**) |-->Input Device "Keyboard[0]"
(**) XKB: keycodes: "xfree86"
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc104"
(**) XKB: layout: "de"
(**) XKB: variant: "nodeadkeys"
(**) |-->Input Device "Mouse[0]"
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/uni/,/usr/X11R6/lib/X11/fonts/misc/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(**) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 0.1.0
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 0.1.0
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(--) PCI:*(1:0:0) S3 Trio3D/2X rev 2, Mem @ 0xe0000000/26
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/drivers/fbdev_drv.o
(II) Module fbdev: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 0.1.0
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 1.0.0
(II) FBDev: driver for framebuffer: fbdev, afb
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 0.0.2
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to feedback@suse.de.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.
 
Old 01-19-2004, 01:42 PM   #4
mfeoli
Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 92

Original Poster
Rep: Reputation: 15
if you wonder what's in XFree86.0.log

XFree86 Version 4.0.2 / X Window System
(protocol Version 11, revision 0, vendor release 6400)
Release Date: 18 December 2000
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/FAQ)
Operating System: SuSE Linux [ELF] SuSE
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Jan 19 12:31:36 2004
(==) Using config file: "/etc/X11/XF86Config"
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (??) unknown.
(==) ServerLayout "Layout[all]"
(**) |-->Screen "Screen[fbdev]" (0)
(**) | |-->Monitor "Monitor[0]"
(**) | |-->Device "Device[fbdev]"
(**) |-->Input Device "Keyboard[0]"
(**) Option "Protocol" "Standard"
(**) Option "XkbKeycodes" "xfree86"
(**) XKB: keycodes: "xfree86"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "de"
(**) XKB: layout: "de"
(**) Option "XkbVariant" "nodeadkeys"
(**) XKB: variant: "nodeadkeys"
(**) |-->Input Device "Mouse[0]"
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/uni/,/usr/X11R6/lib/X11/fonts/misc/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(**) ModulePath set to "/usr/X11R6/lib/modules"
(**) Option "AllowMouseOpenFail"
(**) Option "BlankTime" "0"
(**) Option "Xinerama" "off"
(++) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.3
XFree86 XInput driver : 0.1
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.2
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.3
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x80000058, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,7190 card 0000,0000 rev 03 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,7191 card 0000,0000 rev 03 class 06,04,00 hdr 01
(II) PCI: 00:07:0: chip 8086,7110 card 0000,0000 rev 02 class 06,01,00 hdr 80
(II) PCI: 00:07:1: chip 8086,7111 card 0000,0000 rev 01 class 01,01,80 hdr 00
(II) PCI: 00:07:2: chip 8086,7112 card 0000,0000 rev 01 class 0c,03,00 hdr 00
(II) PCI: 00:07:3: chip 8086,7113 card 0000,0000 rev 02 class 06,80,00 hdr 00
(II) PCI: 00:09:0: chip 10ec,8029 card 10ec,8029 rev 00 class 02,00,00 hdr 00
(II) PCI: 00:0b:0: chip 1274,5880 card 1274,2003 rev 02 class 04,01,00 hdr 00
(II) PCI: 00:0c:0: chip 10b5,9050 card 12c7,0529 rev 02 class 06,80,00 hdr 00
(II) PCI: 01:00:0: chip 5333,8a13 card 5333,8a13 rev 02 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.3
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x00 (VGA_EN is cleared)
(II) Bus 0 I/O range:
[0] -1 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x88 (VGA_EN is set)
(II) Bus 1 I/O range:
[0] -1 0x0000d000 - 0x0000dfff (0x1000) IX[B]
(II) Bus 1 non-prefetchable memory range:
[0] -1 0xe0000000 - 0xe7ffffff (0x8000000) MX[B]
(II) Bus 1 prefetchable memory range:
(II) Bus -1: bridge is at (0:7:0), (0,-1,0), BCTRL: 0x00 (VGA_EN is cleared)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:0:0) S3 Trio3D/2X rev 2, Mem @ 0xe0000000/26
(II) Addressable bus resource ranges are
[0] -1 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0x00000000 - 0x000001ff (0x200) IX[B]E
(II) Active PCI resource ranges:
[0] -1 0xec000000 - 0xec001fff (0x2000) MX[B]
[1] -1 0xec002000 - 0xec00207f (0x80) MX[B]
[2] -1 0xe8000000 - 0xebffffff (0x4000000) MX[B]
[3] -1 0xe0000000 - 0xe3ffffff (0x4000000) MX[B](B)
[4] -1 0x0000ec00 - 0x0000ec7f (0x80) IX[B]
[5] -1 0x0000e800 - 0x0000e83f (0x40) IX[B]
[6] -1 0x0000e400 - 0x0000e41f (0x20) IX[B]
[7] -1 0x0000e000 - 0x0000e01f (0x20) IX[B]
[8] -1 0x0000f000 - 0x0000f00f (0x10) IX[B]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0xec000000 - 0xec001fff (0x2000) MX[B]
[1] -1 0xec002000 - 0xec00207f (0x80) MX[B]
[2] -1 0xe8000000 - 0xebffffff (0x4000000) MX[B]
[3] -1 0xe0000000 - 0xe3ffffff (0x4000000) MX[B](B)
[4] -1 0x0000ec00 - 0x0000ec7f (0x80) IX[B]
[5] -1 0x0000e800 - 0x0000e83f (0x40) IX[B]
[6] -1 0x0000e400 - 0x0000e41f (0x20) IX[B]
[7] -1 0x0000e000 - 0x0000e01f (0x20) IX[B]
[8] -1 0x0000f000 - 0x0000f00f (0x10) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0x00000000 - 0x000001ff (0x200) IX[B]E
(II) All system resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0xec000000 - 0xec001fff (0x2000) MX[B]
[6] -1 0xec002000 - 0xec00207f (0x80) MX[B]
[7] -1 0xe8000000 - 0xebffffff (0x4000000) MX[B]
[8] -1 0xe0000000 - 0xe3ffffff (0x4000000) MX[B](B)
[9] -1 0x00000000 - 0x000001ff (0x200) IX[B]E
[10] -1 0x0000ec00 - 0x0000ec7f (0x80) IX[B]
[11] -1 0x0000e800 - 0x0000e83f (0x40) IX[B]
[12] -1 0x0000e400 - 0x0000e41f (0x20) IX[B]
[13] -1 0x0000e000 - 0x0000e01f (0x20) IX[B]
[14] -1 0x0000f000 - 0x0000f00f (0x10) IX[B]
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) LoadModule: "fbdev"
(II) Loading /usr/X11R6/lib/modules/drivers/fbdev_drv.o
(II) Module fbdev: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.3
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.1
(II) FBDev: driver for framebuffer: fbdev, afb
(II) Primary Device is: PCI 01:00:0
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 0.0.2
ABI class: XFree86 Video Driver, version 0.3
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to feedback@suse.de.
 
Old 01-19-2004, 04:06 PM   #5
mfeoli
Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 92

Original Poster
Rep: Reputation: 15
Has anyone got a clue on where to go from here,? I'm really stocked here.
 
Old 01-19-2004, 05:59 PM   #6
WH16
LQ Newbie
 
Registered: Jan 2004
Location: NC
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
I'm copying this info from elsewheres:

"XFree86 4.x utility called xf86cfg.
However, i would recommend that you use
# XFree86 -configure
this will create a file called /root/XF86Config.new
After that try starting X with the following command
# XFree86 -xf86config XF86Config.new
If everything looks fine copy /root/XF86Config.new to
/etc/X11/XF86Config-4 (which is a correct name for X 4.x config file)"

Try running a new config to see if that alieviates the problem. If it does, just switch to the new config file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I need help to solve this problem TheTiger Fedora 1 10-26-2005 02:01 PM
xawtv: does anybody know how to solve this ? Deep-Blue-ro Linux - Newbie 2 11-13-2004 05:15 PM
Who can help me to solve this problem? Annie0716 Programming 2 08-09-2004 08:59 PM
Finding Module Dependencies...(Still loading...still loading..still loading..HANG!!!) Aeudian Linux - General 3 08-11-2003 04:31 PM
Finding Module Dependencies.....(still loading....Still loading....still loading) Aeudian Linux - Newbie 1 07-28-2003 03:27 PM


All times are GMT -5. The time now is 01:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration