LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   X dead after upgrade to Fedora Core 11 (http://www.linuxquestions.org/questions/linux-newbie-8/x-dead-after-upgrade-to-fedora-core-11-a-743368/)

lulatsch 07-28-2009 08:11 AM

X dead after upgrade to Fedora Core 11
 
I had Fedora Core 10. I used preupgrade to upgrade to FC11.

Now my x is dead.

Here are the contents of my xorg.conf
Code:

# Xorg configuration created by livna-config-display

Section "ServerLayout"
        Identifier    "Default Layout"
        Screen      0  "Screen0" 0 0
EndSection

Section "Files"
        ModulePath  "/usr/lib/xorg/modules/extensions/fglrx"
        ModulePath  "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
        Option            "AIGLX" "on"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "fglrx"
        Option            "OpenGLOverlay" "off"
        Option            "VideoOverlay" "on"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        DefaultDepth    24
EndSection

Section "Extensions"
        Option            "Composite" "Enable"
EndSection


And here are the contents of /var/log/Xorg.0.log
Code:



X.Org X Server 1.6.1.901 (1.6.2 RC 1)
Release Date: 2009-5-8
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-128.1.6.el5 i686
Current Operating System: Linux lucille 2.6.29.6-213.fc11.i586 #1 SMP Tue Jul 7 20:45:17 EDT 2009 i686
Kernel command line: ro root=/dev/VolGroup00/LogVol00 rhgb quiet
Build Date: 18 May 2009  02:47:59PM
Build ID: xorg-x11-server 1.6.1.901-1.fc11
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jul 28 14:59:01 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen0" (0)
(**) |  |-->Monitor "<default monitor>"
(**) |  |-->Device "Videocard0"
(==) No monitor specified for screen "Screen0".
        Using a default monitor configuration.
(**) Option "AIGLX" "on"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
        catalogue:/etc/X11/fontpath.d,
        built-ins
(**) ModulePath set to "/usr/lib/xorg/modules/extensions/fglrx,/usr/lib/xorg/modules"
(**) Extension "Composite" is enabled
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
        If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Loader magic: 0x640
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 5.0
        X.Org XInput driver : 4.0
        X.Org Server Extension : 2.0
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0@1:0:0) ATI Technologies Inc RV570 [Radeon X1950 Pro] rev 154, Mem @ 0xe0000000/268435456, 0xf3000000/65536, I/O @ 0x00009000/256, BIOS @ 0x????????/131072
(II) No APM support in BIOS or kernel
(II) System resource ranges:
        [0] -1        0        0xffffffff - 0xffffffff (0x1) MX[B]
        [1] -1        0        0x000f0000 - 0x000fffff (0x10000) MX[B]
        [2] -1        0        0x000c0000 - 0x000effff (0x30000) MX[B]
        [3] -1        0        0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [4] -1        0        0xffffffff - 0xffffffff (0x1) MX[B]
        [5] -1        0        0x000f0000 - 0x000fffff (0x10000) MX[B]
        [6] -1        0        0x000c0000 - 0x000effff (0x30000) MX[B]
        [7] -1        0        0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [8] -1        0        0xffffffff - 0xffffffff (0x1) MX[B]
        [9] -1        0        0x000f0000 - 0x000fffff (0x10000) MX[B]
        [10] -1        0        0x000c0000 - 0x000effff (0x30000) MX[B]
        [11] -1        0        0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [12] -1        0        0xffffffff - 0xffffffff (0x1) MX[B]
        [13] -1        0        0x000f0000 - 0x000fffff (0x10000) MX[B]
        [14] -1        0        0x000c0000 - 0x000effff (0x30000) MX[B]
        [15] -1        0        0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [16] -1        0        0xffffffff - 0xffffffff (0x1) MX[B]
        [17] -1        0        0x000f0000 - 0x000fffff (0x10000) MX[B]
        [18] -1        0        0x000c0000 - 0x000effff (0x30000) MX[B]
        [19] -1        0        0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [20] -1        0        0x0000ffff - 0x0000ffff (0x1) IX[B]
        [21] -1        0        0x00000000 - 0x00000000 (0x1) IX[B]
        [22] -1        0        0x0000ffff - 0x0000ffff (0x1) IX[B]
        [23] -1        0        0x00000000 - 0x00000000 (0x1) IX[B]
        [24] -1        0        0x0000ffff - 0x0000ffff (0x1) IX[B]
        [25] -1        0        0x00000000 - 0x00000000 (0x1) IX[B]
        [26] -1        0        0x0000ffff - 0x0000ffff (0x1) IX[B]
        [27] -1        0        0x00000000 - 0x00000000 (0x1) IX[B]
        [28] -1        0        0x0000ffff - 0x0000ffff (0x1) IX[B]
        [29] -1        0        0x00000000 - 0x00000000 (0x1) IX[B]
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
        compiled for 1.6.1.901, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
        compiled for 1.6.1.901, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/fglrx//libglx.so
dlopen: /usr/lib/xorg/modules/extensions/fglrx//libglx.so: undefined symbol: miInitVisualsProc
(EE) Failed to load /usr/lib/xorg/modules/extensions/fglrx//libglx.so
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (loader failed, 7)
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
        compiled for 1.6.1.901, module version = 1.13.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/fglrx//libdri.so
(II) Module dri: vendor="X.Org Foundation"
        compiled for 7.4.0, module version = 1.0.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
        compiled for 1.6.1.901, module version = 1.0.0
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for 1.4.99.906, module version = 8.59.2
        Module class: X.Org Video Driver
[atiddxSetup] X version mismatch - detected X.org 7.1.1.901, required X.org 7.4.-1.906
(II) UnloadModule: "fglrx"
(II) Unloading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
        at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Please help :-(

amani 07-28-2009 10:12 AM

fglrx is unlikely to work properly in Fedora 11

boot into runlevel 3 (append runlevel 3 to kernel line before boot)

login as root

Uninstall all fglrx related packages with yum or rpm


If you installed fglrx directly, then the uninstall script is in /usr/share/ati

Use driver radeon

baig 07-28-2009 10:32 AM

Hi,

Its not Fedora Core 11... its only Fedora 11 now :)

Core was till 8. from 9 onwards its not core any more.

Cheers!

lulatsch 07-30-2009 06:53 AM

Quote:

Originally Posted by amani (Post 3623051)
fglrx is unlikely to work properly in Fedora 11

boot into runlevel 3 (append runlevel 3 to kernel line before boot)

login as root

Uninstall all fglrx related packages with yum or rpm


If you installed fglrx directly, then the uninstall script is in /usr/share/ati

Use driver radeon

How do I install the Radeon driver?

PTrenholme 07-30-2009 07:26 AM

You don't - it's part of the X package.

In fact, all you need to do is replace fglrx with radeon in your xorg.conf file and reboot X. (Note that ctrl-alt-backspace will not reboot X unless you change the DontZap option to true in the ServerFlags section of xorg.conf. (See the F11 release notes for details. The change to the default DontZap setting was made by the X-server people, not Red Hat.))

lulatsch 08-03-2009 04:16 PM

Quote:

Originally Posted by PTrenholme (Post 3625383)
You don't - it's part of the X package.

In fact, all you need to do is replace fglrx with radeon in your xorg.conf file and reboot X. (Note that ctrl-alt-backspace will not reboot X unless you change the DontZap option to true in the ServerFlags section of xorg.conf. (See the F11 release notes for details. The change to the default DontZap setting was made by the X-server people, not Red Hat.))

Thankyou, this worked perfectly.


All times are GMT -5. The time now is 07:53 PM.